Package Details: wireshark-gtk2 2.6.20-1

Git Clone URL: https://aur.archlinux.org/wireshark-gtk2.git (read-only, click to copy)
Package Base: wireshark-gtk2
Description: a free network protocol analyzer for Unix/Linux and Windows - GTK2 frontend
Upstream URL: http://www.wireshark.org/
Licenses: GPL2
Conflicts: wireshark-cli, wireshark-common, wireshark-qt
Provides: wireshark-cli, wireshark-gtk
Submitter: ipha
Maintainer: bidulock
Last Packager: bidulock
Votes: 19
Popularity: 0.48
First Submitted: 2013-06-13 23:48
Last Updated: 2020-11-13 12:41

Required by (26)

Sources (3)

Latest Comments

1 2 3 Next › Last »

tywyqu commented on 2021-03-11 14:29

checking for pod2man... /usr/sbin/pod2man
checking for pod2html... no
configure: error: I couldn't find pod2html; make sure it's installed and in your path
==> ERROR: A failure occurred in build().
    Aborting...
error making: wireshark-gtk2

/usr/bin/core_perl/cpan install Pod::Html

bidulock commented on 2020-11-13 12:42

Source URL updated.

The 2.6 series is the last to support GTK2, so moving to 3.4.0 would defeat the purpose of a GTK2 package.

Chiggins commented on 2020-11-05 17:33

==> ERROR: Failure while downloading https://www.wireshark.org/download/src/wireshark-2.6.20.tar.xz

Should this start getting updated to 3.4.0?

optize commented on 2020-06-26 07:11

You can edit PKGBUILD and change version to 2.6.17, according to: https://www.wireshark.org/download/src/wireshark-2.6.17.tar.xz

mpranjic commented on 2020-01-16 11:42

The file https://www.wireshark.org/download/src/wireshark-2.6.13.tar.xz returns HTTP 404.

madscience commented on 2019-08-06 10:05

I just tested and it does build in a clean chroot. Not sure why gcc is complaining.

EDIT: I moved a mount point and it f**ked up my ccache dir. Sorry to trouble you.

bidulock commented on 2019-08-06 09:20

Sorry, version 2.6.10 builds fine for both architectures in a clean chroot.

madscience commented on 2019-08-05 20:47

2.6.10 won't build, make error is "unable to compute suffix of object files". I'm on a fully updated system with no funny gcc customizations. After looking at config.log, the relevant error is:

gcc version 9.1.0 (GCC) configure:4312: $? = 0 configure:4301: gcc -V >&5 gcc: error: unrecognized command line option '-V' gcc: fatal error: no input files compilation terminated.

I checked the configure file, and the issue is on line 4301: for ac_option in --version -v -V -qversion; do

srainey commented on 2019-08-02 19:42

Version is now 2.6.10, causing the download to fail, but you change the PKGBUILD path to https://www.wireshark.org/download/src/all-versions/wireshark-2.6.9.tar.xz to avoid any possible differences from 2.6.10 (I haven't tried 2.6.10, just wanted to make the install as quick as possible here)

digital commented on 2015-12-25 07:37

ar: `u' modifier ignored since `D' is the default (see `U')
ranlib: .libs/libdissectors.a: No space left on device
Makefile:3641: ошибка выполнения рецепта для цели «libdissectors.la»
make[5]: *** [libdissectors.la] Ошибка 1
make[5]: выход из каталога «/tmp/yaourt-tmp-user/aur-wireshark-gtk2/src/wireshark-2.0.0/epan/dissectors»
Makefile:13945: ошибка выполнения рецепта для цели «all-recursive»
make[4]: *** [all-recursive] Ошибка 1
make[4]: выход из каталога «/tmp/yaourt-tmp-user/aur-wireshark-gtk2/src/wireshark-2.0.0/epan/dissectors»
Makefile:3591: ошибка выполнения рецепта для цели «all»
make[3]: *** [all] Ошибка 2
make[3]: выход из каталога «/tmp/yaourt-tmp-user/aur-wireshark-gtk2/src/wireshark-2.0.0/epan/dissectors»
Makefile:1938: ошибка выполнения рецепта для цели «all-recursive»
make[2]: *** [all-recursive] Ошибка 1
make[2]: выход из каталога «/tmp/yaourt-tmp-user/aur-wireshark-gtk2/src/wireshark-2.0.0/epan»
Makefile:3697: ошибка выполнения рецепта для цели «all-recursive»
make[1]: *** [all-recursive] Ошибка 1
make[1]: выход из каталога «/tmp/yaourt-tmp-user/aur-wireshark-gtk2/src/wireshark-2.0.0»
Makefile:2329: ошибка выполнения рецепта для цели «all»
make: *** [all] Ошибка 2
==> ОШИБКА: Произошел сбой в build().
Преждевременный выход...
==> ОШИБКА: Makepkg не смог собрать wireshark-gtk2.
==> Перезапустить сборку wireshark-gtk2 ? да/Нет [y/N]