Package Details: wmix 1:3.2-1

Git Clone URL: https://aur.archlinux.org/wmix.git (read-only)
Package Base: wmix
Description: Dockapp mixer for OSS or ALSA
Upstream URL: http://www.dockapps.net/wmix
Licenses: GPL
Submitter: ilpianista
Maintainer: bidulock
Last Packager: bidulock
Votes: 5
Popularity: 0.091962
First Submitted: 2010-11-13 15:34
Last Updated: 2016-08-18 21:55

Dependencies (1)

Required by (0)

Sources (1)

Latest Comments

abarbarian commented on 2017-06-11 12:42

Thanks for taking the time to help.
I followed your sugestion below, rebooted and wmix will not run from ythe RUN in WM
Running from the cli gets me this.

$ wmix
*** Error in `wmix': free(): invalid next size (fast): 0x0000000000f2d6c0 ***
======= Backtrace: =========
/usr/lib/libc.so.6(+0x7254c)[0x7f490a6d454c]
/usr/lib/libc.so.6(+0x78bfb)[0x7f490a6dabfb]
/usr/lib/libc.so.6(+0x79fd1)[0x7f490a6dbfd1]
wmix[0x402004]
/usr/lib/libc.so.6(__libc_start_main+0xea)[0x7f490a68243a]
wmix[0x40261a]
======= Memory map: ========
00400000-0040e000 r-xp 00000000 103:04 164118 /usr/bin/wmix
0060d000-0060e000 r--p 0000d000 103:04 164118 /usr/bin/wmix
0060e000-0060f000 rw-p 0000e000 103:04 164118 /usr/bin/wmix
0060f000-00610000 rw-p 00000000 00:00 0
00f1e000-00f4f000 rw-p 00000000 00:00 0 [heap]
7f4904000000-7f4904021000 rw-p 00000000 00:00 0
7f4904021000-7f4908000000 ---p 00000000 00:00 0
7f49095f8000-7f490960e000 r-xp 00000000 103:04 134275 /usr/li
7f490960e000-7f490980d000 ---p 00016000 103:04 134275 /usr/lib/libgcc_s.so.1
7f490980d000-7f490980e000 r--p 00015000 103:04 134275 /usr/lib/libgcc_s.so.1
7f490980e000-7f490980f000 rw-p 00016000 103:04 134275 /usr/lib/libgcc_s.so.1
7f490980f000-7f4909814000 r-xp 00000000 103:04 160942 /usr/lib/libXfixes.so.3.1.0
7f4909814000-7f4909a13000 ---p 00005000 103:04 160942 /usr/lib/libXfixes.so.3.1.0
7f4909a13000-7f4909a14000 r--p 00004000 103:04 160942 /usr/lib/libXfixes.so.3.1.0
7f4909a14000-7f4909a15000 rw-p 00005000 103:04 160942 /usr/lib/libXfixes.so.3.1.0
7f4909a15000-7f4909a1e000 r-xp 00000000 103:04 161575 /usr/lib/libXrender.so.1.3.0
7f4909a1e000-7f4909c1e000 ---p 00009000 103:04 161575 /usr/lib/libXrender.so.1.3.0
7f4909c1e000-7f4909c1f000 r--p 00009000 103:04 161575 /usr/lib/libXrender.so.1.3.0
7f4909c1f000-7f4909c20000 rw-p 0000a000 103:04 161575 /usr/lib/libXrender.so.1.3.0
7f4909c20000-7f4909c2a000 r-xp 00000000 103:04 161643 /usr/lib/libXcursor.so.1.0.2
7f4909c2a000-7f4909e29000 ---p 0000a000 103:04 161643 /usr/lib/libXcursor.so.1.0.2
7f4909e29000-7f4909e2a000 r--p 00009000 103:04 161643 /usr/lib/libXcursor.so.1.0.2
7f4909e2a000-7f4909e2b000 rw-p 0000a000 103:04 161643 /usr/lib/libXcursor.so.1.0.2
7f4909e2b000-7f4909e30000 r-xp 00000000 103:04 156586 /usr/lib/libXdmcp.so.6.0.0
7f4909e30000-7f490a02f000 ---p 00005000 103:04 156586 /usr/lib/libXdmcp.so.6.0.0
7f490a02f000-7f490a030000 r--p 00004000 103:04 156586 /usr/lib/libXdmcp.so.6.0.0
7f490a030000-7f490a031000 rw-p 00005000 103:04 156586 /usr/lib/libXdmcp.so.6.0.0
7f490a031000-7f490a033000 r-xp 00000000 103:04 156591 /usr/lib/libXau.so.6.0.0
7f490a033000-7f490a233000 ---p 00002000 103:04 156591 /usr/lib/libXau.so.6.0.0
7f490a233000-7f490a234000 r--p 00002000 103:04 156591 /usr/lib/libXau.so.6.0.0
7f490a234000-7f490a235000 rw-p 00003000 103:04 156591 /usr/lib/libXau.so.6.0.0
7f490a235000-7f490a238000 r-xp 00000000 103:04 133959 /usr/lib/libdl-2.25.so
7f490a238000-7f490a437000 ---p 00003000 103:04 133959 /usr/lib/libdl-2.25.so
7f490a437000-7f490a438000 r--p 00002000 103:04 133959 /usr/lib/libdl-2.25.so
7f490a438000-7f490a439000 rw-p 00003000 103:04 133959 /usr/lib/libdl-2.25.so
7f490a439000-7f490a461000 r-xp 00000000 103:04 156652 /usr/lib/libxcb.so.1.1.0
7f490a461000-7f490a660000 ---p 00028000 103:04 156652 /usr/lib/libxcb.so.1.1.0
7f490a660000-7f490a661000 r--p 00027000 103:04 156652 /usr/lib/libxcb.so.1.1.0
7f490a661000-7f490a662000 rw-p 00028000 103:04 156652 /usr/lib/libxcb.so.1.1.0
7f490a662000-7f490a7fe000 r-xp 00000000 103:04 133905 /usr/lib/libc-2.25.so
7f490aa03000-7f490aa07000 rw-p 00000000 00:00 0
7f490aa07000-7f490ab17000 r-xp 00000000 103:04 133960 /usr/lib/libm-2.25.so
7f490ab17000-7f490ad17000 ---p 00110000 103:04 133960 /usr/lib/libm-2.25.so
7f490ad17000-7f490ad18000 r--p 00110000 103:04 133960 /usr/lib/libm-2.25.so
7f490ad18000-7f490ad19000 rw-p 00111000 103:04 133960 /usr/lib/libm-2.25.so
7f490ad19000-7f490ae52000 r-xp 00000000 103:04 159782 /usr/lib/libX11.so.6.3.0
7f490ae52000-7f490b052000 ---p 00139000 103:04 159782 /usr/lib/libX11.so.6.3.0
7f490b052000-7f490b053000 r--p 00139000 103:04 159782 /usr/lib/libX11.so.6.3.0
7f490b053000-7f490b058000 rw-p 0013a000 103:04 159782 /usr/lib/libX11.so.6.3.0
7f490b058000-7f490b069000 r-xp 00000000 103:04 160790 /usr/lib/libXext.so.6.4.0
7f490b069000-7f490b268000 ---p 00011000 103:04 160790 /usr/lib/libXext.so.6.4.0
7f490b268000-7f490b269000 r--p 00010000 103:04 160790 /usr/lib/libXext.so.6.4.0
7f490b269000-7f490b26a000 rw-p 00011000 103:04 160790 /usr/lib/libXext.so.6.4.0
7f490b26a000-7f490b27b000 r-xp 00000000 103:04 161890 /usr/lib/libXpm.so.4.11.0
7f490b27b000-7f490b47a000 ---p 00011000 103:04 161890 /usr/lib/libXpm.so.4.11.0
7f490b47a000-7f490b47b000 r--p 00010000 103:04 161890 /usr/lib/libXpm.so.4.11.0
7f490b47b000-7f490b47c000 rw-p 00011000 103:04 161890 /usr/lib/libXpm.so.4.11.0
7f490b47c000-7f490b49f000 r-xp 00000000 103:04 133904 /usr/lib/ld-2.25.so
7f490b677000-7f490b67e000 rw-p 00000000 00:00 0
7f490b69d000-7f490b69e000 rw-p 00000000 00:00 0
7f490b69e000-7f490b69f000 r--p 00022000 103:04 133904 /usr/lib/ld-2.25.so
7f490b69f000-7f490b6a0000 rw-p 00023000 103:04 133904 /usr/lib/ld-2.25.so
7f490b6a0000-7f490b6a1000 rw-p 00000000 00:00 0
7ffe3760d000-7ffe3762e000 rw-p 00000000 00:00 0 [stack]
7ffe3764b000-7ffe3764d000 r--p 00000000 00:00 0 [vvar]
7ffe3764d000-7ffe3764f000 r-xp 00000000 00:00 0 [vdso]
ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0 [vsyscall]
Aborted (core dumped)

Sorry for wasting your time, This is too complicated for me to accomplish I'll have to try another way.
Thanks

bidulock commented on 2017-06-10 22:34

The dock app uses OSS devices. You need to load OSS compatibility modules for it to work. I place the following in /etc/modules-load.d/oss-compat.conf:

# load OSS compatability modules
snd-mixer-oss
snd-pcm-oss
snd-seq-oss

or you can try it by simply doing:

sudo modprobe snd-mixer-oss

abarbarian commented on 2017-06-10 14:38

Tried this and it seems to install but will not run from the RUN option in Window Maker. Trying to run from the cli gets me
$ wmix
error: cannot open mixer device /dev/mixer

;-(

abarbarian commented on 2012-03-02 14:22

This gives the following error when you try to run it.

$ wmix
error: cannot open mixer device /dev/mixer

ilpianista commented on 2010-11-13 15:35

* moved from [extra]