Package Details: woeusb-git 3.2.1.r0.g1aaec5f-1

Git Clone URL: https://aur.archlinux.org/woeusb-git.git (read-only)
Package Base: woeusb-git
Description: A Linux program to create Windows USB stick installer from a real Windows DVD or an image
Upstream URL: https://github.com/slacka/WoeUSB
Licenses: GPL3
Provides: woeusb
Submitter: darkfm
Maintainer: darkfm
Last Packager: darkfm
Votes: 109
Popularity: 4.904777
First Submitted: 2017-06-20 07:52
Last Updated: 2018-06-02 16:32

Latest Comments

1 2 3 4 Next › Last »

jamesan commented on 2018-02-16 12:36

The version string doesn't conform to the VCS packaging guidelines as described in ArchWiki, namely in including the release version string if it's defined:

https://wiki.archlinux.org/index.php/VCS_package_guidelines#Git

Specifically for packages with public releases or repository tags like this one, $pkgver must include the latest tag, the number of commits since the tagged release, and the abbreviated commit name. For the WoeUSB repository right now, the derived $pkgver value should be:

3.1.4.r13.gfc91ec1

A pkgver() function definition that generates this version string can be found on the "VCS packaging guidelines" page in ArchWiki, as the last example in the article's Git section. Modify that example's sed command by adding an additional script (i.e. 's/^v//') to remove the leading "v" found in the upstream repo's tags.

Here's a diff of the PKGBUILD implementing the correction:

https://pastebin.com/6kChvq2r

drathir commented on 2018-02-05 03:59

@darkfm after some more debugging looks like not package fault good if possible error provided associate with fat32 max file size limitation in code... Taking off out of date flag...

nTia89 commented on 2018-01-21 16:58

@baqtor @darkfm No, 'gksu' is not a dependency: 1. GNOME (and I think other DE too) has a graphical su front-end integrated, so even if gksu isn't installed in my system, I get the pop-up window which asks me for the password... 2. a user can simpky lauch "sudo woeusbgui"

thus, gksu isn't a dep but an optional dependency!

darkfm commented on 2018-01-20 22:22

@drbuckingham: That's likely to be an upstream bug

drbuckingham commented on 2018-01-18 22:09

Error : Error from 'MainPanel.cpp' at line 158 Description: Can't read usb list !

baqtor commented on 2018-01-14 15:15

Also depends on gksu

mijailr commented on 2017-12-12 05:01

Also depends on ntfs-3g

justasug commented on 2017-12-02 11:06

It also seems to depend on "wget", because it spits a warning about no wget being available when running the CLI version.

asbachb commented on 2017-10-17 21:28

There're some missing dependencies:

* dosfstools
* parted

Pietro_Pizzi commented on 2017-09-23 22:36

@mihails-strasuns That don't work for me:

==> Starting pkgver()...
==> ERROR: pkgver is not allowed to contain colons, hyphens or whitespace.
==> ERROR: pkgver() generated an invalid version: r561.v2.1.3-46-ga6e69df
==> ERROR: Makepkg was unable to build winusb-git.