Package Details: wowup 2.4.7-1

Git Clone URL: (read-only, click to copy)
Package Base: wowup
Description: WowUp the World of Warcraft addon updater
Upstream URL:
Licenses: GPL3
Submitter: cyano
Maintainer: cyano
Last Packager: cyano
Votes: 5
Popularity: 0.014116
First Submitted: 2020-11-11 05:22
Last Updated: 2021-10-12 23:32

Latest Comments

1 2 Next › Last »

mr_nuub commented on 2021-05-18 07:44

Hi! I came across these messages:

npm WARN EBADENGINE Unsupported engine {
npm WARN EBADENGINE   package: 'opossum@6.0.1',
npm WARN EBADENGINE   required: { node: '^15 || ^14 || ^12 || ^10' },
npm WARN EBADENGINE   current: { node: 'v16.0.0', npm: '7.11.2' }

There is no need to downgrade Node.JS. Just install nvm and run nvm install 15 --latest-npm (or nvm use 15 if it's already installed) right before building.

nikost74 commented on 2021-05-11 15:16

Confirmed that Node.js v15.14 works for building. You can follow the instrucions here on how to downgrade from latest to 15.14 (check Alternate installations under Installation):

cyano commented on 2021-04-26 00:27

Node.js v16.0 breaks electron-builder. The error message looks like:

editions-autoloader-none-broadened: Unable to determine a suitable edition, even after broadening.  stackTrace=
  Error: editions-autoloader-none-broadened: Unable to determine a suitable edition, even after broadening.
    at ...

Downgrade to Node.js v15.14 will temporarily fix it. nodejs at ALA

Update: fixed in 2.2.1-1 by upgrading electron-builder to 22.11.x.

cyano commented on 2021-04-01 23:44

Upgrading to 2.2.0-beta.17 for Bruning Crusade Classic Beta support.

To add a classic beta client, click the “Add New” button in “Options > Clients” and navigate to World of Warcraft/_classic_beta_/WowClassicB.exe, and then change the addon update channal to “Alpha”.

orlfman commented on 2021-03-31 04:50

@cyano alright, thank you.

cyano commented on 2021-03-31 01:00

@orlfman It seems to be an upstream dependency issue. Switching to latest beta will temporarily fix it.

_pkgver=2.2.0-beta.16  # prefixed with an underscore

<del>I’ll try adding package-lock.json in 2.2.x releases.</del>

Update: package-lock.json was added in upstream commit ecf2a55. This will be fixed in 2.2.

orlfman commented on 2021-03-30 06:02

wowup is failing for me unfortunately.. i'm getting this error:

cyano commented on 2021-03-18 15:02

@rootpeer Fixed in 2.1.2-2 by setting legacy-peer-deps=true in .npmrc. (for smooth merging when using NPM mirrors.)

Thanks @Dehir.

Dehir commented on 2021-03-18 10:15

npm install <<<"N" --legacy-peer-deps

Build it for me but apparently its not a long term preferred solution

rootpeer commented on 2021-03-15 11:19

Build fails:

==> Starting build()...
npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR! 
npm ERR! While resolving: wowup@2.1.2
npm ERR! Found: @angular/core@11.1.1
npm ERR! node_modules/@angular/core
npm ERR!   dev @angular/core@"11.1.1" from the root project
npm ERR! 
npm ERR! Could not resolve dependency:
npm ERR! peer @angular/core@"11.1.2" from @angular/animations@11.1.2
npm ERR! node_modules/@angular/animations
npm ERR!   @angular/animations@"~11.1.1" from the root project
npm ERR! 
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
npm ERR! 
npm ERR! See /home/.npm/eresolve-report.txt for a full report.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/.npm/_logs/2021-03-15T11_18_36_870Z-debug.log
==> ERROR: A failure occurred in build().
error making: wowup

Am I doing something wrong?