Package Details: wp-cli 2.7.0-1

Git Clone URL: https://aur.archlinux.org/wp-cli.git (read-only, click to copy)
Package Base: wp-cli
Description: A command-line tool for managing WordPress
Upstream URL: http://wp-cli.org/
Licenses: MIT
Submitter: 0x6d617474
Maintainer: 0x6d617474
Last Packager: 0x6d617474
Votes: 14
Popularity: 0.000095
First Submitted: 2014-05-16 18:44 (UTC)
Last Updated: 2022-11-25 16:44 (UTC)

Latest Comments

1 2 3 4 5 Next › Last »

0x6d617474 commented on 2021-06-01 22:01 (UTC) (edited on 2021-06-01 22:07 (UTC) by 0x6d617474)

@caleb I added an extra line to the PKGBUILD locally to verify that it is using PHP 8 and Composer 2. WP-CLI 2.4.0 built from the PKGBUILD works fine for me.

Here is my build and testing process, please let me know how it can be improved:

$ pacman -Qq | grep php | wc -l # PHP not installed
0

$ makepkg -si
[SNIP]
PHP 8.0.6 (cli) (built: May  5 2021 04:49:35) ( NTS )
Copyright (c) The PHP Group
Zend Engine v4.0.6, Copyright (c) Zend Technologies
Composer version 2.0.14 2021-05-21 17:03:37
> run-php-unit-tests
Binary reporting as WP-CLI 2.4.0

$ wp core download
Downloading WordPress 5.7.2 (en_US)...
md5 hash verified: 5493c7abf5317889af2bcd885d352823
Success: WordPress downloaded.

$ wp core verify-checksums 
Success: WordPress installation verifies against checksums.

alerque commented on 2021-06-01 10:02 (UTC) (edited on 2021-06-01 10:04 (UTC) by alerque)

@0x6d617474 Your testing is goofed up, the 2.5.0 release you just bumped to is the first version to support PHP8. Previous versions detected it and refused to run at all. I've been using the wp-cli-git package to get PHP8 support for some time. This release version works fine now, but whatever you did before you were not actually executing it under PHP8. Perhaps you had PHP8 packages on your system but somehow you had PHP7 set as the default or specifically targeted this to run under it (php7 /usr/bin/wp-cli was one way to run this).

0x6d617474 commented on 2021-03-26 00:35 (UTC)

A clean install of the package appears to work fine for me under PHP 8.

Is there a specific error message you are getting when you try to use the software?

alerque commented on 2021-02-27 13:44 (UTC)

The dependencies on this are out of date because php in Arch Linux repos is now php8 and this app is not yet compatible. It must me run under php7. There are php7 packages in [community], so that should be the dependency and the shebang line will need fixing.

0x6d617474 commented on 2021-01-30 22:00 (UTC)

Fixed git dependency via --prefer-dist in the composer update step.

0x6d617474 commented on 2021-01-14 02:40 (UTC)

I have added a patch to fix the compatibility issues with composer 2.x.

I was hoping that a new release of the upstream package would fix this such that we wouldn't need to address the issue in the package, but it's been long enough and a new release doesn't look like it is coming soon

The build step now includes a call to update specific dependencies to a minimum version that supports composer 2.x.

exoro commented on 2020-12-02 16:58 (UTC)

I get this error: Your lock file does not contain a compatible set of packages. Please run composer update.

Problem 1 - cweagans/composer-patches is locked to version 1.6.7 and an update of this package was not requested. - cweagans/composer-patches 1.6.7 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint. Problem 2 - dealerdirect/phpcodesniffer-composer-installer is locked to version v0.5.0 and an update of this package was not requested. - dealerdirect/phpcodesniffer-composer-installer v0.5.0 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint. Problem 3 - cweagans/composer-patches 1.6.7 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint. - wp-cli/wp-cli dev-master requires cweagans/composer-patches ^1.6 -> satisfiable by cweagans/composer-patches[1.6.7]. - wp-cli/wp-cli is locked to version dev-master and an update of this package was not requested.

You are using Composer 2, which some of your plugins seem to be incompatible with. Make sure you update your plugins or report a plugin-issue to ask them to support Composer 2. Building phar... Missing vendor/autoload.php ==> ERROR: A failure occurred in build(). Aborting... error making: wp-cli

lkrms commented on 2020-05-12 05:37 (UTC)

That's a much better way to solve the mustache issue. Thanks for the patch :)

0x6d617474 commented on 2020-04-28 00:42 (UTC)

This package will stay in sync with the upstream wp-cli-bundle release schedule, since the bundle is the recommended way to install the wp-cli software.

As such, even if a new release of the wp-cli framework is released, this package will not update until the corresponding wp-cli-bundle is released.

I have applied a patch to utilize mustache 2.13.0 in order to avoid compatibility issues with PHP 7.4, which should stabilize things until the next bundle release.

Please report any issues with the inclusion of the 2.13.0 release of mustache here, rather than with the wp-cli authors.