Package Details: wpa_supplicant-git 2.10.r197.gf5ad97245-1

Git Clone URL: https://aur.archlinux.org/wpa_supplicant-git.git (read-only, click to copy)
Package Base: wpa_supplicant-git
Description: A daemon program controlling the wireless connection
Upstream URL: https://w1.fi/wpa_supplicant/
Licenses: BSD
Conflicts: wpa_supplicant
Provides: wpa_supplicant
Submitter: Chocobo1
Maintainer: Chocobo1
Last Packager: Chocobo1
Votes: 2
Popularity: 0.000000
First Submitted: 2017-08-09 16:14 (UTC)
Last Updated: 2022-04-07 17:31 (UTC)

Required by (27)

Sources (2)

Latest Comments

1 2 Next › Last »

dvorapa commented on 2022-11-05 19:12 (UTC)

@paulodu16 as I have faced the same issue as you, I created a fork of wpa_supplicant (the core repository package, not git version - hope it is ok for you as well). You can find it here: https://aur.archlinux.org/packages/wpa_supplicant-wep

Chocobo1 commented on 2022-09-08 07:12 (UTC)

Please, could you enable WEP support ? It's now disabled by default... Even if it's absolutely unsecured, there are some access point still configured on this protocol.

Sorry I have to decline this request. WEP is going to be removed in some future versions, says upstream: https://w1.fi/cgit/hostap/tree/wpa_supplicant/defconfig#n633 and I don't want unnecessary maintenance for it. Since this is an VCS package primarily aimed for developers, you are free to fork it and maintain your own version.

paulodu16 commented on 2022-09-07 09:22 (UTC) (edited on 2022-09-07 09:23 (UTC) by paulodu16)

Please, could you enable WEP support ? It's now disabled by default... Even if it's absolutely unsecured, there are some access point still configured on this protocol.

You could just add the line :

grep -qxF 'CONFIG_WEP=y' config || echo 'CONFIG_WEP=y' >> config

Just after "prepare() { cd "$srcdir"" on line 23

Chocobo1 commented on 2022-04-07 17:32 (UTC)

Editing the PKGBUILD to update the URL worked for me. https://raw.githubusercontent.com/archlinux/svntogit-packages/master/wpa_supplicant/trunk/wpa_supplicant_config

Thanks, fixed.

Josholith commented on 2022-04-07 16:46 (UTC)

Getting error when trying to build:

curl: (22) The requested URL returned error: 404                                                                        
==> ERROR: Failure while downloading https://raw.githubusercontent.com/archlinux/svntogit-packages/packages/wpa_supplicant/trunk/config

Editing the PKGBUILD to update the URL worked for me.

https://raw.githubusercontent.com/archlinux/svntogit-packages/master/wpa_supplicant/trunk/wpa_supplicant_config

yan12125 commented on 2021-07-06 17:58 (UTC)

Thanks for the fast fix!

Chocobo1 commented on 2021-07-06 06:23 (UTC)

Hi, recently git.archlinux.org is gone [1]. Could you change the config source to https://github.com/archlinux/svntogit-packages/raw/packages/wpa_supplicant/trunk/config?

OK, done.

yan12125 commented on 2021-07-05 17:41 (UTC)

Hi, recently git.archlinux.org is gone [1]. Could you change the config source to https://github.com/archlinux/svntogit-packages/raw/packages/wpa_supplicant/trunk/config?

[1] https://lists.archlinux.org/pipermail/arch-dev-public/2021-June/030466.html

carlosnewmusic commented on 2021-02-20 02:50 (UTC)

/usr/bin/ld: /var/tmp/pamac-build-user/wpa_supplicant-git/src/hostap/build/wpa_supplicant/src/drivers/driver_nl80211_monitor.o:(.bss+0x0): definiciones múltiples de __packed'; /var/tmp/pamac-build-user/wpa_supplicant-git/src/hostap/build/wpa_supplicant/src/drivers/driver_nl80211.o:(.bss+0x0): primero se definió aquí /usr/bin/ld: /var/tmp/pamac-build-user/wpa_supplicant-git/src/hostap/build/wpa_supplicant/src/utils/radiotap.o:(.bss+0x0): definiciones múltiples de__packed'; /var/tmp/pamac-build-user/wpa_supplicant-git/src/hostap/build/wpa_supplicant/src/drivers/driver_nl80211.o:(.bss+0x0): primero se definió aquí collect2: error: ld devolvió el estado de salida 1 make: *** [Makefile:1882: wpa_supplicant] Error 1

noxx commented on 2020-01-07 13:25 (UTC)

Please enable SAE support by setting CONFIG_SAE=y.