Package Details: writerscafe 2.39-2

Git Clone URL: https://aur.archlinux.org/writerscafe.git (read-only)
Package Base: writerscafe
Description: A set of power tools for all fiction writers, whether experienced or just starting out
Upstream URL: http://writerscafe.co.uk/
Licenses: custom
Submitter: dcelasun
Maintainer: dcelasun
Last Packager: dcelasun
Votes: 10
Popularity: 0.036318
First Submitted: 2010-05-08 10:11
Last Updated: 2016-05-27 06:14

Latest Comments

dcelasun commented on 2016-05-27 06:14

Should be fixed now.

sfabius commented on 2016-05-26 19:42

I got an error:
==> ERROR: license should be an array
==> ERROR: Makepkg was unable to build writerscafe.

Line 7 should be:
license=('custom')

dcelasun commented on 2016-01-12 06:38

Seems like I've missed two _minor_ versions. Updated.

bernarcher commented on 2016-01-12 00:57

Again several versions behind as of
http://www.writerscafe.co.uk/writerscafe-2.39.pkgbuild

Aerion commented on 2014-01-07 16:17

No worries, I was just getting concerned it might have been abandoned. Thanks for the very prompt response and subsequent instant update!

dcelasun commented on 2014-01-07 16:09

My apologies for neglecting this package for so long. Updated it to 2.37.

Aerion commented on 2014-01-07 15:55

If you no longer use this package, or don't have the time to maintain it, perhaps you could disown it?

It is now January 2014, and the package is still several versions behind, despite being flagged out of date over half a year ago.

Aerion commented on 2013-06-20 16:05

Version 2.37 is available

dcelasun commented on 2012-07-31 07:42

Package updated. Thanks for finding the problem!

dcelasun commented on 2012-07-31 07:38

You are right about the problem, but wrong about the solution. What you are suggesting would make /usr/bin/writerscafe an orphan, which is not the Arch Way. I'll try to come up with a different solution.

Anonymous comment on 2012-07-30 16:04

With the link being made when the package is built, it's being linked to the binary in the build directory under the /tmp hierarchy. That directory gets deleted after it's done installing, so /usr/bin/writerscafe becomes a dead link. I'm pretty the way to make this work is to create a file called "writerscafe.install" and put the following functions in it:
post_install() {
ln -s /usr/share/writerscafe2/writerscafe /usr/bin/writerscafe
}

pre_remove() {
rm /usr/bin/writerscafe
}

Then add the following line to the PKGBUILD
install="writerscafe.install"
and remove the /usr/bin/writerscafe linking from the PKGBUILD

see: https://wiki.archlinux.org/index.php/PKGBUILD#install

dcelasun commented on 2012-04-06 17:04

Updated to 2.31.

dcelasun commented on 2011-11-11 16:11

Works fine for me with:

C
en_US
en_US.iso88591
en_US.utf8
POSIX

hasufell commented on 2011-11-11 16:05

had to add locale en_GB, would segfault without on start

# locale -a
C
POSIX
de_DE
de_DE.iso88591
de_DE.iso885915@euro
de_DE.utf8
de_DE@euro
deutsch
en_US
en_US.iso88591
en_US.utf8
german

dcelasun commented on 2011-05-24 05:54

Updated to 2.30. Please report any problems.

dcelasun commented on 2011-02-17 21:07

Note: I know what I'm doing in the install file is not pretty, but this is a binary program and there is no way to call the damn executable without symlinking it.

dcelasun commented on 2011-02-17 20:48

Updated to 2.29. Please report any problems.

caseyjp1 commented on 2010-11-09 21:27

nev' mind. somehow missed that this is a 32bit install. sigh. Need 64

caseyjp1 commented on 2010-11-09 21:25

package fails to install with:

error: failed to commit transaction (conflicting files)

Anonymous comment on 2010-06-01 22:45

Sorry for late answer, but it seems that it requires the specific version 1.2 to work

dcelasun commented on 2010-05-23 17:38

2.26 release 2. libjpeg6 dependency removed.

@juiceball: Does it explicitly require libpng 1.2 or would libpng 1.4 work as well?

dcelasun commented on 2010-05-23 16:24

Thanks! I'll update it as soon as possible.

Anonymous comment on 2010-05-23 16:01

Thanks! It does not need libjpeg6 anymore, but it seems to require libpng12 (AUR).

dcelasun commented on 2010-05-22 16:58

Updated to version 2.26.

dcelasun commented on 2010-05-22 11:52

I'll update the package later today, when I get home.