Package Details: writerscafe 2.42-2

Git Clone URL: (read-only)
Package Base: writerscafe
Description: A set of power tools for all fiction writers, whether experienced or just starting out
Upstream URL:
Licenses: custom
Submitter: dcelasun
Maintainer: dcelasun
Last Packager: dcelasun
Votes: 11
Popularity: 0.015322
First Submitted: 2010-05-08 10:11
Last Updated: 2017-08-25 10:46

Latest Comments

dcelasun commented on 2017-08-25 10:47

Nice catch! I've pushed a workaround for the /usr/bin symlink issue.

bernarcher commented on 2017-08-25 05:57

I think the language problem is caused by the current locale bug where systemd resets the user locales so that there is only (on my system)


while writerscafe obviously tries to read LC_ALL instead. Hence LC_ALL has to be passed in the command. For the time being I put a small wrapper script in my ~/bin:

~/bin% cat writerscafe2
cd /usr/share/writerscafe2
LC_ALL=de_DE.utf8 ./writerscafe

bernarcher commented on 2017-08-24 23:21

The PKGBUILD installs writerscafe in /usr/share/writerscafe2 and puts a symbolic link to there in /usr/bin.

Yet, the program unfortunately assumes its ressources in the directory it has been started from, hence /usr/bin where it cannot find them, however. It needs to be started from the /usr/share/writerscafe2 directory instead.

A simple link from /usr/bin will thusly not work. For the time being I do switch to /usr/share/writerscafe2 and start the program manually from there.

bernarcher commented on 2017-08-24 20:41

At least it starts with LC_ALL locales, yet there are some startup error messages.

% LC_ALL=de_DE.UTF8 writerscafe2
Could not initialise locale for language 87 (de_DE). Trying system locale.
Could not initialise locale for 87 (de_DE) either.

Clean start with LC_ALL=C

I did report this to upstream.

dcelasun commented on 2017-08-24 20:34

I see. I'm afraid I can't be any more helpful. Maybe someone else has an idea...

bernarcher commented on 2017-08-24 20:32

I did try before already. This is what I get:

LANG=en_US.UTF-8 writerscafe
Could not initialise locale for language 57 (de_DE). Trying system locale.
zsh: segmentation fault (core dumped) LANG=en_US.UTF-8 writerscafe2

Wait - it works with LC_ALL=C writerscafe2

dcelasun commented on 2017-08-24 11:25

Maybe try to launch with the English locale?

LANG=en_US.UTF-8 writerscafe


LC_ALL=C writerscafe

bernarcher commented on 2017-08-24 11:01

Upstream obviously cannot help. This is what I got in response to the bug report:

"Sorry to hear that. Unfortunately it's hard to target all versions of
Linux with one binary, and I find Arch Linux is too hard for me to
install to make it a worthwhile target.

If you can run W.C. inside gdb, it might give more information that I
could use."

Personnally I have no time to do so. Perhaps somebody else can do. (If the fault is not caused by my system only.)

dcelasun commented on 2017-08-23 19:57

Since this program is distributed as a precompiled binary, segmentation faults should be reported upstream:

bernarcher commented on 2017-08-23 17:15

Latest version 2.42 does not start:

Could not initialise locale for language 57 (de_DE). Trying system locale.
zsh: segmentation fault (core dumped) writerscafe2

Arch x86_54 fully up to date
Running from openbox

dcelasun commented on 2016-05-27 06:14

Should be fixed now.

sfabius commented on 2016-05-26 19:42

I got an error:
==> ERROR: license should be an array
==> ERROR: Makepkg was unable to build writerscafe.

Line 7 should be:

dcelasun commented on 2016-01-12 06:38

Seems like I've missed two _minor_ versions. Updated.

bernarcher commented on 2016-01-12 00:57

Again several versions behind as of

Aerion commented on 2014-01-07 16:17

No worries, I was just getting concerned it might have been abandoned. Thanks for the very prompt response and subsequent instant update!

dcelasun commented on 2014-01-07 16:09

My apologies for neglecting this package for so long. Updated it to 2.37.

Aerion commented on 2014-01-07 15:55

If you no longer use this package, or don't have the time to maintain it, perhaps you could disown it?

It is now January 2014, and the package is still several versions behind, despite being flagged out of date over half a year ago.

Aerion commented on 2013-06-20 16:05

Version 2.37 is available

dcelasun commented on 2012-07-31 07:42

Package updated. Thanks for finding the problem!

dcelasun commented on 2012-07-31 07:38

You are right about the problem, but wrong about the solution. What you are suggesting would make /usr/bin/writerscafe an orphan, which is not the Arch Way. I'll try to come up with a different solution.

Anonymous comment on 2012-07-30 16:04

With the link being made when the package is built, it's being linked to the binary in the build directory under the /tmp hierarchy. That directory gets deleted after it's done installing, so /usr/bin/writerscafe becomes a dead link. I'm pretty the way to make this work is to create a file called "writerscafe.install" and put the following functions in it:
post_install() {
ln -s /usr/share/writerscafe2/writerscafe /usr/bin/writerscafe

pre_remove() {
rm /usr/bin/writerscafe

Then add the following line to the PKGBUILD
and remove the /usr/bin/writerscafe linking from the PKGBUILD


dcelasun commented on 2012-04-06 17:04

Updated to 2.31.

dcelasun commented on 2011-11-11 16:11

Works fine for me with:


hasufell commented on 2011-11-11 16:05

had to add locale en_GB, would segfault without on start

# locale -a

dcelasun commented on 2011-05-24 05:54

Updated to 2.30. Please report any problems.

dcelasun commented on 2011-02-17 21:07

Note: I know what I'm doing in the install file is not pretty, but this is a binary program and there is no way to call the damn executable without symlinking it.

dcelasun commented on 2011-02-17 20:48

Updated to 2.29. Please report any problems.

caseyjp1 commented on 2010-11-09 21:27

nev' mind. somehow missed that this is a 32bit install. sigh. Need 64

caseyjp1 commented on 2010-11-09 21:25

package fails to install with:

error: failed to commit transaction (conflicting files)

Anonymous comment on 2010-06-01 22:45

Sorry for late answer, but it seems that it requires the specific version 1.2 to work

dcelasun commented on 2010-05-23 17:38

2.26 release 2. libjpeg6 dependency removed.

@juiceball: Does it explicitly require libpng 1.2 or would libpng 1.4 work as well?

dcelasun commented on 2010-05-23 16:24

Thanks! I'll update it as soon as possible.

Anonymous comment on 2010-05-23 16:01

Thanks! It does not need libjpeg6 anymore, but it seems to require libpng12 (AUR).

dcelasun commented on 2010-05-22 16:58

Updated to version 2.26.

dcelasun commented on 2010-05-22 11:52

I'll update the package later today, when I get home.