Package Details: wspr-svn 2460-5

Git Clone URL: https://aur.archlinux.org/wspr-svn.git (read-only, click to copy)
Package Base: wspr-svn
Description: Weak Signal Propagation Reporter
Upstream URL: http://physics.princeton.edu/pulsar/K1JT/wspr.html
Keywords: ham-radio
Licenses: GPL
Submitter: None
Maintainer: None
Last Packager: CarstenF
Votes: 6
Popularity: 0.000000
First Submitted: 2011-03-14 23:50 (UTC)
Last Updated: 2016-03-15 13:24 (UTC)

Latest Comments

clpc2 commented on 2017-12-29 09:41 (UTC)

I am installing this on a Raspberry Pi ArchARM. Can anyone help me with this error while compiling.....

call random_seed(PUT=iclock) 1 Error: Size of ‘put’ argument of ‘random_seed’ intrinsic at (1) too small (12/33) error: Command "/usr/bin/gfortran -g -O2 -fno-range-check -ffixed-line-length-none -Wall -Wno-character-truncation -Wno-conversion -Wtabs -fPIC -fbounds-check -fPIC -g -D_FORTIFY_SOURCE=2 -DPACKAGE_NAME="wspr" -DPACKAGE_TARNAME="wspr" -DPACKAGE_VERSION="1.11" -DPACKAGE_STRING="wspr 1.11" -DPACKAGE_BUGREPORT="" -DFC_LIB_PATH="/usr/lib/gcc/armv7l-unknown-linux-gnueabihf/7.2.1/" -DFC="gfortran" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_SYS_RESOURCE_H=1 -DHAVE_SYS_PARAM_H=1 -DHAVE_ERRNO_H=1 -DHAVE_SYS_SYSLOG_H=1 -DHAVE_STDDEF_H=1 -DHAVE_LIBGEN_H=1 -DHAVE_SYS_WAIT_H=1 -DHAVE_WAIT_H=1 -DHAVE_STDIO_H=1 -DHAVE_TERMIOS_H=1 -DHAVE_SYS_RESOURCE_H=1 -DHAVE_LINUX_PPDEV_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_FCNTL_H=1 -DHAVE_SYS_IOCTL_H=1 -DTIME_WITH_SYS_TIME=1 -DSTRING_WITH_STRINGS=1 -DNDEBUG=1 -DPREFIX="/usr" -DFC_LIB_PATH="/usr/lib/gcc/armv7l-unknown-linux-gnueabihf/7.2.1/" -DFC="gfortran" -I/usr/include -I/usr/local/include -I. -I/tmp/tmpKQyHXd/src.linux-armv7l-2.7 -I/usr/lib/python2.7/site-packages/numpy/core/include -I/usr/include/python2.7 -c -c wspr2.f90 -o /tmp/tmpKQyHXd/wspr2.o" failed with exit status 1 make: *** [Makefile:98: WsprMod/w.so] Error 1 ==> ERROR: A failure occurred in build().

Thanks

StayFrosty commented on 2016-11-14 02:38 (UTC)

tcl, tk, and hamlib should also be listed as dependencies.

minorsecond commented on 2015-01-16 16:50 (UTC)

Want to note that it seems that Python2-Pillow does not work with WSPR and I can only get it to work with Python2-Imaging. I think this may be something that has to be fixed by the dev himself but I'm not sure. Frustrating because upgrade wants to force mo replace the Python2-imaging with Python2-Pillow. You'll probably get the following error: File "/usr/bin/wspr.py", line 38, in <module> import Image, ImageTk, ImageDraw ImportError: No module named Image ================================== EDIT - In order to get it working with Python2-Pillow, allowing for an up-to-date system, I did the following. Open up /usr/bin/wspr.py in your editor of choice and find line 38, "import Image, ImageTK, ImageDraw." Add "from PIL" before the "import." It will look like: from PIL import Image, ImageTk, ImageDraw There may be a more simple fix but this will do for now. It seems that the original wspr.py from the SVN specifies "from PIL import..." but that is changed in the build process. Where to change that is beyond me at the moment.

CarstenF commented on 2015-01-16 12:29 (UTC)

Thanks for your updated PKGBUILD. I've submitted it to AUR. And I've added i686 ,armv5h, armv6h, armv7h to the working arch. Thanks for your help! vy 73 DL1CAF

minorsecond commented on 2015-01-16 12:04 (UTC)

The SVN URL has become out of date again and g95 refuses to compile on my system so I updated the PKGBUILD and WSPR compiles nicely. I've submitted it to the maintainer for review but here is the link for those of you who want to install it. http://pastebin.com/3WiCk2WD Enjoy!

commented on 2012-05-23 03:52 (UTC)

WSPR is back at Berlios.

commented on 2012-01-07 06:05 (UTC)

New PKGBUILD follows the developers moving from Berlios to SourceForge

commented on 2011-03-28 20:23 (UTC)

I cleaned up the file installation as setup.py takes care of almost everything. I'm no longer dumping everything to /opt.

commented on 2011-03-14 23:56 (UTC)

Builds the most current WSPR available in the Berlios svn repository.