Package Details: wxbase 3.1.0-4

Git Clone URL: https://aur.archlinux.org/wxbase.git (read-only)
Package Base: wxbase
Description: wxWidgets base libraries for no X install (3.x branch stable version)
Upstream URL: http://wxwidgets.org
Licenses: custom:wxWindows
Conflicts: wxbase, wxgtk, wxwidgets
Provides: wxbase=3.1.0
Submitter: None
Maintainer: the0
Last Packager: the0
Votes: 7
Popularity: 0.000000
First Submitted: 2009-05-10 00:30
Last Updated: 2016-07-29 13:58

Dependencies (1)

Required by (1)

Sources (1)

Latest Comments

the0 commented on 2015-01-20 00:13

Please note: this release still identifies itself as 3.0.1, i.e. "wx-config --version" returns "3.0.1".

the0 commented on 2015-01-19 23:36

I'll instead update this package to the last stable release (3.0.2), seems it works fine with the latest amule-daemon-git.

sl1pkn07 commented on 2015-01-19 21:44

you can rename this package to wxbase2.8? for use wxbase for 3.x.x branch and wxbase2.8 for 2.8.x branch

greetings

the0 commented on 2014-03-29 13:37

I won't update this to the last stable release (3.0.0) due to bug [1], which, I suppose, is the reason for amule crash on start.
[1] http://trac.wxwidgets.org/ticket/10720

the0 commented on 2013-12-13 15:00

wxWidgets 3.0.0 is out!

Florian commented on 2013-04-11 10:49

Could you please remove the empty makedepends line, and split the build() into build() and package()?

Anonymous comment on 2012-08-06 21:04

Sorry for my poor english.

The nasm package is required to build, but is not a dependency. This is not a problem?

Anonymous comment on 2011-05-02 16:12

Updated to 2.8.12

atommixz commented on 2010-11-06 14:58

maybe more nice use wxBase-2.8.11.tar.bz2??? http://downloads.sourceforge.net/wxwindows/wxBase-2.8.11.tar.bz2

Anonymous comment on 2010-04-28 22:19

Uploaded without disable-all-features.. however I have remove --with-regex=builtin since it is not working for me.

Anonymous comment on 2010-04-28 18:04

I'm not sure about 'disable-all-features' now, I think it might cause alot of things not to work.

my previous suggestion (below) is one I've tested with other applications and everything works, and also it being really minimal and light on resources.

Anonymous comment on 2010-04-28 17:59

I have use the previous suggestion of using --disable-all-features.
What's the difference when your configure options are used gav616?

Anonymous comment on 2010-04-28 14:52

suggestion:

./configure --prefix=/usr --libdir=/usr/lib \
--disable-gui --disable-debug --enable-unicode --disable-compat24 \
--disable-compat26 --with-regex=builtin --with-zlib=sys --without-odbc \
--without-expat --without-libmspack --without-subdirs