Package Details: wxbase2.8-light 2.8.12.1-11

Git Clone URL: https://aur.archlinux.org/wxwidgets2.8-light.git (read-only, click to copy)
Package Base: wxwidgets2.8-light
Description: wxWidgets 2.8 Base (GNOME/GStreamer free!)
Upstream URL: http://wxwidgets.org
Licenses: custom:wxWindows
Conflicts: wxbase2.8
Provides: wxbase2.8
Submitter: sl1pkn07
Maintainer: geyslan (denisfalqueto)
Last Packager: denisfalqueto
Votes: 8
Popularity: 0.77
First Submitted: 2014-09-29 09:41 (UTC)
Last Updated: 2018-03-15 21:54 (UTC)

Latest Comments

denisfalqueto commented on 2018-03-15 22:18 (UTC)

Changelog for 2.8.12.1-11:

  • Set fixed CXX ABI version, so Safesign's TokenAdmin doesn't warn about wrong ABI

geyslan commented on 2017-03-29 19:35 (UTC)

@ProFfeSsoRr, it's working again.

ProFfeSsoRr commented on 2017-03-06 11:48 (UTC)

Now this package can not build, need to add wxGTK-2.8.12.1-r2-gcc6.patch from non-light edition of this package.

sl1pkn07 commented on 2016-10-16 17:31 (UTC)

configure you git installation first

user1549751245 commented on 2016-10-16 17:26 (UTC)

I get this error when compiling: Extracting sources... -> Creating working copy of wxWidgets git repo... Cloning into 'wxwidgets'... done. Switched to a new branch 'makepkg' ==> Starting prepare()... *** Please tell me who you are. Run git config --global user.email "you@example.com" git config --global user.name "Your Name" to set your account's default identity. Omit --global to set the identity only in this repository. fatal: empty ident name (for <(null)>) not allowed ==> ERROR: A failure occurred in prepare(). Aborting... ==> ERROR: Makepkg was unable to build wxwidgets-light. ==> Restart building wxbase-light ? [y/N]

sl1pkn07 commented on 2015-02-09 16:04 (UTC)

ow men. fixed sorry and greetings

DarkElf commented on 2015-02-09 15:50 (UTC)

I get this error during compilation: checking for GTK+ version... checking for pkg-config... /usr/bin/pkg-config checking for GTK+ - version >= 2.0.0... Package gtk+-2.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `gtk+-2.0.pc' to the PKG_CONFIG_PATH environment variable No package 'gtk+-2.0' found no *** Could not run GTK+ test program, checking why... *** The test program failed to compile or link. See the file config.log for the *** exact error that occured. This usually means GTK+ is incorrectly installed. configure: error: The development files for GTK+ were not found. For GTK+ 2, please ensure that pkg-config is in the path and that gtk+-2.0.pc is installed. For GTK+ 1.2 please check that gtk-config is in the path, and that the version is 1.2.3 or above. Also check that the libraries returned by 'pkg-config gtk+-2.0 --libs' or 'gtk-config --libs' are in the LD_LIBRARY_PATH or equivalent. Do you have any solution for this? Thankyou