Package Details: wxgtk-light 3.0.2-7

Git Clone URL: https://aur.archlinux.org/wxwidgets-light.git (read-only)
Package Base: wxwidgets-light
Description: wxWidgets GTK2 and GTK3 Toolkit (GNOME/GStreamer free!)
Upstream URL: http://wxwidgets.org
Licenses: custom:wxWindows
Conflicts: wxgtk
Provides: wxgtk=3.0.2
Submitter: sl1pkn07
Maintainer: sl1pkn07
Last Packager: sl1pkn07
Votes: 0
Popularity: 0.000000
First Submitted: 2014-09-29 09:41
Last Updated: 2016-07-31 20:46

Required by (177)

Sources (4)

Latest Comments

sl1pkn07 commented on 2016-12-21 13:19

No from my side. Sorry. (Of course patch are welcome)

DarkElf commented on 2016-12-21 10:12

{standard input}: Assembler messages:
{standard input}:22620: Warning: end of file not at end of a line; newline inserted
{standard input}:24414: Error: ARM register expected -- `cmp r'
g++: internal compiler error: Ucciso (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See <https://github.com/archlinuxarm/PKGBUILDs/issues> for instructions.
make: *** [Makefile:40442: richtextdll_richtextbuffer.o] Error 4
make: *** Attesa per i processi non terminati....

any solution to this?
(trying to build on RaspberryPi 2)

sl1pkn07 commented on 2016-08-01 04:09

Is your first time using Git?

Please configure Git like say in that message before install the package

Bitl0rd commented on 2016-08-01 02:22

==> Iniciando prepare()…

*** Please tell me who you are.

Run

git config --global user.email "you@example.com"
git config --global user.name "Your Name"

to set your account's default identity.
Omit --global to set the identity only in this repository.

fatal: empty ident name (for <(null)>) not allowed
==> ERROR: Se produjo un fallo en prepare().
Cancelando…

sl1pkn07 commented on 2016-04-24 18:15

@ifndef_define ops!. done

ifndef_define commented on 2016-04-24 18:09

I believe clang should be added as a build dependency. I was getting ./configure errors until I installed it.

ckoresko commented on 2015-10-06 15:00

Package built with no issues but install failed:
==> Finished making: wxwidgets-light 3.0.2-5 (Tue Oct 6 10:51:15 EDT 2015)
==> Installing wxwidgets-light package group with pacman -U...
loading packages...
error: '/home/koresko/build/wxwidgets-light/wxcommon-light-3.0.2-5-x86_64.pkg.tar.xz': could not find or read package
==> WARNING: Failed to install built package(s).

Doing 'sudo pacman -U *.pkg.tar.xz' in the build directory successfully installed the three newly-built packages.