Package Details: wxgtk2-dev 3.1.7-1

Git Clone URL: https://aur.archlinux.org/wxgtk-dev.git (read-only, click to copy)
Package Base: wxgtk-dev
Description: GTK+2 implementation of wxWidgets API for GUI
Upstream URL: https://wxwidgets.org
Licenses: custom:wxWindows
Conflicts: wxgtk, wxgtk2
Provides: wxgtk, wxgtk2
Replaces: wxgtk
Submitter: ibrokemypie
Maintainer: wangqr
Last Packager: wangqr
Votes: 9
Popularity: 0.144263
First Submitted: 2017-11-16 12:42 (UTC)
Last Updated: 2022-06-08 13:38 (UTC)

Pinned Comments

wangqr commented on 2021-10-19 09:43 (UTC)

@reisen wx-config is provided as a symlink to wx-config-gtk3 in the split package wxgtk3-dev. This change was made due to the EOL of Gtk2 and the plan to drop any gtk2 dependencies. See also: https://archlinux.org/todo/gtk-2-eol/

Latest Comments

wangqr commented on 2022-03-05 16:12 (UTC)

@feNNec wxgtk3-dev is a split package of wxgtk-dev. You can find it here: https://aur.archlinux.org/packages/wxgtk3-dev

feNNec commented on 2022-02-24 19:16 (UTC) (edited on 2022-02-24 19:17 (UTC) by feNNec)

wxgtk3-dev not found in AUR ???

dobedobedo commented on 2022-01-22 14:35 (UTC)

Hi @wangqr, I submitted the AUR package python-wxpython-dev based on your PKGBUILD.
https://aur.archlinux.org/packages/python-wxpython-dev/
This name should not violate the first rule of the AUR submission guideline.
Feel free to take it over.

dobedobedo commented on 2022-01-17 15:31 (UTC)

@wangqr, may I ask for what reason the python-wxpython-dev package is not allowed?

wangqr commented on 2022-01-04 18:31 (UTC) (edited on 2022-01-11 13:36 (UTC) by wangqr)

@dobedobedo Sure. https://aur.archlinux.org/packages/python-wxpython41/

Edit: It is not allowed on AUR. Here's the backup: https://github.com/wangqr/PKGBUILDs/tree/master/python-wxpython41

dobedobedo commented on 2022-01-04 11:18 (UTC) (edited on 2022-01-04 11:18 (UTC) by dobedobedo)

Hi @wangqr, thanks for providing and maintaining this package.
Just wondering if you would also like to create a python-wxpython AUR package which support wxWidget 3.1? The python-wxpython from the repo doesn't support this version of wxWidget.
Below is the PKGBUILD provided on GitHub. I tried it and it works without problems.
https://github.com/OSGeo/grass/issues/1261#issuecomment-769192288

dulice commented on 2021-11-29 06:10 (UTC)

@wangqr no, filezilla is precompiled version. I didn't think it was necessary. It is not a problem for me, I installed wxgtk-dev for some experiments and I just wanted to warn about the problem

wangqr commented on 2021-11-24 16:07 (UTC)

@dulice Looks like a soname issue. Have you tried recompiling filezilla after installed wxgtk-dev?

dulice commented on 2021-11-23 07:28 (UTC)

sorry, the error is for wxgtk-common-dev

dulice commented on 2021-11-23 06:44 (UTC)

After installed it if launch filezilla I have:

filezilla: error while loading shared libraries: libwx_gtk3u_aui-3.0.so.0: cannot open shared object file: No such file or directory

I guest must be changed "provided" in wxgtk3-dev or filezilla dependecies

wangqr commented on 2021-10-19 09:43 (UTC)

@reisen wx-config is provided as a symlink to wx-config-gtk3 in the split package wxgtk3-dev. This change was made due to the EOL of Gtk2 and the plan to drop any gtk2 dependencies. See also: https://archlinux.org/todo/gtk-2-eol/

reisen commented on 2021-10-19 04:18 (UTC)

This package does not provide the wx-config binary like the official wxgtk2 package does, which breaks any makefile that expects wx-config to be present. I know it provides wx-config-gtk2, but that's a different binary name.

wangqr commented on 2021-01-27 01:33 (UTC)

@ruy16109 official wxgtkX stays on wx 3.0.x. This AUR provides wx 3.1.x

ruy16109 commented on 2020-10-26 16:03 (UTC) (edited on 2020-10-26 16:04 (UTC) by ruy16109)

Just curious, what is the difference between this AUR and the official wxgtkX?

LindyBalboa commented on 2019-02-20 20:09 (UTC)

I recently got the ABI version mismatch error when trying to launch audacity. I eventually noticed the patch "make-abicheck-non-fatal.patch". This needs to be updated to reflect the new version in the directory names as well as the proper lines of code, starting at line 847 now instead.

Dark-Sky commented on 2018-10-07 14:49 (UTC) (edited on 2018-10-07 14:52 (UTC) by Dark-Sky)

I built this package today using Clean Chroot Manager and it built just fine for CubicSDR that now requires this version. CubicSDR also built and works also with this version. It remains to be seen if this version will break any of my other programs I have installed built using the old version though.

ibrokemypie commented on 2018-08-28 10:03 (UTC)

Shasum updated, disowning package as I no longer use it though.

tapir commented on 2018-08-28 09:16 (UTC)

build broken. same here: sha1sum for the webkit patch is d2bd62d0852f3647782780565849692e7837c10c

hrehfeld commented on 2018-08-12 12:16 (UTC) (edited on 2018-08-12 12:16 (UTC) by hrehfeld)

Build broken for me: https://gist.github.com/hrehfeld/2257216926d6f8c02a9600d921719c96

wxgtk-webkit2gtk.patch fails validity check.

Dark-Sky commented on 2018-06-11 16:25 (UTC)

I get endless pango header file errors. Example:

/usr/include/pango-1.0/pango/pangofc-decoder.h:107:7: error: ‘PangoFcFont’ has not been declared PangoFcFont *fcfont,

tapir commented on 2018-02-26 20:46 (UTC)

Any idea when it will be updated to 3.1.1 This release makes my package wxgtk-trenchbroom obsolete so I would like to switch to it.