Package Details: wxmedit 3.1-1

Git Clone URL: https://aur.archlinux.org/wxmedit.git (read-only)
Package Base: wxmedit
Description: Cross-platform Text/Hex Editor, a fork of MadEdit with bug fixes and improvements
Upstream URL: https://wxmedit.github.io/
Licenses: GPL
Submitter: codestation
Maintainer: codestation
Last Packager: codestation
Votes: 12
Popularity: 0.022027
First Submitted: 2014-01-08 04:14
Last Updated: 2016-05-15 16:22

Latest Comments

potatoe commented on 2017-02-09 16:42

I don't think this package needs to depend on the 2.8 version of wxgtk any more, it builds and seems to work fine with the wxgtk 3.0.2-6 package from extra (after changing the PKGBUILD's deps and the ./configure options).

The compilation problem from 2014 in the comments here seems to have been fixed in recent versions of the app (with an ifdef: https://github.com/hltj/wxMEdit/blob/3.1/src/wxmedit/wxmedit.cpp#L53 ), and the app's README explicitly mentions support for "wxWidgets 2.8/3.0".

petronny commented on 2016-05-15 16:27

* https://www.archlinux.org/todo/hooks-part-1/
"Each rebuild requires the install file updated to remove these commands."

* https://wiki.archlinux.org/index.php/DeveloperWiki:Pacman_Hooks
"Implemented
update-desktop-database
update-mime-database
update-appstream-index
install-info
glib-compile-schemas
gtk-update-icon-cache, xdg-icon-resource
gconfpkg
gio-querymodules
gdk-pixbuf-query-loaders
gtk-query-immodules-2.0
gtk-query-immodules-3.0"

codestation commented on 2016-05-15 16:22

Where did you find this info? After lots of searching i found this: http://allanmcrae.com/2016/01/pacman-5-0-released/

But i am not sure if there is a more accesible source...

Anyway, the package is updated.

BTW, do you know if the desktop-file-utils dependency is still required?

petronny commented on 2016-05-15 15:20

Please remove
update-desktop-database -q
from wxmedit.install

it is no longer needed now.

codestation commented on 2015-11-19 02:49

Moved boost to makedepends. Didn't bump the version so a rebuild isn't needed. Boost will go away from the dep list automagically on the next package version.

lilydjwg commented on 2015-11-17 10:33

I doubt this package needs boost to run. There are only headers in that package and I can run wxmedit without boost or boost-libs just fine.

codestation commented on 2014-11-08 17:48

Updated the URL but the latest release tarball is still 2.9.8, There is a 2.9.8.3 but marked as prerelease, not sure how unstable is it so i am sticking with the tarball on the "Latest Release" section.

carstene1ns commented on 2014-11-08 17:28

New version + new URL: http://wxmedit.github.io/.

DaveCode commented on 2014-07-24 03:50

Thank you for this pkg.

kfgz commented on 2014-05-14 18:53

Sorry. I've got it wrong. Last issue is with wxHexEditor.

All comments