Package Details: wxsvg 1.5.13-3

Git Clone URL: https://aur.archlinux.org/wxsvg.git (read-only)
Package Base: wxsvg
Description: C++ library to create, manipulate and render SVG files
Upstream URL: http://wxsvg.sourceforge.net/
Licenses: custom:wxWindows
Submitter: xyproto
Maintainer: artafinde
Last Packager: artafinde
Votes: 57
Popularity: 0.140734
First Submitted: 2011-12-14 17:07
Last Updated: 2018-06-07 07:03

Latest Comments

fbbdev commented on 2018-03-05 14:39

I think webkitgtk2 can be removed from the dependencies. It is not listed in wxsvg readme; grep -Ri webkit on wxsvg code gives nothing; the package builds and works fine without it. Plus webkitgtk2 is not hosted by official repos anymore and the AUR version takes months to compile.

artafinde commented on 2018-03-02 08:20

SF.net is experiencing issues so can't update the package just yet, I will check back later today

artafinde commented on 2018-01-28 11:50

Noticed the same - was waiting for next release update (which happened now) to combine the changes. Shout if you have issues.

joe1984 commented on 2018-01-27 15:11

I don't think ffmpeg0.10 should be listed as a dependency anymore. I was able to successfully compile the package without it. DVDStyler seems to work fine.

wolfyrion commented on 2017-10-06 22:07

@migrev well it seems now that is trying to build wxsvg but webkitgtk2 is not compiling.
(I have let my pc to compile webkitgtk2 for 3 hours but nothing so I had to stop it)

migrev commented on 2017-10-06 07:56

@wolfyrion: What you actually want is ffmpeg0.10, which provides ffmpeg-compat. I have updated PKGBUILD to make that clearer. Thanks for your message.

wolfyrion commented on 2017-10-06 05:49

I wanted to build DVDSTYLER but it required WXSVG which it required ffmpeg-compat.

Failed to prepare transaction:
could not satisfy dependencies:
unable to satisfy dependency 'ffmpeg-compat' required by wxsvg

I have tried ffmpeg-compat-54 and 55 but no luck

tomx3 commented on 2017-01-18 08:35

libexif is missing in dependencies.

migrev commented on 2016-11-14 13:50

Apart from the missing libexif dependency (which will fix with a -r2), I'm unable of reproducing the compile fail. In my system everthing compiles, links and packages smoothly. Anyone else can confirm the fail? Thx.

keepitsimpleengr commented on 2016-11-14 12:25

Still failing.
Output of yaourt at http://pastebin.com/8nSQUEhL

All comments