Package Details: x-tile-git 3.3.r4.g76faafc-1

Git Clone URL: https://aur.archlinux.org/x-tile-git.git (read-only, click to copy)
Package Base: x-tile-git
Description: Allows you to select a number of windows and tile them in different ways
Upstream URL: https://www.giuspen.com/x-tile
Keywords: tiling
Licenses: GPL2
Conflicts: x-tile
Provides: x-tile
Submitter: Fanch
Maintainer: Fanch
Last Packager: yochananmarqos
Votes: 4
Popularity: 0.000000
First Submitted: 2015-11-15 14:20 (UTC)
Last Updated: 2021-08-27 21:08 (UTC)

Latest Comments

yochananmarqos commented on 2021-08-22 14:23 (UTC)

@silent: Oops, fixed.

silent commented on 2021-08-22 11:15 (UTC)

I get this error when building the package with with yay: ==> Starting check()... linux/x-tile-git.desktop: file does not exist ==> ERROR: A failure occurred in check(). Aborting...

yochananmarqos commented on 2020-03-30 00:46 (UTC)

@Fanch: Thanks. I use RSS feeds for projects I'm interested in. ;)

Fanch commented on 2020-03-29 22:23 (UTC)

@yochananmarqos I added you as maintainer, as it look like you are more aware than me of what happen upstream ;)

yochananmarqos commented on 2020-03-29 21:39 (UTC) (edited on 2020-03-29 21:40 (UTC) by yochananmarqos)

He just migrated the project to Python 3 and gconf is no longer needed. See my updated PKGBUILD.

yochananmarqos commented on 2020-03-29 00:08 (UTC) (edited on 2020-03-29 00:09 (UTC) by yochananmarqos)

pygtk is no longer needed, see the latest commit

They now should be:

depends=('gconf' 'libappindicator-gtk3' 'python2-gobject')
makedepends=('git')

yochananmarqos commented on 2019-07-17 15:20 (UTC)

Whoops, I was wrong about it requiring python2-distutils-extra.

Fanch commented on 2019-07-14 08:54 (UTC)

@yochananmarqos: done, thank you ;)

yochananmarqos commented on 2019-06-30 18:22 (UTC) (edited on 2019-07-17 15:23 (UTC) by yochananmarqos)

This no longer requires python2-gconf and should be replaced by pygtk. It also requires 'python2-libappindicator` for the tray icon.

The shebang in setup.py should be changed to python2, see the x-tile PKGBUILD.