Package Details: x-tile 2.5.1-1

Git Clone URL: https://aur.archlinux.org/x-tile.git (read-only)
Package Base: x-tile
Description: A gnome/xfce tiling applet for your panel
Upstream URL: http://www.giuspen.com/x-tile
Licenses: GPL2
Submitter: None
Maintainer: bidulock
Last Packager: bidulock
Votes: 43
Popularity: 0.021309
First Submitted: 2009-08-30 22:59
Last Updated: 2015-12-04 12:33

Latest Comments

Fanch commented on 2015-11-15 14:29

@rogue_ronin : https://aur.archlinux.org/packages/x-tile-git/ work for me

rogue_ronin commented on 2015-09-06 00:11

~ : x-tile
Segmentation fault (core dumped)

How can I help resolve this problem?

Aloha.

luolimao commented on 2012-12-12 02:40

@zeltax Is your gvfs package up-to-date? Also, it may be that one of your installed packages was built with an older version of gvfs.

Anonymous comment on 2012-09-03 15:07

Hmm, It's working fine here and i've had a quick fiddle to try and recreate. I'm using compiz as my WM though. I'll have a look later on, have you asked upstream yet?

zeltak commented on 2012-09-03 14:25

hya

it installs well but i get this error:

--> x-tile

** (process:11881): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:11881): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:11881): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
WM = Enlightenment
Traceback (most recent call last):
File "/usr/bin/x-tile", line 54, in <module>
__builtin__.glob = globs.GlobalsObject()
File "/usr/share/x-tile/modules/globs.py", line 131, in __init__
self.desktop_width, self.desktop_height = support.get_desktop_width_n_height()
File "/usr/share/x-tile/modules/support.py", line 35, in get_desktop_width_n_height
return glob.ret_pointer[2], glob.ret_pointer[3]
ValueError: NULL pointer access


any ideas?

z.

Anonymous comment on 2012-06-22 23:22

Sorry about that I'd updated it locally but forgot to upload the tarball.

benoliver999 commented on 2012-06-21 23:39

Agreed with gabx, I'm getting a 404 without his fix.

benoliver999 commented on 2012-06-21 23:37

I'm getting a 404 on this one.

gabx commented on 2012-06-15 18:37

2.3.1 is out.
In PKGBUILD, please correct the following:
pkgver=2.3.1
....
md5sums=('251aec74e6ebe9bef17598cfbff16871')

dracorp commented on 2012-05-27 19:18

v2.3 is out.

Anonymous comment on 2011-12-27 05:10

Ver 2.2 released

• fixed bugs
• added support for appindicator where the system tray is not supported (ubuntu unity)

Anonymous comment on 2011-07-08 22:33

Ver 2.1 released.
• fixed bugs
• added czech language

Anonymous comment on 2011-07-05 22:56

Ver 2.0 re;eased.
• now working on any X desktop environment (gnome, kde, xfce, lxde,…)
• implemented optional system tray docking and menu (it’s also possible to have x-tile start in the system tray)
Doesn't use Gnomeapplt at all any more, seems to work 'out of the box' on Gnome + XFCE for me.

chepaz commented on 2011-07-01 16:01

Nice work, thanks!

Anonymous comment on 2011-07-01 10:33

Sorry about that, I missed off python2-gconf dep which pulls in pygtk and gconf, neither of which are strictly 'just gnome' pkgs. PKGBUILD updated.
Nothing is installed in /usr/local I don't know how you've got that. My pkg has /usr/{bin,lib,share} dirs.

nbvcxz commented on 2011-07-01 10:07

Would be very nice to get rid totally out of Gnome, but running x-tile:
Traceback (most recent call last):
File "/usr/bin/x-tile-ng", line 30, in <module>
import gtk, gconf
ImportError: No module named gconf
And second thing is - why do you intall it in /usr/local ?

Anonymous comment on 2011-07-01 09:20

Ver 1.9 out, I've got this working now using the 'gnome free' script (x-tile-ng) and a little bash wrapper to make starting it easier. Not ideal I know but it's all I could come up with. Everything __should__ still work as before, if it doesn't let me know and I'll _try_ and sort it.
'gnome-python-desktop' dep has been removed and this x-tile pkg doesn't need any Gnome deps any more so you might be able to ditch a few pkgs (especially if your not using the gnome DE). I've was able to get rid of 22 pkgs/77 MB but I'm now using XFCE4 mainly so YMMV

chepaz commented on 2011-06-19 16:45

Hm. Ok, i was afraid that this is due gnome3. I moved also to xfwm4-tiling but i want some more tiling than 50/50-tile. I'm not a PKGBUILD-Guru but before you drop the pkg i would take it over and try my very best ;)

Anonymous comment on 2011-06-19 11:46

gnomeapplet has been dropped because it's not compatible with gnome-panel 3, I'm waiting to see if they fix it in a new ver, but I've pretty much moved over to xfce now cos I'm not liking gnome3. If you wanna take this over let me know and I'll disown it.

chepaz commented on 2011-06-18 08:41

Line 16 of the PKGBUILD should be:
cd "$srcdir/$pkgname"-"$pkgver"
But wait a bit with fixing, they'll bump a new version these days.


Any hints about this?

Traceback (most recent call last):
File "/usr/bin/x-tile", line 30, in <module>
import gtk, gnomeapplet, gobject, gconf
ImportError: No module named gnomeapplet

chepaz commented on 2011-06-18 08:05

Line 16 of the PKGBUILD should be:

cd "$srcdir/$pkgname"-"$pkgver"

But wait a bit with fixing, they'll bump a new version these days :)

Anonymous comment on 2011-04-22 21:55

Updated thanks, Wish they'd bump versions when they change things

TheLemonMan commented on 2011-04-22 10:16

The MD5 sum is wrong, should be '5ad81b9e569ea3fe7483d544992ac9f7' and the underscore between PKGNAME and PKGVERSION should be changed to a '-'

Anonymous comment on 2011-02-19 00:26

Updated, thanks

Anonymous comment on 2011-02-18 22:47

checksum is seems to be wrong. For me it was 1daae4708fcb4509ffc23c5d326015c6 :-?

Anonymous comment on 2010-11-15 17:50

Ver 1.8.3 out Command line options have changed, so might break your shortcuts etc, check out the homepage.

chepaz commented on 2010-10-23 14:17

For me it seems to work. No problems so far.

Anonymous comment on 2010-10-22 05:54

No need to update really, just a PKGBUILD clean up. Please let me know if this works if you do update.

chepaz commented on 2010-10-20 12:30

Thanks sausageandeggs. I'll appreciate your choice since my knowledge in packaging lacks much, especially on this weird PKBUILD :)

Anonymous comment on 2010-10-20 12:30

Adopted and updated for python changeover

Anonymous comment on 2010-10-20 09:32

Sorry guys but I don't use this program anymore and I do not have the time to maintain pkgbuild in an actual state.

chepaz commented on 2010-10-20 08:02

Doesn't work here. X-tile crashes on startup. Manually changed the first line of /usr/bin/x-tile to /usr/bin/env python2 helps (was: /usr/bin/env python).

chepaz commented on 2010-10-20 08:00

Doesn't work here. X-tile crashes on startup.

Anonymous comment on 2010-10-19 16:28

I've updated pkgbuild but I have not tested it meanwhile.

qwertzdenek commented on 2010-10-19 13:54

Python was updated to version 3. Change /usr/bin/x-tile first line to "/usr/bin/env python2".

Anonymous comment on 2010-07-26 05:05

Updated!

Thalskarth commented on 2010-07-25 20:06

There's 1.6.1 already

Anonymous comment on 2010-07-11 07:17

Updated!

chepaz commented on 2010-07-05 15:22

vito45:

The site has moved, use this pkgbuild --> http://npaste.de/av/

Anonymous comment on 2010-07-05 15:07

I have this error:
==> Validating source files with md5sums...
x-tile-1.5.2.tar.gz ... FAILED
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build x-tile.

Anonymous comment on 2010-06-05 05:11

Updated!

chepaz commented on 2010-06-04 20:36

New release --> 1.5.1. Support for german language.

chepaz commented on 2010-06-04 20:33

New release --> 1.5.1. Support for german language.

Anonymous comment on 2010-04-07 08:14

Updated!

Anonymous comment on 2010-03-30 16:30

Update please!
In new release added russian, italian and french translation.