Package Details: x3270 3.4ga10-1

Git Clone URL: https://aur.archlinux.org/x3270.git (read-only)
Package Base: x3270
Description: An IBM 3270 terminal emulator for the X Window System
Upstream URL: http://x3270.bgp.nu/
Licenses: BSD, MIT
Submitter: None
Maintainer: tuftedocelot
Last Packager: tuftedocelot
Votes: 26
Popularity: 0.161428
First Submitted: 2006-08-09 22:35
Last Updated: 2016-02-13 18:29

Latest Comments

tuftedocelot commented on 2013-10-10 21:35

Bump to latest version

tuftedocelot commented on 2013-06-15 14:05

Updated to latest version. Thanks to ras for his patch on this one and for catching the licensing

tuftedocelot commented on 2013-06-05 12:34

Thanks, ras. I'll get your patch integrated this evening

ras commented on 2013-06-05 08:45

Hello all, there is a newer version, and I also made some other fixes with the PKGBUILD:
* fixed dependencies suggested by namcap
* added proper license file from the source directory of x3270 (BSD + MIT)

Here is the patch:

--- PKGBUILD.txt 2013-06-05 10:43:30.933232338 +0200
+++ PKGBUILD 2013-06-05 10:37:47.936572127 +0200
@@ -4 +4 @@
-pkgver=3.3.12ga12
+pkgver=3.3.12ga13
@@ -9,2 +9,2 @@
-license=('GPL')
-depends=('openssl' 'xbitmaps')
+license=('BSD' 'MIT')
+depends=('openssl' 'libxaw')
@@ -17,2 +17,2 @@
-sha256sums=('2b7ca0614a7b0d97507753f933f4be04aa16a4bc255ad80b2c14a9dfebbcb8b8'
- 'bb3f1a301ca4f6d6d4f4cafe451945a55a9af7995d712a0f314fc58dfb16da6f')
+sha256sums=('b3b75def2f4a996b04e26aa1886e6b47723562432c95f9d04191bcf6e45c13bb'
+ 'bb3f1a301ca4f6d6d4f4cafe451945a55a9af7995d712a0f314fc58dfb16da6f')
@@ -35,0 +36,2 @@
+ mkdir $pkgdir/usr/share/licenses
+ mkdir $pkgdir/usr/share/licenses/x3270
@@ -37,0 +40 @@
+ install -m644 $srcdir/${pkgname}-${pkgver:0:3}/LICENSE $pkgdir/usr/share/licenses/x3270/

tuftedocelot commented on 2013-04-08 13:28

Updated to the newest version. Thanks to usch for his patch to the PKGBUILD

usch commented on 2013-04-08 07:49

I was not aware of a newer version, so I did it with 3.3.12ga11

tuftedocelot commented on 2013-04-06 14:36

@usch, is this with 3.3.12ga11 or the new version 3.3.12ga12 that I haven't gotten to yet?

usch commented on 2013-04-05 20:19

I was able to build and install it with success after replaced the build()
function in PKGBUILD with:
build() {
cd $srcdir/$pkgname-${pkgver:0:3}
./configure --prefix=/usr --bindir=/usr/bin --sysconfdir=/etc --with-fontdir=/usr/share/fonts/3270

make depend || return 1
make || return 1
}

package() {
cd $srcdir/$pkgname-${pkgver:0:3}
make DESTDIR=$pkgdir/ install || return 1

chmod 644 $pkgdir/etc/x3270/ibm_hosts

mkdir $pkgdir/usr/share/applications
mkdir $pkgdir/usr/share/pixmaps
install -m644 $srcdir/x3270.desktop $pkgdir/usr/share/applications/
install -m644 $srcdir/${pkgname}-${pkgver:0:3}/x3270-icon2.xpm $pkgdir/usr/share/pixmaps/
}

tuftedocelot commented on 2013-02-16 17:33

Updated to latest version: http://bpaste.net/raw/77688/

Winz commented on 2013-02-11 14:58

Davbo,

If you are not maintaining this package anymore, could you flag it as an orphan package ? I work with x3270 and I can maintain this package as long as I will work on IBM systems.

Winz

marcs commented on 2012-07-19 08:33

I've managed to compile the latest version, on my updated archbox:


# Contributor: Davbo <dave@davbo.org>
pkgname=x3270
pkgver=3.3.12ga10
pkgrel=1
pkgdesc="An IBM 3270 terminal emulator for the X Window System"
arch=('i686' 'x86_64')
url="http://x3270.bgp.nu/"
license=('GPL')
depends=('openssl' 'xbitmaps')
makedepends=('imake' 'openssl' 'libx11' 'libxaw' 'libxt' 'xbitmaps')
backup=(etc/x3270/ibm_hosts)
install=x3270.install
source=(http://downloads.sourceforge.net/sourceforge/x3270/suite3270-$pkgver-src.tgz
x3270.desktop)

md5sums=('0549b971383c0ce5b662d0c03409a941'
'cdb90e91f28479681a7939b9d19ea98f')

build() {
cd $startdir/src/$pkgname-${pkgver:0:3}
./configure --prefix=/usr --bindir=/usr/bin --sysconfdir=/etc --with-fontdir=/usr/share/fonts/3270

make depend || return 1
make || return 1
make DESTDIR=$startdir/pkg install || return 1

chmod 644 $startdir/pkg/etc/x3270/ibm_hosts

mkdir $startdir/pkg/usr/share/applications
mkdir $startdir/pkg/usr/share/pixmaps
install -m644 $startdir/src/x3270.desktop $startdir/pkg/usr/share/applications/
install -m644 $startdir/src/${pkgname}-${pkgver:0:3}/x3270-icon2.xpm $startdir/pkg/usr/share/pixmaps/
}

marcs commented on 2012-07-19 08:33

I managed to compile the latest version on my update archbox, this is the PKGBUILD:
# Contributor: Davbo <dave@davbo.org>
pkgname=x3270
pkgver=3.3.12ga10
pkgrel=1
pkgdesc="An IBM 3270 terminal emulator for the X Window System"
arch=('i686' 'x86_64')
url="http://x3270.bgp.nu/"
license=('GPL')
depends=('openssl' 'xbitmaps')
makedepends=('imake' 'openssl' 'libx11' 'libxaw' 'libxt' 'xbitmaps')
backup=(etc/x3270/ibm_hosts)
install=x3270.install
source=(http://downloads.sourceforge.net/sourceforge/x3270/suite3270-$pkgver-src.tgz
x3270.desktop)

md5sums=('0549b971383c0ce5b662d0c03409a941'
'cdb90e91f28479681a7939b9d19ea98f')

build() {
cd $startdir/src/$pkgname-${pkgver:0:3}
./configure --prefix=/usr --bindir=/usr/bin --sysconfdir=/etc --with-fontdir=/usr/share/fonts/3270

make depend || return 1
make || return 1
make DESTDIR=$startdir/pkg install || return 1

chmod 644 $startdir/pkg/etc/x3270/ibm_hosts

mkdir $startdir/pkg/usr/share/applications
mkdir $startdir/pkg/usr/share/pixmaps
install -m644 $startdir/src/x3270.desktop $startdir/pkg/usr/share/applications/
install -m644 $startdir/src/${pkgname}-${pkgver:0:3}/x3270-icon2.xpm $startdir/pkg/usr/share/pixmaps/
}

Anonymous comment on 2011-11-12 23:14

Version 3.3.12ga7 builds fine; just needs PKGBUILD pkgver set.

adriaticc commented on 2011-04-25 00:26

Before running make, I needed to mkdir -p $startdir/pkg/usr/share/fonts/3270