Package Details: xapps-git 1.2.2.r0.gd957699-2

Git Clone URL: https://aur.archlinux.org/xapps-git.git (read-only)
Package Base: xapps-git
Description: Common library for X-Apps project
Upstream URL: https://github.com/linuxmint/xapps
Licenses: GPL
Conflicts: xapps
Provides: xapps
Submitter: kernelmd
Maintainer: eschwartz
Last Packager: eschwartz
Votes: 2
Popularity: 0.001264
First Submitted: 2016-09-21 16:24
Last Updated: 2018-08-08 03:14

Required by (9)

Sources (1)

Latest Comments

eschwartz commented on 2018-04-19 18:13

"working", yes. "good", no. I've taken this opportunity to adopt the package and base it off of my [community] package.

Things you missed:

  • pygobject-devel is wrong and not needed at all, it does need to be able to import gi under both python and python2 (which means python{,2}-gobject).

  • The pkgver is wonky.

  • Some scripts require python in depends, unless you remove them which I have done because they are useless and require e.g. Debian-specific renames of the gist utility.

  • meson should use the "plain" releasetype in order to fully respect makepkg.conf

oberon2007 commented on 2018-04-16 21:58

I made a working PKGBUILD here: https://gist.github.com/oberon2007/63d6a4f028164dab28224f3ffd54435a

oberon2007 commented on 2018-04-16 21:22

PKGBUILD needs update!

/tmp/yaourt-tmp-user/aur-xapps-git/./PKGBUILD: line 27: ./autogen.sh: No such file or directory

xapps is using meson build now.

willemw commented on 2017-10-13 07:42

@kernelmd: It needed some more changes. Updated PKGBUILD file: https://gist.github.com/willemw12/83a6729e384f95eff2b186690c4b19c2

kernelmd commented on 2017-10-13 06:33

willemw, unfortunately I can't test it atm, as I don't have arch installed. The error should be fixed by installing gtk-doc package. Please try it and reply here with the results, so that I could update the package.

willemw commented on 2017-10-13 06:20

./autogen.sh: line 28: gtkdocize: command not found
==> ERROR: A failure occurred in build().

PKGBUILD of xapps has:
makedepends=('gnome-common' 'gobject-introspection')

kernelmd commented on 2016-11-06 10:04

oberon2007, thank you for feedback. I have just updated the package.

oberon2007 commented on 2016-11-03 10:44

depends=('libgnomekbd') needs to be added.
Thank you for the x-apps packages! :)