Package Details: xaralx 0.7_rev1785-10

Git Clone URL: https://aur.archlinux.org/xaralx.git (read-only)
Package Base: xaralx
Description: An advanced vector graphics program, development release
Upstream URL: http://www.xaraxtreme.org/
Licenses: GPL
Submitter: None
Maintainer: dark-saber
Last Packager: dark-saber
Votes: 79
Popularity: 0.300965
First Submitted: 2007-05-12 02:51
Last Updated: 2015-09-21 20:23

Latest Comments

dark-saber commented on 2015-09-21 20:18

@djringjr:
Thank you, I've updated the PKGBUILD based on your file, so the package should build fine on i686 machines.

djringjr commented on 2015-09-21 18:23

I have just left a new PKGBUILD file.

Make a folder / directory in a temporary place.

mkdir /tmp/xaralx

Save PKGBUILD (from the previous comment) to /tmp/xaralx

As regular user:
makepkg ./PKGBUILD

This file should be produced in /tmp/xaralx:
xaralx-0.7_rev1785-9-i686.pkg.tar.xz

To install xaralx as supervisor/root user:
pacman -U xaralx-0.7_rev1785-9-i686.pkg.tar.xz

For complete functionality of xaralx, install imagemagick.

As supervisor / root:
pacman -S imagemagick

xaralx will now work.


djringjr commented on 2015-09-21 18:15

# Maintainer: Dmitry Kharitonov <darksab0r@gmail.com>
# Contributor: mmm
# Contributor: Woody Gilk <woody@archlinux.org>
# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
# This file corrected and verified as working by: DJ Ring, Jr <n1ea@arrl.net>
pkgname=xaralx
pkgver=0.7_rev1785
pkgrel=9
pkgdesc="An advanced vector graphics program, development release"
arch=('i686' 'x86_64')
url="http://www.xaraxtreme.org/"
license=('GPL')
depends=('wxgtk' 'libpng' 'libjpeg' 'libxml2')
makedepends=('pkgconfig')
optdepends=('imagemagick: needed for some conversions')
install=${pkgname}.install
source=(http://downloads.xara.com/opensource/xaralx${pkgver}.tar.bz2)
md5sums=('14c6b270bcc1598b9b3d38f9a6db71aa')

if [ "$CARCH" = "x86_64" ]; then
depends+=(lib32-{libstdc++5 pangox-compat gtk2})
elif [ "$CARCH" = "i686" ]; then
depends+=(libstdc++5 pangox-compat gtk2)
fi


package() {
cd $srcdir/$pkgname
## needed for source/svn build
# autoreconf -f -i -s
# ./configure --prefix=/usr --enable-filters \
# --enable-xarlib --disable-svnversion --with-gnu-ld
# make
# make DESTDIR=$pkgdir install

install -d $pkgdir/usr/bin $pkgdir/usr/share/xaralx/doc $pkgdir/usr/share/licenses/xaralx
install -D -m755 bin/* $pkgdir/usr/bin
cp -R share/xaralx $pkgdir/usr/share/
chmod -R 644 $pkgdir/usr/share/xaralx
install -D -m644 share/xaralx/doc/LICENSE $pkgdir/usr/share/licenses/xaralx/LICENSE
# Desktop compatibility
install -D -m644 $pkgname.png $pkgdir/usr/share/pixmaps/$pkgname.png
install -D -m644 $pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
install -D -m644 $pkgname.xml $pkgdir/usr/share/mime/packages/$pkgname.xml
}

ids1024 commented on 2015-02-08 00:28

This no longer builds. Pacman does not support packages without a package() function anymore.

thore commented on 2014-10-26 11:41

Needed to add lib32-libstdc++5 as runtime dependency.

barton commented on 2014-05-11 19:12

==> WARNING: Using a PKGBUILD without a package() function is deprecated.

On i686 error while loading shared libraries: libpangox-1.0.so.0:
so 'pangox-compat' goes under the elif [ "$CARCH" = "i686" ] clause.

Hope to see an update soon. Thanks.

DaveCode commented on 2014-03-03 21:31

Super app, mmm. Voted. Please add lib32-gtk2 dep under PKGBUILD clause,
if [ "$CARCH" = "x86_64" ]

I guess upstream choice whether to use ImageMagick instead of GraphicsMagick.

Under "Help / About Xara Xtreme" the dialog shows wrong "Build date: 07-Nov-07" and posibly wrong wx lib. It shows wxWidgets 2.8.6 but I have

$ pacman -Qs wxgtk

local/mkvtoolnix-gtk 6.7.0-2
Set of tools to create, edit and inspect Matroska files - wxGTK GUI
local/wxgtk 3.0.0-2
GTK+ implementation of wxWidgets API for GUI
local/wxgtk2.8 2.8.12.1-1
GTK+ implementation of wxWidgets API for GUI

vanlong441 commented on 2013-09-26 02:49

for those who get

xaralx: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory

install lib32-gtk2

mmm commented on 2013-03-29 13:14

@all
Guys, sorry for the delay, I was busy these days. Thanks for sharing the upgrade info, changes incorporated in PKGBUILD.

@StefanHusmann
I dont understand why should I rename or remove a supported arch(!) from the PKGBUILD?
Anyway, if a TU wants to maintain this in [community], I would be happy for that. Just take this pkg and the name. Do i need to orphan it?

haawda commented on 2013-03-22 22:15

Please create a package xaralx-bin and let a TU merge these two packages. Also, please remove x86_64 from the arch array. The current name is misleading.

msx commented on 2013-03-21 04:02

@JGobell thank you :)

JGobeil commented on 2013-03-18 14:52

The program need 32bits libraries.
For 64bit system, add in dependencies multilib/lib32-libstdc++5 and aur/lib32-pangox-compat.

msx commented on 2013-01-19 05:52

Hi, I just discovered I can't run XaraLX anymore since I'm facing this library error:
xaralx: error while loading shared libraries: libpangox-1.0.so.0: cannot open shared object file: No such file or directory

Now, there's this lib32-pangox-compat package but it don't do any good since once installed I have:
xaralx: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory

Does anyone else have this glitch? Can anybody share the missing libs so I can install them manually and finally run XaraLX?
Thanks!

Auguste commented on 2012-08-10 05:31

this package is now binary version of the pre-compiled 32-bit executables. please adjust the dependencies accordingly for x86_64 to list the lib32- counterparts.

mmm commented on 2012-07-31 12:03

release -7 should fix some dependency issues reported here and on ML. Please test and let me know.
Nice summer!

Anonymous comment on 2012-07-18 20:07

Tested. Found a permissions problem on the directory at /usr/share/xaralx post-install. The application does not run after fixing that; I only get "no such file or directory '/usr/bin/xaralx'" and "can not execute child process xaralx" depending on how I attempt to launch the app (CLI or desktop).

The installation itself runs smoothly...

mmm commented on 2012-06-25 21:27

adopted, updated, should work. Please test and enjoy! mmm

ecraven commented on 2012-02-03 08:47

this seems to be a bug in the Makefile, which doesn't link against all libraries (gtk-x11, gdk-x11, gobjects, png14 and jpeg are missing). even after adding them in, XaraLX does not work on my machine. I'll disown this package, it seems to be rather unmaintained upstream :(

nitralime commented on 2012-02-01 09:31

I got the following error:
...
make[1]: Entering directory `/home/xxx/xaralx/src/XaraLX-0.7r1785'
g++ -Wl,--start-group Kernel/libKernel.a wxOil/libwxOil.a tools/libTools.a wxXtra/libwxXtra.a -Wl,--end-group --debug -L./libs/x86_64 -pthread -Wl,-O1,--sort-common,--as-needed,-z,relro,--hash-style=gnu -lwx_gtk2u_richtext-2.8 -lwx_gtk2u_aui-2.8 -lwx_gtk2u_xrc-2.8 -lwx_gtk2u_qa-2.8 -lwx_gtk2u_html-2.8 -lwx_gtk2u_adv-2.8 -lwx_gtk2u_core-2.8 -lwx_baseu_xml-2.8 -lwx_baseu_net-2.8 -lwx_baseu-2.8 -lpthread -lxml2 -lz -lm -lCDraw -o XaraLX
/usr/bin/ld: wxXtra/libwxXtra.a(libwxXtra_a-platform.o): undefined reference to symbol 'gtk_widget_set_name'
/usr/bin/ld: note: 'gtk_widget_set_name' is defined in DSO /usr/lib/libgtk-x11-2.0.so.0 so try adding it to the linker command line
/usr/lib/libgtk-x11-2.0.so.0: could not read symbols: Invalid operation
collect2: ld returned 1 exit status
make[1]: *** [XaraLX] Error 1
make[1]: Leaving directory `/home/xxx/xaralx/src/XaraLX-0.7r1785'
make: *** [all-recursive] Error 1
==> ERROR: A failure occurred in build().
Aborting...

ecraven commented on 2011-12-06 15:32

As the message "No space left on device" indicates, you seem to have no space left on the device where you build your packages.
Please make sure you have a gigabyte or two of space before building.

i18nde commented on 2011-12-06 07:37

Will not build, error output:
...

ranlib: libKernel.a: No space left on device
make[1]: *** [libKernel.a] Error 1
make[1]: Leaving directory `/tmp/yaourt-tmp-xxx/aur-xaralx/src/XaraLX-0.7r1785/Kernel'
make: *** [all-recursive] Error 1

Tried it several times, all the same. :(

Anonymous comment on 2010-12-06 04:43

I found some issues with your tarball. AUR guidelines suggest to not include binaries. This includes:
xaralx/xaralx-wxGTK-2.8.patch.bz2
Try to find sources for the binaries instead of embedding them. Besides, what is the point to tarballing already compressed files? Thank you.

Anonymous comment on 2010-11-23 21:32

I can't write any text on xara's sheet.

Instead, names of xara's files on the tabs appers inscription - DrawingView

ecraven commented on 2010-09-03 22:10

fixed with patch from gentoo/sourcemage, should work again

markuman commented on 2010-06-28 08:51

yeah, this project is pretty dead since magix bought xara ;-(
by the way, this PKGBUILD don't work anymore!

haawda commented on 2010-05-08 09:04

Thank you for reporting upstream, but I think the linux project is pretty dead.

td123 commented on 2010-05-06 14:54

Reported bug upstream to convert to libpng14. http://bugzilla.xara.com/show_bug.cgi?id=7408

cassava commented on 2010-04-14 09:41

Doesn't build anymore since libpng >= 1.4.
It needs to be built against libpng12 I think.