Package Details: xbps-git 0.51.r379.g59dffd76-1

Git Clone URL: https://aur.archlinux.org/xbps-git.git (read-only)
Package Base: xbps-git
Description: (Void Linux's) The X Binary Package System
Upstream URL: https://github.com/void-linux/xbps
Licenses: custom:2-clause-BSD
Submitter: oats
Maintainer: aksr
Last Packager: aksr
Votes: 1
Popularity: 0.000000
First Submitted: 2016-06-23 16:05
Last Updated: 2019-06-17 04:01

Latest Comments

TheGoliath commented on 2019-06-15 16:23

To get the package compiled successfully, you need to comment both license installs in the package section

daxx commented on 2018-09-04 08:33

Void Linux repos have moved from https://github.com/voidlinux to https://github.com/void-linux

AgustinCB commented on 2017-08-22 11:49

To be able to compile, I had to add this two lines before ./configure:

export LDFLAGS="$LDFLAGS -L/usr/lib/openssl-1.0"
export CFLAGS="$CFLAGS -I/usr/include/openssl-1.0 -Wno-error=implicit-fallthrough= -Wno-error=unsafe-loop-optimization -Wno-error=format-truncation="

xanc commented on 2017-05-28 13:48

I get this error:
fetch/common.c:898:3: error: ‘ASN1_STRING_data’ is deprecated [-Werror=deprecated-declarations]
ns = (const char *)ASN1_STRING_data(name->d.ia5);
^~
In file included from /usr/include/openssl/bn.h:31:0,
from /usr/include/openssl/asn1.h:24,
from /usr/include/openssl/objects.h:916,
from /usr/include/openssl/evp.h:27,
from /usr/include/openssl/x509.h:23,
from /usr/include/openssl/x509v3.h:14,
from fetch/common.c:62:
/usr/include/openssl/asn1.h:553:1: note: declared here
DEPRECATEDIN_1_1_0(unsigned char *ASN1_STRING_data(ASN1_STRING *x))
^
cc1: all warnings being treated as errors
make[1]: *** [Makefile:62: fetch/common.o] Error 1
make[1]: Leaving directory '/home/xan/aur/xbps-git/xbps-git/src/xbps/lib'
make: *** [Makefile:15: all] Error 1
==> ERROR: S'ha produït un error a build().
S'està cancel·lant...

socke commented on 2017-05-22 21:01

The build is failing because arch upgraded to openssl 1.1. To fix it, please add:

export LDFLAGS="$LDFLAGS -L/usr/lib/openssl-1.0"
export CFLAGS="$CFLAGS -I/usr/include/openssl-1.0"

right before the ./configure and change the openssl dependency to openssl-1.0.

Hope this will be fixed upstream soon.