Package Details: xcalib 0.10-1

Git Clone URL: https://aur.archlinux.org/xcalib.git (read-only)
Package Base: xcalib
Description: A tiny monitor calibration loader for X.org
Upstream URL: https://github.com/OpenICC/xcalib
Licenses: GPL2
Submitter: None
Maintainer: gato_lento
Last Packager: gato_lento
Votes: 188
Popularity: 0.498665
First Submitted: 2007-05-17 14:37
Last Updated: 2018-09-15 13:36

Dependencies (3)

Required by (2)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

taro-k commented on 2013-06-14 13:10

Thanks lot for your prompt response!

Oh, now I understand.
I should do donwload the tar ball rather than
wget https://aur.archlinux.org/packages/xc/*/PKGBUILD

Now I have installed successfully.

best regards,
Taro Konda

Gilrain commented on 2013-06-14 12:18

The patch is inside the tarball which can be downloaded through the Package Actions box on the right. Then it's just a matter of following the directions: <https://wiki.archlinux.org/index.php/AUR_User_Guidelines#Installing_packages>

taro-k commented on 2013-06-14 11:31

Hi, I am a beginner of Arch Linux.
I got the following error trying to build this package.
Where can I find it?

==> ERROR: makefile-ldflags.patch was not found in the build directory and is not a URL.

best regards

luolimao commented on 2012-08-20 16:31

Thanks for the update; I really appreciate it :)

luolimao commented on 2012-08-17 16:05

Also, the `libxxf86vm' package depends on the other 3 listed dependencies, so the other 3 are redundant and should be omitted: https://wiki.archlinux.org/index.php/Pkgbuild#depends
I have updated my version of the PKGBUILD to reflect this.

luolimao commented on 2012-08-17 16:02

The references in the PKGBUILD to $startdir/src and $startdir/pkg should be replaced by $srcdir and $pkgdir, respectively. My .makepkg.conf specifies that the building goes on in a special builds directory, so, in my case, $startdir/src doesn't even exist (I made it this way to avoid clutter). The variable $startdir has been deprecated for this very reason: https://wiki.archlinux.org/index.php/Creating_packages#Creating_a_PKGBUILD

Also, the `cp' command should be avoided in these sorts of scripts, and the `install' command used instead.

With these changes in mind, I have the rewritten PKGBUILD (I didn't bump the version; you can do so if you wish.) here: https://gist.github.com/3380143

frigg commented on 2012-04-28 14:43

celereon 55, in my archlinux there is already a symlink existant:
$ uname -a
Linux blubber 3.3.3-1-ARCH #1 SMP PREEMPT Mon Apr 23 09:33:32 UTC 2012

$ ls -lisaF /bin/du
3482999 0 lrwxrwxrwx 1 root root 11 Mar 27 04:16 /bin/du -> /usr/bin/du*

celeron55 commented on 2012-04-19 12:34

==> Creating package...
/usr/bin/makepkg: line 1129: /usr/bin/du: No such file or directory
/usr/bin/makepkg: line 1130: * 1024 : syntax error: operand expected (error token is "* 1024 ")

Workaround:
ln -s /bin/du /usr/bin/du

celeron55 commented on 2012-04-19 12:33

==> Creating package...
/usr/bin/makepkg: line 1129: /usr/bin/du: No such file or directory
/usr/bin/makepkg: line 1130: * 1024 : syntax error: operand expected (error token is "* 1024 ")

Workaround:
ln -s /bin/du /usr/bin/du

frigg commented on 2012-02-06 09:37

Votan, please post the output of
ldd xcalib
If you need a LUT loader immediately, have a look at the much newer dispwin binary of the argyllcms package.