Package Details: xcl-git 0.0.0.291.672.g1410ba8-5

Git Clone URL: https://aur.archlinux.org/xcl-git.git (read-only)
Package Base: xcl-git
Description: An native-code implementation of Common Lisp
Upstream URL: http://armedbear.org/
Licenses: GPL
Conflicts: xcl
Provides: common-lisp, xcl
Submitter: haawda
Maintainer: haawda
Last Packager: haawda
Votes: 1
Popularity: 0.000000
First Submitted: 2013-03-11 19:19
Last Updated: 2015-06-08 22:54

Required by (3)

Sources (2)

Latest Comments

haawda commented on 2014-06-26 09:56

Removed info documention provided by other packages.

haawda commented on 2014-01-12 15:59

added !makeflags and an install file.

hav3lock commented on 2013-05-02 20:54

Okay, well, I'll see if tinkering with it a bit helps any, and thank you for adding the 'common-lisp' thingy to the provides array. I really appreciate it.

haawda commented on 2013-05-02 18:54

I am not sure if it is error free, but I never got a core dump. Mainly using x86_84.

hav3lock commented on 2013-05-02 15:11

Does xcl-git run alright on your comp, Stefan? I get a core dump after I install it and then reboot.

;; (note this example was produced in xcl (non git, I think) but it happens with the git package too)

XCL 0.0.0.291 (x86-64)
Copyright (C) 2006-2011 Peter Graves
zsh: trace trap (core dumped) xcl

Not really sure what aspect of a reboot breaks it, but it doesn't seem to function after rebooting. It works just fine up to that point.

$ xcl
XCL 0.0.0.291-672-g1410ba8 (x86-64) built Thu May 2 11:07:24 EDT 2013
Copyright (C) 2006-2011 Peter Graves
Startup completed in 0.37 seconds.
Type ":help" for a list of available commands.
CL-USER(1):

Now, I checked the upstream site and they actually point out that they haven't tested it on x86_64, which is what I'm running it on, so it might just be that I'm not running it on x86.

hav3lock commented on 2013-05-02 15:09

Does xcl-git run alright on your comp, Stefan? I get a core dump after I install it and then reboot.

XCL 0.0.0.291 (x86-64)
Copyright (C) 2006-2011 Peter Graves
zsh: trace trap (core dumped) xcl

Not really sure what aspect of a reboot breaks it, but it doesn't seem to function after rebooting. It works just fine up to that point.

$ xcl
XCL 0.0.0.291-672-g1410ba8 (x86-64) built Thu May 2 11:07:24 EDT 2013
Copyright (C) 2006-2011 Peter Graves
Startup completed in 0.37 seconds.
Type ":help" for a list of available commands.
CL-USER(1):

Now, I checked the upstream site and they actually point out that they haven't tested it on x86_64, which is what I'm running it on, so it might just be that I'm not running it on x86.

hav3lock commented on 2013-05-02 04:09

please add 'common-lisp' to the provides array, per the wiki's instruction of lisp packages, more specifically packaging lisp implementations.

https://wiki.archlinux.org/index.php/Lisp_Package_Guidelines

haawda commented on 2013-03-11 19:22

First upload.