Package Details: xdg-utils-mimeo 1.1.1-4

Git Clone URL: https://aur.archlinux.org/xdg-utils-mimeo.git (read-only)
Package Base: xdg-utils-mimeo
Description: Command line tools that assist applications with a variety of desktop integration tasks; patched to use mimeo
Upstream URL: https://wiki.freedesktop.org/www/Software/xdg-utils/
Keywords: mime mimeo xdg-open
Licenses: MIT
Conflicts: xdg-utils
Provides: xdg-utils
Submitter: matthewbauer
Maintainer: TrialnError
Last Packager: TrialnError
Votes: 59
Popularity: 0.876704
First Submitted: 2009-12-16 04:08
Last Updated: 2016-08-02 11:03

Dependencies (15)

Required by (341)

Sources (4)

Latest Comments

TrialnError commented on 2016-02-18 09:47

@unitaker: Unless the DE is detected as xfce xdg-utils shouldn't use exo. This doesn't prevent the case with thunar and xfburn, which explicit depends on exo. I suppose those call/use exo directly.

Or does this also happen with a terminal and using xdg-open?

Edit: To make it clear. Currently the only way which would let xdg-utils choose exo:
XDG_CURRENT_DESKTOP is set to XFCE.
If the var is empty, which happens without a running DE, it falls back to simple if-then checks.
There it would be again possible that the desktop is detected as xfce. But only if xfwm4 is used as window manager. Or whatever would cause xprop -root to report xfce4 somewhere in its output.[0]

But dunno if such a setup is used. If so, I could move the check for mimeo up a bit.
Or maybe I will do it anyway. Will think about it.
_______
[0] https://cgit.freedesktop.org/xdg/xdg-utils/tree/scripts/xdg-utils-common.in#n249

untitaker commented on 2016-02-16 17:28

Could the patch be changed such that mimeo is preferred over open_xfce and others? I have xfburn installed which pulls in exo (xfce's app launcher thing), which then gets prioritized over mimeo.

TrialnError commented on 2016-01-01 18:08

@ d7rk:
That means you haven't the puplic gpg/pgp key of the developer in your gpg key database.

Either invoke makepkg with --nopgpcheck, disable/remove the validpgpkey line or use gnupg and download the key (gnupg --recv-keys followed by the id from the pkgbuild)

d7rk commented on 2016-01-01 17:13

Hi,

I get
Verifying source file signatures with gpg...
xdg-utils-1.1.1.tar.gz ... FAILED (unknown public key C43570F80CC295E6)
==> ERROR: One or more PGP signatures could not be verified!

when trying to install.
Cheers,

TrialnError commented on 2016-01-01 15:18

@eigengrau: Updated the patch. If DE is still mimeo it will use for screensaver the generic method.
Setting the DE to generic won't work, as this function is included in every xdg-* script. And in the other scripts (at least those touched by the patch) there are specific calls to mimeo. So no general generic call


Edit: *cough* added the missing char from the name. although eigengau got something for it too :D

TrialnError commented on 2015-12-30 21:21

Thanks for the intel you provided.
I will look at the patch and your proposal

eigengrau commented on 2015-12-28 20:36

Sorry, the complete patch is here instead:

https://ptpb.pw/Awus.patch

eigengrau commented on 2015-12-28 20:34

I’ve noticed that xdg-screensaver doesn’t work anymore when mimeo-detection.diff is applied. This is because xdg-screensaver has a case statement which will trip over DE=mimeo. I’ve added a patch to the PKGBUILD here:

https://ptpb.pw/q7to.diff

One alternative might be not setting DE to "mimeo" in your original patch, but using "generic" instead, since "generic" is already recognized in xdg-screensaver. Whether that works of course depends on whether you strictly need it to be "mimeo" somewhere else.

TrialnError commented on 2015-07-25 16:59

So, updated.
I added the those functions, but they do the same like the xfce ones (more or less nothing)
If this should be something else, or you notice problems please comment

TrialnError commented on 2015-07-25 16:41

Ok, I think I figured it out.
Even on older versions default-url-scheme-handler) should have failed because there weren't a default-url-scheme-handler-mimeo function.

So next question. Should it even exist?

TrialnError commented on 2015-07-25 15:42

I want to update in advance the xdg-utils package, as they made some big changes.
But I need some help in one point, as I don't have currently the insight what is the best course.

Offending commit:
http://cgit.freedesktop.org/xdg/xdg-utils/commit/?id=0e9b529de574e2b9495c5a8f3d64db6dc7acde70

THe dispatch_specific changed significantly and I'm not sure if mimeo should be added as extra or if it can be snugged into on of the others.
Not sure because of what is happening at
line: 681: default-url-scheme-handler)

TrialnError commented on 2015-07-25 15:41

I want to update in advance the xdg-utils package, as they made some big changes.
But I need some help in one point, as I don't have currently the insight what is the best course.

Offending commit:
http://cgit.freedesktop.org/xdg/xdg-utils/commit/?id=0e9b529de574e2b9495c5a8f3d64db6dc7acde70

THe dispatch_specific changed significantly and I'm not sure if mimeo should be added as extra or if can be snugged into on of the others.
Not sure because of what is happending at
line: 681: default-url-scheme-handler)

TrialnError commented on 2014-10-31 21:37

Dunno about the w3m thing. It built for me without w3m installed in a clean chroot

sxty commented on 2014-02-17 19:45

I had to install w3m for the build to work. Apparently xmlto has an undisclosed dependency to w3m?

Also, xmlto uses bashisms... >_<

TrialnError commented on 2013-11-13 19:09

And your point is?
You don't have these makedepends installed on your system, therefore the error.
Issue makepkg -sr to circumvent such messages.

Or is something else with these?

rafi commented on 2013-11-01 14:35

==> Missing dependencies:
-> docbook-xsl
-> lynx
-> xmlto

TrialnError commented on 2013-08-21 21:55

Another follow-up for the package in [extra]

TrialnError commented on 2013-02-16 17:54

I updated the PKGBuild and the patch files to follow the xdg-utils package from [extra]

PKGBuild: http://pastie.org/6196735
Patch: http://pastie.org/6196741

untitaker commented on 2012-03-13 15:04

This package doesn't build anymore... complains about a missing Makefile.

edke commented on 2011-09-23 14:00

Hello.

xdg-open is still not working after installation of xdg-utils-mimeo and mineo. More info at https://bbs.archlinux.org/viewtopic.php?pid=994440#p994440

Vithon commented on 2011-03-28 13:19

Instead of having this if loop checking for mimeo, wouldn't it be easier and quicker to just add mimeo to the depends array in the PKGBUILD?

xduugu commented on 2011-03-13 23:12

Since mimeo also supports file uris now, there is no need to change this package anymore.

ngoonee commented on 2011-03-10 23:50

Sorry, this one. The other one had a typo http://pastebin.com/P9eJ0BTM

ngoonee commented on 2011-03-10 23:49

http://pastebin.com/mDxr2B3V is an example of what I meant.

ngoonee commented on 2011-03-10 23:42

Can I suggest that the mimeo lines be added both prior to the open_generic_xdg_mime (to catch file:// links) and before checking for BROWSER? As it is now mimeo itself does not handle file:// links

Schnouki commented on 2011-02-09 12:48

Much better :)
Thank you guys for the quick fix!

jackoneill commented on 2011-02-09 12:35

@xduugu: thanks

Updated.

xduugu commented on 2011-02-09 11:22

Setting BROWSER to mimeo seems to work, but that's not what I meant. Nice solution anyway. :)

I've updated the patch so that mimeo will be called for any input. Sorry for the noise, guys.
http://aur.pastebin.com/MTbh1QKt

xduugu commented on 2011-02-09 11:21

Setting BROWSER to mimeo seems to work, but that's not what I meant. Nice solution anyway. :)

I've updated the patch so that mimeo will be called for any input. Sorry for the noise, guys.
http://aur.pastebin.com/S7dS3egq

Schnouki commented on 2011-02-09 10:49

What about URLs that should not be opened by a browser but by something else? Like mailto:, ftp://, spotify:... Right now this does not work anymore. Or should I set BROWSER to "mimeo"?

jackoneill commented on 2011-02-09 10:49

>Lastest version stopped working with url's,

Gah. Guess I should use the packages I maintain... (actually I have this installed, I just don't use xdg-open)

If anyone has a fix (and possibly wants to maintain this?) I'll be most grateful...

xduugu commented on 2011-02-09 10:45

Works fine. Just set your BROWSER variable.

thibm commented on 2011-02-09 10:39

Hello,

Lastest version stopped working with url's, because in open_generic() mimeo is only called on paths or file://, and not outside the 'if' block starting line 415

Thibault

jackoneill commented on 2011-02-08 11:33

Ugh. Hard tabs ftl.

jackoneill commented on 2011-02-08 11:31

@xduugu:
Thanks.

Took the latest xdg-utils from abs and patched it.

xduugu commented on 2011-02-05 12:51

mimeo patch for xdg-utils 1.10rc1: http://aur.pastebin.com/VJBcWKhz

jackoneill commented on 2010-08-24 12:43

Hello.

This package does not build:
==> Starting build()...
Cloning into xdg-utils...
fatal: http://git.archlinux.de/~pierre/xdg-utils.git/info/refs not found: did you run git update-server-info on the server?
Aborting...

I've adapted the pkgbuild from extra/xdg-utils and corrected the mimeo.patch. Here's the tarball: http://omploader.org/iNWJuZw
It does build, but I haven't tested it yet.

jackoneill commented on 2010-08-24 12:31

Hello.

This package does not build:
==> Starting build()...
Cloning into xdg-utils...
fatal: http://git.archlinux.de/~pierre/xdg-utils.git/info/refs not found: did you run git update-server-info on the server?
Aborting...

I've adapted the pkgbuild from extra/xdg-utils and corrected the mimeo.patch. Here's the tarball: http://omploader.org/iNWJuZw
It does build, but I haven't tested it yet.