Package Details: xen-docs 4.18.1pre-1

Git Clone URL: https://aur.archlinux.org/xen.git (read-only, click to copy)
Package Base: xen
Description: Xen hypervisor documentation and man pages
Upstream URL: https://xenproject.org/
Keywords: hypervisor virtualization xen
Licenses: GPL2
Submitter: sergej
Maintainer: Refutationalist
Last Packager: Refutationalist
Votes: 186
Popularity: 1.12
First Submitted: 2009-11-09 11:22 (UTC)
Last Updated: 2024-01-19 23:00 (UTC)

Dependencies (36)

Required by (1)

Sources (17)

Pinned Comments

Refutationalist commented on 2024-05-22 22:08 (UTC) (edited on 2024-05-23 00:07 (UTC) by Refutationalist)

As of now (2024-22-05) Xen with stubdom doesn't build because of a problem in the imported code. Been this way for about two weeks. Anyone else seeing this behavior?

Also, there is a lot of work happening on Xen in my development repo, thanks to @Serus. Check it out at: https://github.com/refutationalist/saur

Latest Comments

1 2 3 4 5 6 .. 101 Next › Last »

Refutationalist commented on 2024-05-22 22:08 (UTC) (edited on 2024-05-23 00:07 (UTC) by Refutationalist)

As of now (2024-22-05) Xen with stubdom doesn't build because of a problem in the imported code. Been this way for about two weeks. Anyone else seeing this behavior?

Also, there is a lot of work happening on Xen in my development repo, thanks to @Serus. Check it out at: https://github.com/refutationalist/saur

daurnimator commented on 2024-01-22 05:27 (UTC)

FYI I plan on moving parts of xen to [extra] soon. Not all functionality of this AUR package will be retained, and you will likely have to e.g. have stubdom parts as their own AUR package xen-stubdom or similar

lapuglisi commented on 2023-09-12 00:43 (UTC) (edited on 2023-09-12 00:45 (UTC) by lapuglisi)

@Refutationalist

We need to change the file 'add-stubdom-fuxes.patch' to contain a new line, so it looks like this:

diff -Naur orig.xen-4.16.1/stubdom/Makefile xen-4.16.1/stubdom/Makefile
--- orig.xen-4.16.1/stubdom/Makefile    2022-05-16 09:41:38.409898784 -0700
+++ xen-4.16.1/stubdom/Makefile 2022-05-16 09:43:31.891076356 -0700
@@ -241,6 +241,7 @@
    patch -d $@ -p1 < vtpm_extern.patch
    patch -d $@ -p1 < vtpm-microsecond-duration.patch
    patch -d $@ -p1 < vtpm-command-duration.patch
+   patch -d $@ -p1 < vtpm-gcc12-fixes.patch
    patch -d $@ -p1 < vtpm-tpm_bn_t-addr.patch
    mkdir $@/build
    cd $@/build; CC=${CC} $(CMAKE) .. -DCMAKE_C_FLAGS:STRING="-std=c99 -DTPM_NO_EXTERN $(TARGET_CPPFLAGS) $(TARGET_CFLAGS) -Wno-declaration-after-statement"
    touch $@

Add line patch -d $@ -p1 < vtpm-tpm_bn_t-addr.patch right after + patch -d $@ -p1 < vtpm-gcc12-fixes.patch to match the contents of src/xen/stubdom/Makefile (the target file for the patch).

Refutationalist commented on 2023-07-11 22:05 (UTC)

Most recent change removes OCaml, as it was supposed to be doing that anyway. Building issues are gone.

lapuglisi commented on 2023-07-03 14:04 (UTC)

For those of you facing the issue below:

xentoollog_stubs.c: In function ‘stub_xtl_ocaml_vmessage’: xentoollog_stubs.c:36:1: error: ‘caml_local_roots’ undeclared (first use in this function); did you mean ‘caml_local_roots_ptr’? 36 | caml_local_roots = caml__frame; \ | ^~~~~~~~~~~~~~~~
xentoollog_stubs.c:114:9: note: in expansion of macro ‘CAMLdone’ 114 | CAMLdone;
| ^~~~~~~~
xentoollog_stubs.c:36:1: note: each undeclared identifier is reported only once for each function it appears in 36 | caml_local_roots = caml__frame; \ | ^~~~~~~~~~~~~~~~
xentoollog_stubs.c:114:9: note: in expansion of macro ‘CAMLdone’ 114 | CAMLdone;
| ^~~~~~~~
xentoollog_stubs.c: In function ‘stub_xtl_ocaml_progress’: xentoollog_stubs.c:36:1: error: ‘caml_local_roots’ undeclared (first use in this function); did you mean ‘caml_local_roots_ptr’? 36 | caml_local_roots = caml__frame; \ | ^~~~~~~~~~~~~~~~ xentoollog_stubs.c:140:9: note: in expansion of macro ‘CAMLdone’ 140 | CAMLdone; | ^~~~~~~~

One workaround is to add the option '--disable-ocamltools' to the './configure' command line in the 'build' function inside PKGBUILD.

Finebread commented on 2023-06-19 18:00 (UTC)

I experience a same problem like manueljben posted here. During installation I get the same error. I tried older Xen version and I got the same error. I tried to change caml_local_roots to caml_local_roots_ptr, didn't work out.

manueljben commented on 2023-06-13 17:11 (UTC) (edited on 2023-06-13 17:11 (UTC) by manueljben)

new problem arised to me today... :-(

xentoollog_stubs.c: In function ‘stub_xtl_ocaml_vmessage’: xentoollog_stubs.c:36:1: error: ‘caml_local_roots’ undeclared (first use in this function); did you mean ‘caml_local_roots_ptr’? 36 | caml_local_roots = caml__frame; \ | ^~~~~~~~~~~~~~~~
xentoollog_stubs.c:114:9: note: in expansion of macro ‘CAMLdone’ 114 | CAMLdone;
| ^~~~~~~~
xentoollog_stubs.c:36:1: note: each undeclared identifier is reported only once for each function it appears in 36 | caml_local_roots = caml__frame; \ | ^~~~~~~~~~~~~~~~
xentoollog_stubs.c:114:9: note: in expansion of macro ‘CAMLdone’ 114 | CAMLdone;
| ^~~~~~~~
xentoollog_stubs.c: In function ‘stub_xtl_ocaml_progress’: xentoollog_stubs.c:36:1: error: ‘caml_local_roots’ undeclared (first use in this function); did you mean ‘caml_local_roots_ptr’? 36 | caml_local_roots = caml__frame; \ | ^~~~~~~~~~~~~~~~ xentoollog_stubs.c:140:9: note: in expansion of macro ‘CAMLdone’ 140 | CAMLdone; | ^~~~~~~~

Refutationalist commented on 2023-05-15 03:12 (UTC)

personal update: It's going to be a bit before I can really look at these changes as I've had hand surgery and typing is not recommended at the moment. Feel free to keep submitting patches here or PRs at my github and I'll update the package itself as soon as I can.