Package Details: xerox-workcentre-6515-6510 5.662.0.0-3

Git Clone URL: https://aur.archlinux.org/xerox-workcentre-6515-6510.git (read-only, click to copy)
Package Base: xerox-workcentre-6515-6510
Description: Xerox WorkCentre 6515 / Phaser 6510 printer driver for CUPS
Upstream URL: https://www.support.xerox.com/en-us/product/workcentre-6515/content/144488?language=en&platform=win10
Keywords: 6515 cups ppd workcentre xerox
Licenses: custom
Submitter: rew1red
Maintainer: rew1red
Last Packager: rew1red
Votes: 1
Popularity: 0.000158
First Submitted: 2019-09-16 18:00 (UTC)
Last Updated: 2022-03-25 17:21 (UTC)

Dependencies (2)

Required by (0)

Sources (2)

Latest Comments

brumaba commented on 2022-03-26 13:52 (UTC) (edited on 2022-03-30 09:23 (UTC) by brumaba)

@rew1red thank you very much for the update. I have been able to install via pamac-cli, but not with pamac-gui, as the install requires user interaction to confirm the overwriting of virtually all files ( APWlaunch.bat launchAPW.bat Setup32.exe Setup64.exe xrcnsur.cat xrcnsur_ppd.inf xrx6510.ppd xrx6515.ppd XSetupCpu.exe) with an apparently exact version. Not sure if it is due to my previous failed attempts, even though I retried a few times after uninstall and clean files with same result.

EDIT: Same overwriting of extracted files when updating this package in my other boxes. Hope this is not a security issue.

rew1red commented on 2022-03-25 17:21 (UTC) (edited on 2022-03-25 17:21 (UTC) by rew1red)

@brumaba it looks like they've make some sort of a stealthy update. The signature of the .exe has changed, although they have not released a new version. I have updated the PKGBUILD to match.

! WARNING:

The signature of xerox-workcentre-6515-6510.exe was previously 29b83d7276b167fdb0cbbd1e110b424658ca1e93b781cab674d6a93a2df5f7a9, and has changed to f24786cf0310ba71afdb4529f25829c8b589cdc7a842e1c2ea0a9a3e101a9111 without a version update. This is probably just an un-versioned change from Xerox, but caution should be exercised whenever a signature changes without warning.

brumaba commented on 2022-03-25 12:32 (UTC) (edited on 2022-03-25 12:37 (UTC) by brumaba)

Thank you for the build. I have successfully using previous versions but cannot install this one on a freshly installed manjaro:

Construyendo xerox-workcentre-6515-6510...
==> Creando el paquete: xerox-workcentre-6515-6510 5.662.0.0-2 (vie 25 mar 2022 12:48:50)
==> Comprobando dependencias mientras se ejecuta...
==> Comprobando dependencias mientras se compila...
==> Recibiendo las fuentes..
-> LICENSE ha sido encontrado
-> xerox-workcentre-6515-6510.exe ha sido encontrado
==> Validando los archivos source con sha256sums...
LICENSE ... Aprobado
xerox-workcentre-6515-6510.exe ... HA FALLADO
==> ERROR: ¡Uno o más archivos no superaron el control de validación!
Error al compilar xerox-workcentre-6515-6510

Downloaded file 'Phaser_6510_5.662.0.0_PPD_English.exe' has a sha258sum = 'f24786cf0310ba71afdb4529f25829c8b589cdc7a842e1c2ea0a9a3e101a9111' which does not match with any in the pkgbuild.

rew1red commented on 2021-07-26 13:53 (UTC)

@m4ug--

Thanks for letting me know! They must have finally switched to a secure download URL. I've revised the PKGBUILD for future users.

m4ug commented on 2021-07-25 16:33 (UTC)

I was having issues downloading the file. I noticed when I manually downloaded it, it was https instead of http, so I updated the URL in the PKG, and it worked just fine.

cat xerox-6515-6510.patch 
--- PKGBUILD    2021-07-25 11:27:01.558288318 -0500
+++ PKGBUILD.new    2021-07-25 11:09:50.948290355 -0500
@@ -10,7 +10,7 @@
 depends=('cups')
 makedepends=('unrar')
 source=('LICENSE'
-        "$pkgname.exe::http://download.support.xerox.com/pub/drivers/6510/drivers/win10/ar/Phaser_6510_${pkgver}_PPD_English.exe"
+        "$pkgname.exe::https://download.support.xerox.com/pub/drivers/6510/drivers/win10/ar/Phaser_6510_${pkgver}_PPD_English.exe"
 )
 sha256sums=('98ec516f5a59dc7b664f8c646efe3eb3f956c3b6de97779359ca1f5ffe849083'
             '29b83d7276b167fdb0cbbd1e110b424658ca1e93b781cab674d6a93a2df5f7a9'