Package Details: xf86-video-ati-git 7.5.0.r75.gafab783-1

Git Clone URL: https://aur.archlinux.org/xf86-video-ati-git.git (read-only)
Package Base: xf86-video-ati-git
Description: X.org ati video driver. Git version
Upstream URL: http://xorg.freedesktop.org/
Licenses: custom
Conflicts: X-ABI-VIDEODRV_VERSION<19, X-ABI-VIDEODRV_VERSION>=20, xf86-video-ati, xorg-server<1.16.0
Provides: xf86-video-ati
Submitter: vbmithr
Maintainer: MRLemux
Last Packager: MRLemux
Votes: 185
Popularity: 0.289726
First Submitted: 2008-02-25 18:44
Last Updated: 2015-09-10 14:46

Latest Comments

mnovick1988 commented on 2016-05-03 21:38

looks abandoned. its been tagged and i brought up the issue a few times. the maintainer deletes my comments and ignore it.

ciupenhauer commented on 2016-04-13 21:29

Is anyone still maintaining this?

cpatrick08 commented on 2015-09-07 21:46

wont build if xorg-server-git is installed

MRLemux commented on 2015-02-10 16:29

Updated it, should now work again.

MRLemux commented on 2014-11-01 11:34

This should depend on xorg-server-git as the radeon driver is made with the X git tree in mind.

Dasonk commented on 2014-10-06 00:01

You should add git as a make dependency

tomkwok commented on 2014-09-27 04:42

Updated. I'm sorry for the delay.

confusedfla commented on 2014-09-24 10:55

@tomkwok: Do you have time/interest in maintaining this package?

This package doesn't work without the fix provided by @kerberizer and with > 200 votes people are/will encounter this ;-)

kerberizer commented on 2014-08-08 02:10

The following seems to work with the new Xorg 1.16...

-depends=('libdrm>=2.4.41' 'systemd' 'ati-dri' 'glamor-egl')
-makedepends=('xorg-server-devel' 'X-ABI-VIDEODRV_VERSION=15')
-conflicts=('xorg-server<1.15.0' 'X-ABI-VIDEODRV_VERSION<15' 'X-ABI-VIDEODRV_VERSION>=16' 'xf86-video-ati')
+depends=('libdrm>=2.4.41' 'systemd' 'ati-dri')
+makedepends=('xorg-server-devel' 'X-ABI-VIDEODRV_VERSION=18')
+conflicts=('xorg-server<1.16.0' 'X-ABI-VIDEODRV_VERSION<18' 'X-ABI-VIDEODRV_VERSION>=19' 'xf86-video-ati')

kerberizer commented on 2014-07-11 09:55

May I suggest adding the following pkgver function to the PKGBUILD...

pkgver() {
cd "${srcdir}/xf86-video-ati"
echo $(git describe --long | sed -r 's/^xf86-video-ati-//;s/([^-]*-g)/r\1/;s/-/./g')
}

The package version would then be something like "7.4.0.r2.gc4ae0e2-1", which would help to keep better track on what exactly code the package was built from.

All comments