Package Details: xf86-video-sis 0.10.8-3

Git Clone URL: (read-only)
Package Base: xf86-video-sis
Description: SiS video driver
Upstream URL:
Licenses: custom
Groups: xorg-drivers
Conflicts: X-ABI-VIDEODRV_VERSION<23, X-ABI-VIDEODRV_VERSION>=24, xorg-server<1.19
Submitter: lordheavy
Maintainer: None
Last Packager: lordheavy
Votes: 1
Popularity: 0.000211
First Submitted: 2017-01-14 20:27
Last Updated: 2017-01-14 20:27

Latest Comments

thx1138 commented on 2017-04-04 21:26

A git bisect tracked this back to

The quick fix is the "iomem=relaxed" command line parameter, which will be required with the Arch kernels from 4.5 and later.

thx1138 commented on 2017-03-18 04:12

This driver works fine with the older linux-lts 4.4 kernels, but has a problem with later kernels, where the log ends with:

(EE) SIS(0): Unable to map FB aperture. Invalid argument (22)
(EE) SIS(0): **************************************************
(EE) SIS(0): SiSMapMem() failed
(EE) SIS(0): **************************************************

Something changed between the 4.4 and 4.5 kernels, if anyone wants to track it down, possibly related to libpciaccess.

For a compatible linux-lts 4.4 kernel, see:

Note that this driver does *not* use the kernel/drivers/gpu/drm/sis/sis.ko.gz module, and it is not needed.