Package Details: xfce-polkit-git 19.fabc2f7-1

Git Clone URL: https://aur.archlinux.org/xfce-polkit-git.git (read-only)
Package Base: xfce-polkit-git
Description: A simple PolicyKit authentication agent for XFCE
Upstream URL: https://github.com/ncopa/xfce-polkit
Licenses: GPL
Conflicts: polkit-gnome, xfce-polkit
Provides: polkit-gnome, xfce-polkit
Submitter: eviveiro
Maintainer: frederik
Last Packager: frederik
Votes: 16
Popularity: 0.088730
First Submitted: 2015-02-23 07:24
Last Updated: 2016-05-27 16:02

Required by (16)

Sources (2)

Latest Comments

TrialnError commented on 2016-05-27 15:57

Hi
This PKGBUILD and the one from the non-git version do something which is really unusual for Arch.
The user needs to manually enable services and configure the system.
Those PKGBUILDs, or more specific the install file is doing this kind of thing upon installing the package.
This shouldn't be the done, so maybe you could remove those install files?

Best regards

PS: Before writing this I asked on the ML about this. See https://lists.archlinux.org/pipermail/aur-general/2016-May/032327.html

eviveiro commented on 2015-03-03 16:18

Thanks for the knowledge, I'm still fairly new to bash scripting. I believe I updated it correctly now.

killermoehre commented on 2015-03-03 14:33

Hi eviveiro,

you updates the entries in the wrong way. The lines have to be

Provides=("${_pkgname}" "polkit-gnome")
Conflicts=("${_pkgname}" "polkit-gnome")

That's the way arrays in bash work.

eviveiro commented on 2015-03-02 22:56

Updated provides and conflicts as suggested.

killermoehre commented on 2015-03-02 13:00

Some thoughts: please add
Provides="polkit-gnome"
Conflicts="polkit-gnome"
so it can be used as drop-in replacement for gnome-polkit (new hard dependency for xfce4-session).