Package Details: xfce4-cpufreq-plugin-git 1:1.2.1.r7.ga6a515f-1

Git Clone URL: https://aur.archlinux.org/xfce4-cpufreq-plugin-git.git (read-only)
Package Base: xfce4-cpufreq-plugin-git
Description: CPU frequency plugin for the Xfce4 panel (git checkout)
Upstream URL: http://goodies.xfce.org/projects/panel-plugins/xfce4-cpufreq-plugin
Licenses: GPL2
Groups: xfce4-goodies
Conflicts: xfce4-cpufreq-plugin
Provides: xfce4-cpufreq-plugin
Submitter: xavery
Maintainer: FredBezies
Last Packager: FredBezies
Votes: 3
Popularity: 0.000001
First Submitted: 2013-08-27 20:36
Last Updated: 2019-01-24 16:00

Latest Comments

FredBezies commented on 2019-01-16 12:43

And a working and updated PKGBUILD:

# Adapted for git by xavery <dkk089@gmail.com>, based on original PKGBUILD by :
# Maintainer: AndyRTR <andyrtr@archlinux.org>
# Contributor: tobias <tobias funnychar archlinux.org>

pkgname=xfce4-cpufreq-plugin-git
_gitname=xfce4-cpufreq-plugin
pkgver=1.2.1.r7.ga6a515f
pkgrel=1
epoch=1
pkgdesc="CPU frequency plugin for the Xfce4 panel (git checkout)"
arch=('i686' 'x86_64')
license=('GPL2')
url="http://goodies.xfce.org/projects/panel-plugins/xfce4-cpufreq-plugin"
groups=('xfce4-goodies')
depends=('xfce4-panel-git' 'hicolor-icon-theme')
makedepends=('intltool' 'git' 'xfce4-dev-tools' 'autoconf' 'libtool')
provides=('xfce4-cpufreq-plugin')
conflicts=('xfce4-cpufreq-plugin')
options=('!libtool')
source=('git://git.xfce.org/panel-plugins/xfce4-cpufreq-plugin')
sha256sums=('SKIP')

pkgver() {
  cd ${_gitname}
  git describe --long | sed 's/^xfce4.cpufreq.plugin-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}

build() {
  cd ${_gitname}
  mkdir m4
  NOCONFIGURE=1 ./autogen.sh
  ./configure --prefix=/usr \
  --sysconfdir=/etc \
  --libexecdir=/usr/lib \
  --localstatedir=/var \
  --disable-static \
  --disable-debug
  make
}

package() {
  cd ${_gitname}
  make DESTDIR=${pkgdir} install
}

FredBezies commented on 2019-01-16 12:33

This PKGBUILD need some cleaning: libxfcegui4 is deprecated. You only need xfce4-panel-git in depends() line.

And install file is now useless...

xavery commented on 2013-09-03 20:27

@drhill1 : Thanks! PKGBUILD updated.

drhill1 commented on 2013-09-03 18:53

Just installed this and it works great, but the pkgver() line within PKGBUILD provides a version that keeps wanting to be updated. I changed the line to the same as that in exo-git and all works well.