Package Details: xfce4-dockbarx-plugin 0.6+r62+f7585b5-1

Git Clone URL: https://aur.archlinux.org/xfce4-dockbarx-plugin.git (read-only, click to copy)
Package Base: xfce4-dockbarx-plugin
Description: Embed DockbarX in the xfce4-panel
Upstream URL: https://github.com/m7s/xfce4-dockbarx-plugin
Licenses: X11
Submitter: twa022
Maintainer: twa022
Last Packager: twa022
Votes: 73
Popularity: 1.07
First Submitted: 2013-03-31 02:53
Last Updated: 2020-08-02 19:09

Latest Comments

1 2 3 Next › Last »

gameslayer commented on 2020-03-23 03:18

@twa022 thank you very much!

twa022 commented on 2020-03-22 18:29

@gameslayer: added a patch; should build okay now.

gameslayer commented on 2020-03-20 11:09

Can't install package due to this issue

gtk+-2.0.vapi:5873.40-5873.42: warning: Gtk is deprecated. Use gtk+-3.0 libxfce4panel-1.0.vapi:102.3-102.41: error: overriding method Xfce.PanelPlugin.remote_event' is incompatible with base methodbool Xfce.PanelPluginProvider.remote_event (string, GLib.Value, uint)': too few parameters. /mnt/Storage/AUR/xfce4-dockbarx-plugin/src/xfce4-dockbarx-plugin/src/dockbarx.vala:81.22-81.24: warning: Gtk is deprecated. Use gtk+-3.0 /mnt/Storage/AUR/xfce4-dockbarx-plugin/src/xfce4-dockbarx-plugin/src/preferences.vala:135.9-135.11: warning: Gdk is deprecated. Use gdk-3.0 /mnt/Storage/AUR/xfce4-dockbarx-plugin/src/xfce4-dockbarx-plugin/src/dockbarx.vala:56.9-56.21: warning: unhandled error Xfconf.Error' Waf: Leaving directory/mnt/Storage/AUR/xfce4-dockbarx-plugin/src/xfce4-dockbarx-plugin/build' Build failed -> task failed (exit status 1): {task 139714940771344: valac dockbarx.vala,preferences.vala -> dockbarx.c,preferences.c} '' ==> ERROR: A failure occurred in build(). Aborting...

gargakumar commented on 2019-08-13 08:41

Can also confirm that uninstalling, restarting XFCE and reinstalling fixed the plugin after latest XFCE update.

Noammac commented on 2019-08-12 15:04

Can confirm that reinstallation works. Not sure why.

kzoli429 commented on 2019-08-12 12:39

Yes it really stopped. However, try to uninstall it, reboot, then reinstall. For me, it works again.

Noammac commented on 2019-08-12 12:34

Doesn't work after 4.14 update. According to following statement by developer, unless someone goes and fixes it, it won't be fixed for a long time: https://github.com/TiZ-EX1/xfce4-dockbarx-plugin/issues/35

gameslayer commented on 2019-07-09 16:23

[UPDATE]

Now works after the latest xfce4-panel update came out!

Fails to build

Checking xfce4-dockbarx-plugin dependencies...

Checking for 'libxfce4panel-1.0' >= 4.8 : not found The configuration failed (complete log in /var/tmp/pamac-build-corey/xfce4-dockbarx-plugin/src/xfce4-dockbarx-plugin/build/config.log) ==> ERROR: A failure occurred in build(). Aborting...

Silejonu commented on 2019-05-07 09:26

Hey, you should add "patch" as a dependency! =)

entidi commented on 2018-08-20 13:56

vala should be moved into makedepends. I am succesfully using it after having uninstalled vala forcibly.