Package Details: xfce4-multiload-nandhp-plugin-git 20130612-2

Git Clone URL: https://aur.archlinux.org/xfce4-multiload-nandhp-plugin-git.git (read-only, click to copy)
Package Base: xfce4-multiload-nandhp-plugin-git
Description: Multiload panel plugin for Xfce panel
Upstream URL: http://github.com/nandhp/multiload-nandhp
Licenses: GPL2
Submitter: ElementW
Maintainer: ElementW
Last Packager: ElementW
Votes: 2
Popularity: 0.000000
First Submitted: 2015-09-12 12:04 (UTC)
Last Updated: 2015-09-12 12:19 (UTC)

Latest Comments

dreieck commented on 2023-04-25 17:10 (UTC) (edited on 2023-04-25 17:13 (UTC) by dreieck)

After having fixed the download protocol issue, configuration fails for me:

[...]
checking for LIBGTOP... yes
checking for XFCE4... no
configure: error: in `/tmp/makepkg/build/xfce4-multiload-nandhp-plugin-git/src/multiload-nandhp':
configure: error: --with-xfce4 was given, but test failed
See `config.log' for more details

Maybe it expects a too old version of xfce, or some dependency is missing.

config.log shows:

[...]
configure:16214: $PKG_CONFIG --exists --print-errors "$pkg_modules"
Package libxfce4panel-1.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libxfce4panel-1.0.pc'
to the PKG_CONFIG_PATH environment variable
Package 'libxfce4panel-1.0', required by 'virtual:world', not found
configure:16217: $? = 1
configure:16231: $PKG_CONFIG --exists --print-errors "$pkg_modules"
Package libxfce4panel-1.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libxfce4panel-1.0.pc'
to the PKG_CONFIG_PATH environment variable
Package 'libxfce4panel-1.0', required by 'virtual:world', not found
configure:16234: $? = 1
configure:16248: result: no
Package 'libxfce4panel-1.0', required by 'virtual:world', not found
configure:16266: error: in `/tmp/makepkg/build/xfce4-multiload-nandhp-plugin-git/src/multiload-nandhp':
configure:16268: error: --with-xfce4 was given, but test failed
[...]

Requires libxfce4panel-1.0, but libxfce4panel-2.0 is present.

↗ Upstream issue report.

Regards!

dreieck commented on 2023-04-25 17:07 (UTC)

You need to change the source protocol from git:// to git+https:// due to changes on github.

Right now, download does not work:

  -> Cloning multiload-nandhp git repo...
Cloning into bare repository '/tmp/makepkg/sources/multiload-nandhp'...
fatal: unable to connect to github.com:
github.com[0: 140.82.121.3]: errno=Connection timed out

==> ERROR: Failure while downloading multiload-nandhp git repo

Thanks for maintaining!