Package Details: xfe 1.43-2

Git Clone URL: https://aur.archlinux.org/xfe.git (read-only)
Package Base: xfe
Description: X File Explorer (Xfe) is an MS-Explorer like file manager for X
Upstream URL: http://roland65.free.fr/xfe
Licenses: GPL
Submitter: Barthalion
Maintainer: meanjollies
Last Packager: meanjollies
Votes: 10
Popularity: 1.275467
First Submitted: 2018-01-05 16:43
Last Updated: 2018-07-20 13:17

Latest Comments

1 2 Next › Last »

meanjollies commented on 2018-07-22 02:00

@JohnRobson do you have the libxft package installed?

semeion commented on 2018-07-22 01:57

The best package manager, i have no idea the reason for what it was removed from official repositories.

Anybody know the reason?

BTW, thanks for the nice job of maintain it here on AUR.

JohnRobson commented on 2018-07-22 01:57

checking X11/Xft/Xft.h presence... no

checking for X11/Xft/Xft.h... no

configure: error: "Xft.h not found"

==> ERROR: A failure occurred in build().

Aborting...

==> ERROR: Makepkg was unable to build xfe.

==> Restart building xfe ? [y/N]

==> ----------------------------

==> ==> ERROR: unable to update

No database errors have been found!

meanjollies commented on 2018-07-20 19:39

@stef204 Okay, and I assume you get no output for "pkg-config --exists --print-errors xcb-aux"? If so, are you modifying any of your PKG_CONFIG vars? Are your packages up to date?

stef204 commented on 2018-07-20 19:27

@meanjollies

% pkg-config --variable pc_path pkg-config

/usr/lib/pkgconfig:/usr/share/pkgconfig

% pkg-config --list-all | grep xcb-aux

xcb-aux XCB Aux library - XCB convenient functions

I still fails to build 'normally' on my (up-to-date) box but does build, as mentioned before, in clean chroot. So no worries.

It happens from time to time with some AUR packages. When it does, I usually just move on to build in clean chroot and if it builds, I leave it at that.

meanjollies commented on 2018-07-20 13:14

@stef204 I'm not able to reproduce this on a clean install. However, I think it is a good idea to add xcb-util as a dependency, so I'll do that. What output do you get for "pkg-config --variable pc_path pkg-config" and "pkg-config --list-all | grep xcb-aux"?

stef204 commented on 2018-07-20 08:15

Fails to build both using makepkg AND asp in clean chroot.

Error message using asp in clean chroot:

"checking for xcb... yes checking for xcb_aux... no configure: error: Cannot find xcb-aux"

xcb-aux should be provided by xcb-util package, installed on my box AND in clean chroot but no joy.

Any ideas?

Edit: if I add xcb-util to dependency array, it builds fine in clean chroot. Otherwise, I would probably have to install xcb-util in clean chroot using something like: "# makechrootpkg -r $CHROOT -- -i"

Although, I should say that I do have xcb-util installed locally and package still fails to build using makepkg.

meanjollies commented on 2018-06-02 19:04

Adopted. An upstream patch is now applied to use pkg-config to detect freetype and xft. This may have fixed any X issues, as I cannot reproduce any freezes.

haawda commented on 2018-06-02 07:03

This program repoducably freezes X on my system. Orphaning.

haawda commented on 2018-06-02 06:35

There is a fork on github.

Change this

source=(xfe-github.zip::https://github.com/escapecode/XFE/archive/master.zip no_freetype_check.patch)

sha256sums=('44b07fc5d7b2dadb3267c1c80279bdc1a84f264272f15e8f5cb920d83c0fab92' '8a7acd26ae612ea02aa00c6cb12763e04b3c17e9c8782d64b76930718a19c92b')

and cd into XFE-master in the three functions.