Package Details: xflr5 6.47-1

Git Clone URL: https://aur.archlinux.org/xflr5.git (read-only)
Package Base: xflr5
Description: An analysis tool for airfoils, wings and planes operating at low Reynolds Numbers.
Upstream URL: http://www.xflr5.com/xflr5.htm
Keywords: airfoil analysis design reynolds
Licenses: GPL
Submitter: hiaselhans
Maintainer: Namarrgon
Last Packager: Namarrgon
Votes: 6
Popularity: 0.000645
First Submitted: 2013-10-03 07:27
Last Updated: 2019-07-09 19:08

Latest Comments

ankei commented on 2019-06-26 07:44

This is real source of the good information. http://passwordsinmicrosoftedge.com Everyone here can easily clear the concepts. Thnaks a lot

pryre commented on 2019-02-14 07:56

I'm not sure what the go is, but 6.44 has been released. However, It looks like the source files have been released in a strange way and might be a pain to update the package. I have not flagged it for this reason.

Also, here's a listing for a desktop entry if you would like to include it in the package. As the package doesn't ship with an accessible icon, I just used x-plane as a filler.

[Desktop Entry]
Version=1.0
Type=Application
Name=xflr5
GenericName=XFLR5
Comment=An analysis tool for airfoils, wings and planes operating at low Reynolds Numbers
Categories=Development;Education
Exec=/usr/bin/xflr5
Icon=x-plane

Namarrgon commented on 2018-06-08 10:09

Sorry for the breakage, i should have tested it better. They broke the project out into libraries and the buildsystem doesn't respect PREFIX for all qmake projects yet. It was never supposed to end up in /usr/local.

pryre commented on 2018-06-08 02:29

Just to add on to @zoidberg's comment, it's probably because Arch doesn't have /usr/local in the LD_PATH (and explicitly advises against it: https://wiki.archlinux.org/index.php/Arch_packaging_standards#Package_etiquette). I'm guessing that the libraries should either be installed to /usr/lib or something of the type instead.

zoidberg commented on 2018-06-07 13:11

When I try to launch xflr5, I get the error

xflr5: error while loading shared libraries: libXFoil.so.1: cannot open shared object file: No such file or directory

and it refuses to launch. This file is owned by the xflr5 package, and it exists in the filesystem (as a symlink) after installation. Any idea what might be wrong?

Edit: The latest version (6.42) installs some libraries in /usr/local/lib, while the previous version (6.40) had no files there.

#Output of `pacman -Ql xflr5' with 6.42:
xflr5 /usr/
xflr5 /usr/local/
xflr5 /usr/local/bin/
xflr5 /usr/local/bin/xflr5
xflr5 /usr/local/lib/
xflr5 /usr/local/lib/libXFoil.so
xflr5 /usr/local/lib/libXFoil.so.1
xflr5 /usr/local/lib/libXFoil.so.1.0
xflr5 /usr/local/lib/libXFoil.so.1.0.0
xflr5 /usr/local/lib/libxflr5-engine.so
xflr5 /usr/local/lib/libxflr5-engine.so.1
xflr5 /usr/local/lib/libxflr5-engine.so.1.0
xflr5 /usr/local/lib/libxflr5-engine.so.1.0.0

#Output of `pacman -Ql xflr5' with 6.40:
xflr5 /usr/
xflr5 /usr/bin/
xflr5 /usr/bin/xflr5

exnanilid commented on 2017-09-19 18:40

This package is no longer current. The following modifications in their respective places worked for me:

pkgver=6.39
source=("http://download.sourceforge.net/project/${pkgname}/${pkgver}/${pkgname}_${pkgver}_src.tar.gz")
md5sums=('c6641d9845ae641aa96383f8e652df6b')

parched commented on 2015-06-01 06:09

@mavrix Thnaks, I will update now.

mavrix commented on 2015-05-31 21:32

This package is no longer current. The following modifications in their respective places worked for me:

pkgver=6.10.04
source=("http://download.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}_src.tar.gz")
md5sums=('1cdbf8c8c941e2387eab74f7f5a27e76')