Package Details: xforms 1.2.5pre1-1

Git Clone URL: https://aur.archlinux.org/xforms.git (read-only)
Package Base: xforms
Description: A graphical user interface toolkit for X Window Systems.
Upstream URL: http://xforms-toolkit.org/
Licenses: LGPL
Submitter: haawda
Maintainer: haawda
Last Packager: haawda
Votes: 9
Popularity: 0.000023
First Submitted: 2009-09-22 19:22
Last Updated: 2016-08-07 20:13

Latest Comments

haawda commented on 2014-07-07 17:31

Updated, thanks.

kopiersperre commented on 2014-06-30 22:35

Version 1.2.4: md5sum d4414c9eb3b284aa2f603a49f376ed22

kopiersperre commented on 2014-01-05 18:49

New stable version (1.2.0)


# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=xforms
pkgver=1.2.0
pkgrel=1
pkgdesc="A graphical user interface toolkit for X Window Systems."
arch=('i686' 'x86_64')
license=('LGPL')
url='http://xforms-toolkit.org/'
depends=('libxpm' 'libjpeg' 'libgl')
makedepends=('texlive-plainextra')
source=(http://download.savannah.gnu.org/releases/xforms/$pkgname.latest_stable.tar.gz)
md5sums=('0fd803fae02c00676313b5060c1ff465')
provides=('xforms-beta')
conflicts=('xforms-beta')
install=$pkgname.install

build() {
cd $srcdir/$pkgname-$pkgver
./configure --prefix=/usr
make
#cd doc
#make info
#make pdf
}
package() {
cd $srcdir/$pkgname-$pkgver
make DESTDIR=$pkgdir/ install
rm $pkgdir/usr/lib/*.la
#install -d $pkgdir/usr/share/info
#install -m644 $srcdir/$pkgname-$pkgver/doc/$pkgname.info* \
# $pkgdir/usr/share/info
#install -Dm644 $srcdir/$pkgname-$pkgver/doc/$pkgname.pdf \
# $pkgdir/usr/share/doc/$pkgname/$pkgname.pdf
}

haawda commented on 2013-12-13 17:02

Update to 1.0.94pre29. The next release 1.0.94pre30 already has links in the download area, but I cannot use them yet.

arcanis commented on 2013-12-06 09:57

And, of course, I had installed automake. Additional info:
$ pkgfile -v texinfo.tex
core/automake 1.14-1 /usr/share/automake-1.14/texinfo.tex
extra/texlive-plainextra 2013.31502-1 /usr/share/texmf-dist/tex/texinfo/texinfo.tex
community/xemacs-all-packages 20110907-1 /usr/share/xemacs/xemacs-packages/man/mmm-mode/texinfo.tex

arcanis commented on 2013-12-06 09:31

hi again =)
Thank you for fixing.
Now I have run pkgfile and found that "texinfo.tex" belongs:
core/automake
extra/texlive-plainextra
community/xemacs-all-packages
I installed "texlive-plainextra" and now it build with pdf normally. So I think you may add this to makedeps and return build pdf.
I'm sorry, I should have done it earlier

haawda commented on 2013-12-05 21:03

Okay, I removed the creation of the pdf file with ths update.

haawda commented on 2013-12-03 20:23

Oops, texinfo.tex is part of texlive-core, not texinfo. Do you have that installed? Pacman should install it for you, as it is a makedependency.

arcanis commented on 2013-12-02 07:39

I had installed texinfo (5.2-2) and it was installed even earlier. But now I have the same error

arcanis commented on 2013-12-02 07:38

okay, I had installed texinfo (5.2-2), but now I have the same error.

haawda commented on 2013-11-30 13:12

install texinfo, it is in base-devel.

arcanis commented on 2013-11-30 00:09

the package doesnt build
! I can't find file `texinfo.tex'.
l.1 \input texinfo.tex
@bye
But if you comment line with "make pdf" all build normally

haawda commented on 2013-11-26 20:52

Guess what! Update.

haawda commented on 2013-11-02 13:33

Update

haawda commented on 2012-11-24 22:54

Update

lineage commented on 2012-02-13 23:02

I have seen some problems with objects (eg checkbuttons) not rendering properly. It is being discussed on the xforms mail list but no-one else can reproduce it at the moment. The leads me to think it could be just something local on my system but it could also be an interaction with the Arch X.org server. If anyone else sees an issue, either check the xforms list or post a comment here.

haawda commented on 2010-07-11 11:10

confirmed and fixed, thank you.

akshaysrinivasan commented on 2010-07-11 08:50

URL is broken. I found this one to work:
http://mirror.veriportal.com/savannah/xforms/$pkgname-$pkgver.tar.gz

haawda commented on 2010-06-01 17:47

I found xforms-1.9.93sp1.

Anonymous comment on 2010-06-01 14:10

After a few days I can confirm the '404: not found' error. Can it be fixed?
Thanks!

Anonymous comment on 2010-05-26 10:40

Ok, now Tex gets correctly installed.
I've got a 404 error now. Don't know if it's a temporary problem or there's a problem in the PKGBUILD:

-> Downloading xforms-1.0.93pre10.tar.gz...
--2010-05-26 12:34:27-- http://mirrors.openfountain.cl/savannah/xforms/xforms-1.0.93pre10.tar.gz
Resolving mirrors.openfountain.cl... 190.96.70.35
Connecting to mirrors.openfountain.cl|190.96.70.35|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2010-05-26 12:34:33 ERROR 404: Not Found.

==> ERROR: Failure while downloading xforms-1.0.93pre10.tar.gz
Aborting...

haawda commented on 2010-05-25 17:08

No it is a makedependency. Added it yesterday.

Anonymous comment on 2010-05-25 09:07

Ok, but wouldn't it be better to add TeX as a dependency if it's required?

haawda commented on 2010-05-24 17:10

you need a working tex installation, or if you do not want that, comment out the relevant parts of the PKGBUILD.

Anonymous comment on 2010-05-24 12:04

Still got errors while compiling:

make[1]: Leaving directory `/home/enrico/.aur/xforms/src/xforms-1.0.93pre10'
restore=: && backupdir=".am$$" && \
am__cwd=`pwd` && CDPATH="${ZSH_VERSION+.}:" && cd . && \
rm -rf $backupdir && mkdir $backupdir && \
if (/bin/sh /home/enrico/.aur/xforms/src/xforms-1.0.93pre10/config/missing --run makeinfo --version) >/dev/null 2>&1; then \
for f in xforms.info xforms.info-[0-9] xforms.info-[0-9][0-9] xforms.i[0-9] xforms.i[0-9][0-9]; do \
if test -f $f; then mv $f $backupdir; restore=mv; else :; fi; \
done; \
else :; fi && \
cd "$am__cwd"; \
if /bin/sh /home/enrico/.aur/xforms/src/xforms-1.0.93pre10/config/missing --run makeinfo -I . \
-o xforms.info xforms.texi; \
then \
rc=0; \
CDPATH="${ZSH_VERSION+.}:" && cd .; \
else \
rc=$?; \
CDPATH="${ZSH_VERSION+.}:" && cd . && \
$restore $backupdir/* `echo "./xforms.info" | sed 's|[^/]*$||'`; \
fi; \
rm -rf $backupdir; exit $rc
TEXINPUTS="../config:$TEXINPUTS" \
MAKEINFO='/bin/sh /home/enrico/.aur/xforms/src/xforms-1.0.93pre10/config/missing --run makeinfo -I .' \
texi2dvi --pdf --batch xforms.texi
You don't have a working TeX binary (tex) installed anywhere in
your PATH, and texi2dvi cannot proceed without one. If you want to use
this script, you'll need to install TeX (if you don't have it) or change
your PATH or TEX environment variable (if you do). See the --help
output for more details.

For information about obtaining TeX, please see http://www.tug.org. If
you happen to be using Debian, you can get it with this command:
apt-get install tetex-bin
make: *** [xforms.pdf] Error 1
==> ERROR: Build Failed.
Aborting...
error: xforms failed while building, remove source files from /home/enrico/.aur/xforms? [Y/n]

If Tex is a dependency it should be addedd to the PKGBUILD.
Thank you

haawda commented on 2010-05-22 22:16

fixed md5sum. But I plan to find a better solution and not to download the pdf anymaore, but to build it using the texinfo sources delivered with the source tarball.

Anonymous comment on 2010-05-22 17:14

When trying to updte the package I get an error about the validity check:

┌─[enrico@beetle][~]
└─[$] aurget -Syu
:: Starting AUR upgrade...
resolving dependencies...
searching AUR...

Targets (1): xforms-1.0.93pre10-1

Proceed with installation? [Y/n] y
:: Retrieving source tarball from AUR...
--2010-05-22 19:04:39-- http://aur.archlinux.org/packages/xforms/xforms.tar.gz
Resolving aur.archlinux.org... 208.92.232.29
Connecting to aur.archlinux.org|208.92.232.29|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 588 [application/x-tgz]
Saving to: `/home/enrico/.aur/xforms.tar.gz'

100%[=====================================>] 588 --.-K/s in 0s

2010-05-22 19:04:45 (35.5 MB/s) - `/home/enrico/.aur/xforms.tar.gz' saved [588/588]

:: Extracting source tarball...
:: Building package...
==> Making package: xforms 1.0.93pre10-1 i686 (Sat May 22 19:04:45 CEST 2010)
==> Checking Runtime Dependencies...
==> Checking Buildtime Dependencies...
==> Retrieving Sources...
-> Downloading xforms-1.0.93pre10.tar.gz...
--2010-05-22 19:04:45-- http://mirrors.openfountain.cl/savannah/xforms/xforms-1.0.93pre10.tar.gz
Resolving mirrors.openfountain.cl... ^@190.96.70.35
Connecting to mirrors.openfountain.cl|190.96.70.35|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 2206123 (2.1M) [application/x-gzip]
Saving to: `xforms-1.0.93pre10.tar.gz.part'
2010-05-22 19:05:02 (192 KB/s) - `xforms-1.0.93pre10.tar.gz.part' saved [2206123/2206123]

-> Downloading xforms.pdf...
--2010-05-22 19:05:02-- http://mirrors.openfountain.cl/savannah/xforms/xforms.pdf
Resolving mirrors.openfountain.cl... 190.96.70.35
Connecting to mirrors.openfountain.cl|190.96.70.35|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 2012727 (1.9M) [application/pdf]
Saving to: `xforms.pdf.part'

100%[=====================================>] 2,012,727 232K/s in 11s

2010-05-22 19:05:19 (186 KB/s) - `xforms.pdf.part' saved [2012727/2012727]

==> Validating source files with md5sums...
xforms-1.0.93pre10.tar.gz ... Passed
xforms.pdf ... FAILED
==> ERROR: One or more files did not pass the validity check!
error: xforms failed while building, remove source files from /home/enrico/.aur/xforms? [Y/n] y

Can this be fixed?
Thanks!

Anonymous comment on 2010-04-27 19:16

HI, this package have problems with the repository,
so i created this PKGBUILD http://aur.pastebin.com/c61ZDjFa
and works !!!
REgards