Package Details: xgalaga 2.1.1.0-5

Git Clone URL: https://aur.archlinux.org/xgalaga.git (read-only)
Package Base: xgalaga
Description: An open source remake of the classic arcade game Galaga
Upstream URL: http://rumsey.org/xgal.html
Licenses: GPL
Submitter: louipc
Maintainer: bidulock
Last Packager: bidulock
Votes: 18
Popularity: 0.044145
First Submitted: 2007-07-24 22:29
Last Updated: 2015-11-02 23:33

Dependencies (2)

Required by (0)

Sources (4)

Latest Comments

bidulock commented on 2014-04-26 01:57

Not as challenging when IM_A_BIG_FAT_CHEATER is defined: see main.c for cheat keys...

bidulock commented on 2014-01-20 07:03

To get oss sound working for all oss applications, add following to
/etc/module-load.d/oss-compat.conf

# load OSS compatability modules
snd-mixer-oss
snd-pcm-oss

u8sand commented on 2014-01-20 03:30

Please make the following changes:
- /bin/cp -f /usr/share/automake-1.13/config.guess .
- /bin/cp -f /usr/share/automake-1.13/config.sub .
+ /bin/cp -f /usr/share/automake-1.14/config.guess .
+ /bin/cp -f /usr/share/automake-1.14/config.sub .

Also for sound one needs oss support (alsa-oss if using alsa) should that be an optional dependency?

u8sand commented on 2014-01-20 01:21

change automoc-13 to -14 or create a more perminant solution.
I also recommend putting alsa-oss as an optional dependency--if one wants sound in xgalaga it requires oss.

Anonymous comment on 2012-05-14 16:12

Updated:
- Added new icon.
- Fixed some warnings.
- Sound server was moved to /usr/bin.
- Scores file was moved to /var/lib/xgalaga.

Anonymous comment on 2012-02-08 13:51

Adopted and updated:
- Fixed download link.
- Fixed compilation error.
- Added pixmap, .desktop file and readme to the package.

I didn't update to the version 2.1. So this pkgbuild is for the original game, written by Joe Rumsey.

Anonymous comment on 2011-05-19 03:13

@louipc
Im not a developer or things like that :) but i saw the problems of the last version too,
and sad but i compare the performace whit the other galaga galaga++ and the last is better..
so i donno the future of this pakage O.o

louipc commented on 2011-05-18 23:05

I hadn't updated because I found that the new version had a lot of problems.
(Lots of crappy Debian patches needlessly applied.)

I will orphan this though and someone else can decide on what to do. Cheers.

somercet commented on 2011-05-18 19:10

I got it working with 2.1.1.0, and under x86_64, too. Would anyone like the source tgz?

Anonymous comment on 2011-05-11 16:20

This is out of date, can some pliz updated ¿? :D
the lastest version is 2.1.1.0

i tried to changes the download paths in the PKGBUILD but no sucess :(

i really hope that one can make that little change ;)

Cheers!