Package Details: xiphos 4.0.3-1

Git Clone URL: https://aur.archlinux.org/xiphos.git (read-only)
Package Base: xiphos
Description: Bible study tool for GTK+
Upstream URL: http://xiphos.org/
Keywords: bible
Licenses: GPL
Conflicts: gnomesword
Provides: gnomesword
Replaces: gnomesword
Submitter: xyproto
Maintainer: vonpupp
Last Packager: vonpupp
Votes: 14
Popularity: 0.124969
First Submitted: 2012-05-21 10:19
Last Updated: 2015-11-01 02:05

Latest Comments

Myshkin commented on 2016-05-17 17:44

I didn't want to install xiphos-git because it pulls in the entire git and I'm on a slow connection and have limited data transfer as well. In order to get this to compile, I had to install biblesync-git. I'm a bit confused because it seems to have installed xiphos 4.0.4, which is fine, of course.

vonpupp commented on 2016-05-13 03:46

@yvand, sorry for the delay. Please try installing xiphos-git. Arch Linux packages based on git are often named with "-git" at the end. If you have problems let us know.

yvand commented on 2016-03-03 11:16

Can you please update the package (or create a new one) and use the new github repository (see http://xiphos.org/download/)?

vonpupp commented on 2016-01-12 15:40

Hello friends, if you get any core dump error when running xiphos after upgrade, just use `yaourt -S biblesync` to update biblesync first.

vonpupp commented on 2015-11-01 19:35

Thank you very much @SanskritFritz

SanskritFritz commented on 2015-11-01 08:24

Thanks for taking care of this package. Looks good so far :)

vonpupp commented on 2015-11-01 02:15

Hello, I adopted this orphan package. It is my first time packaging anything, so if you find any errors please let me know.

Alister.Hood commented on 2015-01-03 23:12

I think you've found the right fix.
Alternatively it is now possible to remove that dependency with --enable-webkit-editor instead (I think this used to only work with a GTK3 build, but I've just tested and it works with GTK2 now).

haawda commented on 2015-01-03 17:05

I can reporduce your error now. But what is the proper fix?

Alister.Hood commented on 2015-01-03 14:51

My comment about text-to-speech working now is of course if I install the old gtkhtml and build against that.

Alister.Hood commented on 2015-01-03 14:50

> I have gtkhtml4 from [extra] here.

Yes, but do you also have an old gtkhtml installed? Try checking xiphos with namcap - if it is really linked to both gtk2 and gtkhtml4 then it shouldn't run - you should get the error I posted.

Alister.Hood commented on 2015-01-03 14:48

> Has anyone ever tried the text-to-speech functionality?
> ... Xiphos still doesn't speak to me...

It works for me now. I put this in ~/.festivalrc to get rid of the American voice (not that the English one is much better):
(set! voice_default voice_rab_diphone)

haawda commented on 2015-01-03 14:38

I have gtkhtml4 from [extra] here.

Alister.Hood commented on 2015-01-03 10:06

# xiphos

(xiphos:10411): Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
Trace/breakpoint trap

I guess you must still have an old gtkhtml package (i.e. version 3) installed and it is actually building against that, not gtkhtml4. That's why I hadn't produced a gtk2 package myself - I had't got around to tracking down and resurrecting the old pkgbuild for gtkhtml. Here it is:
https://projects.archlinux.org/svntogit/packages.git/commit/?id=782c2bf2507303ac82ecc03a047a708da7821376
I suggest renaming it gtkhtml3.

haawda commented on 2015-01-03 00:13

gtk2 is the recommended option over gtk3, so here it is.

haawda commented on 2015-01-03 00:06

You probably will need biblesync as new dependency. I just uplaoded it as dependency for xiphos-svn.

Alister.Hood commented on 2015-01-02 21:45

I see this has been disowned, so I suggest you go ahead, caleb.
I'm keen on a gtk2 variant, so assuming that still works I think I'll create it.

caleb commented on 2014-12-27 21:07

4.0 is out now. Any plans to continue maintaining this package or might it be time to disown it so somebody else can run with it? I'd be willing to work on this if it's not going to get done.

Alister.Hood commented on 2014-12-01 00:34

3.2.2 has been out for a while

alium commented on 2014-11-10 15:07

docbook2x is not required to run the program (as dependency). The program works without it. Can you please give as optdepends?

1. move 'docbook2x' from depends to makedepends and add something in the style "optdepends=('docbook2x: suport man documentation')"

alium commented on 2014-11-10 15:02

docbook2x is not required to run the program (as dependency). The program works without it. Can you please give as optdepends?

Menche commented on 2014-05-31 20:00

Actually, never mind. I was able to build sword-svn and will update xiphos shortly. Rather than make another package for gtkhtml, I'm using gtk3.

Menche commented on 2014-05-31 19:45

I am still unable to build sword or sword-svn. I am disowning this package so someone else who is able to can update it.

haawda commented on 2014-05-25 22:46

I normally run xiphos-svn, which I maintain in AUR. But I tried xiphos 3.20 with gtk3 enabled and also ran it once, no obvious problem.

Alister.Hood commented on 2014-05-25 13:41

The release notes say "GTK2 is still the display toolkit we expect to be used." but I don't know if that really means it is no good with gtk3. Do you run it with gtk3?
gtkhtml2 sounds strange to me, when it would be version 3.32.2

Alister.Hood commented on 2014-05-25 13:41

The release notes say "GTK2 is still the display toolkit we expect to be used." but I don't know if that really means it is no good with gtk3.
gtkhtml2 sounds strange to me, when it would be version 3.32.2

haawda commented on 2014-05-25 12:08

I'd suggest gtkhtml2 instead. But I think it is not needed. waf configure --gtk=3 should work.

Alister.Hood commented on 2014-05-25 02:22

Is there anything stopping this being updated?
In case I wasn't clear, 3.2.0 builds fine with sword 1.7.3

So the only real issue is still that you need to install gtkhtml using downgrade. Perhaps we should add it to AUR - I'm not sure if it would upset someone calling it "gtkhtml" - maybe it should be "gtkhtml-gtk2".

Alister.Hood commented on 2014-05-17 22:48

N.B. Sword has been updated.

Alister.Hood commented on 2014-05-17 13:03

Has anyone ever tried the text-to-speech functionality?
I installed festival-english and followed the instructions for it on the Arch wiki. Testing it on the command line works, and Xiphos no longer gives an error message, but Xiphos still doesn't speak to me...

SanskritFritz commented on 2014-05-10 20:00

I'm contacting upstream about the sword problem.

Menche commented on 2014-05-10 19:49

I am unable to build sword (or sword-svn) at the moment; I'll update and fix this package when I can get that installed.

Anonymous comment on 2014-04-16 20:37

Will not build with gkthtml4. Configure is looking for gtkhtml-editor and gtkhtml 3.14.

haawda commented on 2014-04-06 14:09

it should be gtkhtml4, not gtkhtml.

maxpro4u commented on 2014-04-05 19:04

xiphos is broken again. gtkhtml has been removed from the arch repository

haawda commented on 2014-02-19 10:46

Builds fine here without waf. The xiphos-included waf script is self-contained.

Menche commented on 2014-02-19 01:29

Added webkitgtk2 to depends and waf to makedepends.

alium commented on 2014-02-17 20:58

please add 'waf' as makedepends, because you need waf to build ;-)

alium commented on 2014-02-17 20:56

please add 'waf' as makedepends, because you need waf to build ;-)

gtk2 use 'webkit' not 'webkit2':

Checking for GNOME related libs
pkg-config --errors-to-stdout --print-errors "gconf-2.0" "gmodule-2.0" "glib-2.0" "libgsf-1 >= 1.14" "libxml-2.0" --cflags --libs libglade-2.0 webkit-1.0 "gtk+-2.0 >= 2.14" "gtkhtml-editor-3.14" "libgtkhtml-3.14 >= 3.23"
Package webkit-1.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `webkit-1.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'webkit-1.0' found
not found

bwaynej commented on 2014-01-30 20:33

webkitgtk2 needs to be added to the dependency list so it will compile.

Alister.Hood commented on 2013-07-01 13:53

FWIW, according to the release notes -DNO_SWORD_SET_RENDER_NOTE_NUMBERS=1 was only required with "old" sword svn, not "new" svn, so it shouldn't be needed now.

But this doesn't compile against current sword svn, so I needed to build xiphos-svn anyway.
If users want, it should still compile against "sword", but then they won't be able to use indexes for fast searching.

Alister.Hood commented on 2013-07-01 13:46

FWIW, according to the release notes -DNO_SWORD_SET_RENDER_NOTE_NUMBERS=1 was only required with "old" sword svn, not "new" svn, so it shouldn't be needed now.

But this doesn't compile against current sword svn, so I needed to build xiphos-svn anyway.

yvand commented on 2013-03-17 12:09

Thank you xyproto for your detailed answer.
Unfortunately I have not enough knowledge in packaging/compiling to adopt this package, maybe later.

xyproto commented on 2013-03-16 22:07

yvand, this package is currently not maintained by anyone, but anyone is free to adopt it.

If there are problems with the sword package, it's possible to leave a comment here: https://aur.archlinux.org/packages/sword

If you wish to depend on sword instead of sword-svn, it's possible to just replace "sword-svn" with "sword" in this PKGBUILD. Some AUR-helpers, like yaourt, lets you edit the file before installing it. Other AUR-helpers just downloads the PKGBUILD and lets you edit it and build the package.

If you wish to change the dependency from sword-svn to sword permanently, you can adopt this package, download it, make the desired changes, run makepkg --source and then upload the resulting source tarball. As far as I can remember, there were problems with the regular sword package and xiphos as well, though.

tl;dr Feel free to adopt this package and fix it.

yvand commented on 2013-03-16 21:58

First thank you for these packages (xiphos, xiphos-svn, bibletime, bibletime-git and sword-svn).
Unfortunately xiphos and xiphos-svn do not work currently!
Indeed xiphos-svn can be installed but the Bible is not well displayed (known issue).
And xiphos do not want to compile (certainly because of sword-svn update...)
Why not create a sword package to avoid such troubles?

Gaming4JC commented on 2013-03-07 03:42

We definately need to get this package back into the main repo. But meanwhile you can just do:
yaourt xiphos-svn
https://aur.archlinux.org/packages/xiphos-svn/

Bleeding edge, but working. :)

thirtythreeforty commented on 2012-12-07 23:28

Mmh, good point.

haawda commented on 2012-12-03 17:42

What about keeping it as it is? And probably repair the sword-package instead?

thirtythreeforty commented on 2012-12-03 16:22

I have adopted this package. I'm willing to get it stable from patches from development if you guys will help as well. I believe the Arch policy is to patch enough so that the software is usable with other Arch software; that's what I'm going for here. We'll see how this goes.

xyproto commented on 2012-08-26 11:37

rbyter, I agree with what you're suggesting, but the problem is that "working" is not that easy to define. Bugs were discovered in the last versions that made it unusable for some people.
On the positive side, this AUR package should work until there is a new release of sword/xiphos that fixes the current issues.

Using the latest version, with patches from the development version, is also possible, but very un-Arch like. The idea is that a separation of consern is a good thing.
Maintainers should package when packaging and the upstream developers should develop. Maintainers should not patch/develop while packaging, but report the issues upstream.
For the case of sword, upstream has not "upheld their part of the deal", so to speak, while the xiphos developers have done a great job, both fixing things and being more communicative (but xiphos depends on sword).

Anonymous comment on 2012-08-24 19:04

Why not use the last stable working version until the developers resolve the issues of the current version? Call it "Last Stable Working" if need be. This way, those who use Xiphos, can continue to do so without issue. Xiphos is one of the best tools for study available on the computer. It would be a shame to see Arch users left out while other distros have rolled back to a stable version.

xyproto commented on 2012-06-05 15:35

ajk, the sword library has several bugs and upstream has not released a new working version for months, despite promising otherwise. Until there is a working release version of sword, xiphos will not work correctly either. Once sword is fixed, xiphos and bibletime may be moved back, if a TU or dev wishes to maintain it.

ajk commented on 2012-06-05 08:49

Can someone please adopt this package to get in back in the repos..?

MyWorld commented on 2012-06-04 14:08

All that is need in the dependency is to change sword to sword-svn.

MyWorld commented on 2012-06-04 14:07

You need sword-svn with this, the old sword library is just too old.

MyWorld commented on 2012-06-04 14:06

You need sword-svn with this, the old sword library is just too old.

xyproto commented on 2012-05-21 14:21

This package is currently an orphan. Feel free to adopt it and fix the problem if you think it is a packaging problem (I don't think it is) or report the bug upstream to the developers.

i18nde commented on 2012-05-21 14:16

Build failed:
...

Waf: Leaving directory `/tmp/yaourt-tmp-XXX/aur-xiphos/src/xiphos-3.1.5/build'
Build failed:
-> task failed (err #1):
{task: cxx sword_main.cc -> sword_main_1.o}
-> task failed (err #1):
{task: cxx module_manager.cc -> module_manager_1.o}

xyproto commented on 2012-05-21 10:24

Moved from [community].