Package Details: xlog 2.0.24-2

Git Clone URL: https://aur.archlinux.org/xlog.git (read-only, click to copy)
Package Base: xlog
Description: Ham Radio general purpose logging program.
Upstream URL: http://www.nongnu.org/xlog/
Licenses: GPL3
Submitter: Allan
Maintainer: not_anonymous
Last Packager: not_anonymous
Votes: 8
Popularity: 0.33
First Submitted: 2008-12-19 03:49 (UTC)
Last Updated: 2022-02-26 15:45 (UTC)

Dependencies (8)

Required by (2)

Sources (1)

Latest Comments

1 2 Next › Last »

not_anonymous commented on 2022-02-26 15:46 (UTC)

Updated and will compile and work with either hamlib3.3 or hamlib4 (or hamlib-git).

not_anonymous commented on 2021-10-06 15:11 (UTC)

Updated again....!!

not_anonymous commented on 2021-08-11 22:44 (UTC)

Updated !!

simona commented on 2020-07-19 21:22 (UTC)

Ok. thxs. we wait :-)

not_anonymous commented on 2020-07-19 17:16 (UTC) (edited on 2020-07-19 17:23 (UTC) by not_anonymous)

The upstream author has updated this software in April (version ....19); alas even when I test the upgrade it is still refusing to compile against gtk2, throwing off errors. These kinds of errors (depreciated declarations) seems to be a recurring problem for this code too.

simona commented on 2020-07-18 15:27 (UTC)

can't compile

phansel commented on 2020-01-17 18:24 (UTC)

This package is currently unusable, not only since libgnomeprint and freetype-config are broken, but also because it depends on deprecated GTK2:

https://tecnocode.co.uk/2019/08/24/gtimeval-deprecation-in-glib-2-61-2/

/usr/include/gtk-2.0/gtk/gtktypeutils.h:236:1: error: 'GTypeDebugFlags' is deprecated [-Werror=deprecated-declarations]

/usr/include/gtk-2.0/gtk/gtktooltips.h:73:3: error: 'GTimeVal' is deprecated: Use 'GDateTime' instead [-Werror=deprecated-declarations]

not_anonymous commented on 2019-01-16 20:55 (UTC)

Updated