Package Details: xmind 3.7.7-1

Git Clone URL: https://aur.archlinux.org/xmind.git (read-only)
Package Base: xmind
Description: Brainstorming and Mind Mapping Software
Upstream URL: http://www.xmind.net
Licenses: LGPL, EPL
Submitter: arojas
Maintainer: RemiliaForever
Last Packager: RemiliaForever
Votes: 10
Popularity: 1.002597
First Submitted: 2017-07-06 19:05
Last Updated: 2018-02-22 16:35

Latest Comments

RemiliaForever commented on 2018-02-23 15:06

@damico, rebuild xmind, edit JAVA_VERSION in PKGBUILD or append --add-modules=java.se.ee to /usr/share/xmind/XMind/XMind.ini if you use java9.

I will make it executing in a better way soon.

damico commented on 2018-02-23 14:42

Hi,

Since last update I'm getting the error below, and can't execute xmind. I tried to delete/rename .xmind folder, and still no luck.

UPDATE: Executing from CLI I'm getting this error: "./XMind WARNING: An illegal reflective access operation has occurred WARNING: Illegal reflective access by org.eclipse.osgi.storage.FrameworkExtensionInstaller (file:/usr/share/xmind/plugins/org.eclipse.osgi_3.11.0.v20160603-1336.jar) to method java.net.URLClassLoader.addURL(java.net.URL) WARNING: Please consider reporting this to the maintainers of org.eclipse.osgi.storage.FrameworkExtensionInstaller WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations WARNING: All illegal access operations will be denied in a future release Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged."

Error on LOG file !SESSION 2018-02-23 11:37:09.283 ----------------------------------------------- eclipse.buildId=R3.7.7.201801311814 java.version=9.0.4 java.vendor=Oracle Corporation BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US Framework arguments: -eclipse.keyring @user.home/.xmind/secure_storage_linux Command-line arguments: -os linux -ws gtk -arch x86_64 -data @user.home/.xmind/workspace -eclipse.keyring @user.home/.xmind/secure_storage_linux

!ENTRY org.xmind.cathy 1 0 2018-02-23 11:37:24.687 !MESSAGE Skip unrecognized command line argument: '-eclipse.keyring'

!ENTRY org.xmind.cathy 1 0 2018-02-23 11:37:24.690 !MESSAGE Skip unrecognized command line argument: '@user.home/.xmind/secure_storage_linux'

!ENTRY org.eclipse.osgi.compatibility.state.nl_zh_TW 2 0 2018-02-23 11:37:25.521 !MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_zh_TW [851] Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state

!ENTRY org.eclipse.osgi.compatibility.state.nl_de 2 0 2018-02-23 11:37:25.521 !MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_de [841] Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state

!ENTRY org.eclipse.osgi.compatibility.state.nl_zh 2 0 2018-02-23 11:37:25.521 !MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_zh [850] Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state

!ENTRY org.eclipse.osgi.compatibility.state.nl_sl 2 0 2018-02-23 11:37:25.521 !MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_sl [849] Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state

!ENTRY org.eclipse.osgi.compatibility.state.nl_ko 2 0 2018-02-23 11:37:25.522 !MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_ko [846] Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state

!ENTRY org.eclipse.osgi.compatibility.state.nl_pt_BR 2 0 2018-02-23 11:37:25.522 !MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_pt_BR [847] Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state

!ENTRY org.eclipse.osgi.compatibility.state.nl_ru 2 0 2018-02-23 11:37:25.522 !MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_ru [848] Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state

!ENTRY org.eclipse.osgi.compatibility.state.nl_it 2 0 2018-02-23 11:37:25.522 !MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_it [844] Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state

!ENTRY org.eclipse.osgi.compatibility.state.nl_fr 2 0 2018-02-23 11:37:25.522 !MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_fr [843] Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state

!ENTRY org.eclipse.osgi.compatibility.state.nl_ar 2 0 2018-02-23 11:37:25.522 !MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_ar [839] Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state

!ENTRY org.eclipse.osgi.compatibility.state.nl_es 2 0 2018-02-23 11:37:25.522 !MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_es [842] Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state

!ENTRY org.eclipse.osgi.compatibility.state.nl_ja 2 0 2018-02-23 11:37:25.522 !MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_ja [845] Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state

!ENTRY org.eclipse.osgi.compatibility.state.nl_da 2 0 2018-02-23 11:37:25.523 !MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_da [840] Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state

!ENTRY org.eclipse.osgi 4 0 2018-02-23 11:37:25.532 !MESSAGE Application error !STACK 1 org.eclipse.e4.core.di.InjectionException: java.lang.NoClassDefFoundError: javax/annotation/PostConstruct at org.eclipse.e4.core.internal.di.InjectorImpl.internalMake(InjectorImpl.java:386) at org.eclipse.e4.core.internal.di.InjectorImpl.make(InjectorImpl.java:294) at org.eclipse.e4.core.contexts.ContextInjectionFactory.make(ContextInjectionFactory.java:162) at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createDefaultHeadlessContext(E4Application.java:490) at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createDefaultContext(E4Application.java:504) at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createE4Workbench(E4Application.java:203) at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:626) at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336) at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:604) at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148) at org.xmind.cathy.internal.CathyApplication.start(CathyApplication.java:145) at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243) at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.base/java.lang.reflect.Method.invoke(Unknown Source) at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673) at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610) at org.eclipse.equinox.launcher.Main.run(Main.java:1519) at org.eclipse.equinox.launcher.Main.main(Main.java:1492) Caused by: java.lang.NoClassDefFoundError: javax/annotation/PostConstruct at org.eclipse.e4.core.internal.di.InjectorImpl.inject(InjectorImpl.java:151) at org.eclipse.e4.core.internal.di.InjectorImpl.internalMake(InjectorImpl.java:375) ... 23 more Caused by: java.lang.ClassNotFoundException: javax.annotation.PostConstruct cannot be found by org.eclipse.e4.core.di_1.6.0.v20160319-0612 at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:398) at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:361) at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:353) at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:161) at java.base/java.lang.ClassLoader.loadClass(Unknown Source) ... 25 more

!ENTRY org.eclipse.e4.ui.workbench 4 0 2018-02-23 11:37:25.549 !MESSAGE FrameworkEvent ERROR !STACK 0 java.lang.NoClassDefFoundError: javax/annotation/PreDestroy at org.eclipse.e4.core.internal.di.InjectorImpl.disposed(InjectorImpl.java:426) at org.eclipse.e4.core.internal.di.Requestor.disposed(Requestor.java:154) at org.eclipse.e4.core.internal.contexts.ContextObjectSupplier$ContextInjectionListener.update(ContextObjectSupplier.java:78) at org.eclipse.e4.core.internal.contexts.TrackableComputationExt.update(TrackableComputationExt.java:111) at org.eclipse.e4.core.internal.contexts.TrackableComputationExt.handleInvalid(TrackableComputationExt.java:74) at org.eclipse.e4.core.internal.contexts.EclipseContext.dispose(EclipseContext.java:176) at org.eclipse.e4.core.internal.contexts.osgi.EclipseContextOSGi.dispose(EclipseContextOSGi.java:106) at org.eclipse.e4.core.internal.contexts.osgi.EclipseContextOSGi.bundleChanged(EclipseContextOSGi.java:139) at org.eclipse.osgi.internal.framework.BundleContextImpl.dispatchEvent(BundleContextImpl.java:903) at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230) at org.eclipse.osgi.framework.eventmgr.ListenerQueue.dispatchEventSynchronous(ListenerQueue.java:148) at org.eclipse.osgi.internal.framework.EquinoxEventPublisher.publishBundleEventPrivileged(EquinoxEventPublisher.java:213) at org.eclipse.osgi.internal.framework.EquinoxEventPublisher.publishBundleEvent(EquinoxEventPublisher.java:120) at org.eclipse.osgi.internal.framework.EquinoxEventPublisher.publishBundleEvent(EquinoxEventPublisher.java:112) at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor.publishModuleEvent(EquinoxContainerAdaptor.java:156) at org.eclipse.osgi.container.Module.publishEvent(Module.java:476) at org.eclipse.osgi.container.Module.doStop(Module.java:634) at org.eclipse.osgi.container.Module.stop(Module.java:498) at org.eclipse.osgi.container.SystemModule.stop(SystemModule.java:191) at org.eclipse.osgi.internal.framework.EquinoxBundle$SystemBundle$EquinoxSystemModule$1.run(EquinoxBundle.java:165) at java.base/java.lang.Thread.run(Unknown Source) Caused by: java.lang.ClassNotFoundException: javax.annotation.PreDestroy cannot be found by org.eclipse.e4.core.di_1.6.0.v20160319-0612 at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:398) at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:361) at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:353) at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:161) at java.base/java.lang.ClassLoader.loadClass(Unknown Source) ... 21 more

RemiliaForever commented on 2018-02-07 11:59

@ZAKhan, try deleting ~/.xmind.

ZAKhan commented on 2018-02-07 11:40

getting this error:

!SESSION 2018-02-07 14:42:24.143 ----------------------------------------------- eclipse.buildId=R3.7.6.201711210129 java.version=9.0.4 java.vendor=Oracle Corporation BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US Framework arguments: -eclipse.keyring @user.home/.xmind/secure_storage_linux Command-line arguments: -os linux -ws gtk -arch x86_64 -data @user.home/.xmind/workspace -eclipse.keyring @user.home/.xmind/secure_storage_linux

!ENTRY org.eclipse.osgi 4 0 2018-02-07 14:42:24.718 !MESSAGE Application error !STACK 1 java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini). at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:78) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243) at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.base/java.lang.reflect.Method.invoke(Method.java:564) at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673) at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610) at org.eclipse.equinox.launcher.Main.run(Main.java:1519) at org.eclipse.equinox.launcher.Main.main(Main.java:1492)

RemiliaForever commented on 2018-02-05 01:23

@nareshseep, how do you launch xmind? /usr/bin/XMind will create ~/.xmind and copy some configuration when init. Make sure it runs successfully. And check /usr/share/xmind/XMind/XMind.ini.

-configuration @user.home/.xmind/configuration -data @user.home/.xmind/workspace

nareshseep commented on 2018-02-04 20:56

@RemiliaForever I found out I had no ~/.xmind , so I then created that directory and gave 777 access to it. the I relaunched the software which gave the same error as shown below. Afterwards i looked into the root directory to see if there was an .xmind directory and there was none. however when i run the app as root it works.

RemiliaForever commented on 2018-02-04 10:56

@nareshseep

it seems you hava no permission to write configuration files. What is your ~/.xmind directory permission? And files in ~/.xmind directory?

nareshseep commented on 2018-02-04 10:27

@RemiliaForever

the log has this error when ran as normal user

!ENTRY org.eclipse.osgi 4 0 2018-02-04 06:24:16.697 !MESSAGE Error reading configuration: Permission denied !STACK 0 java.io.IOException: Permission denied at java.io.UnixFileSystem.createFileExclusively(Native Method) at java.io.File.createTempFile(File.java:2024)

RemiliaForever commented on 2018-01-25 04:29

@electricprism, fixed.

electricprism commented on 2018-01-24 21:58

Could someone share a fix on patching in

  1. File Icons for .xmind files

  2. A launcher so I can set the default application of .xmind files to open in.

RemiliaForever commented on 2018-01-23 01:50

@nareshseep, Xmind needs jre>=8. If you want to set jre7 as system default, you could edit /usr/bin/XMind and override PATH environment to make xmind use jre8.

What's the error messages? If it crash on start, trying delete ~/.xmind directory.

BTW, you can change jre(8/9) or gtk(2/3) version in XMind.ini/PKGBUILD, default use jre8 and gtk3, read PKGBUILD for more information. But old configuration may cause crash on start, after xmind update. I hava no idea there is a better way to solve that.

nareshseep commented on 2018-01-22 20:28

additional info was able to launch the program as root.. if i launch it as normal user it will not run

nareshseep commented on 2018-01-22 19:45

Was getting the error jdk 1.8 required...

checked jdk version

archlinux-java status

Available Java environments: java-7-openjdk/jre (default) java-8-openjdk/jre

set jdk 1.8 as default

sudo archlinux-java set java-8-openjdk/jre

Was able to launch xmind with no issues afterwards.

nperic commented on 2017-10-08 15:09

I managed to get it running under Java 9 by adding --add-modules=java.se.ee to the XMind.ini, here is the diff:

@@ -13,4 +13,5 @@
-eclipse.keyring
@user.home/.xmind/secure_storage_linux
-vmargs
+--add-modules=java.se.ee
-Dfile.encoding=UTF-8

I'm still seeing the following error in the log, not sure if that existed before, didn't check the log while I had Java 8:
!ENTRY org.xmind.cathy 1 0 2017-10-08 17:03:47.257
!MESSAGE Skip unrecognized command line argument: '-eclipse.keyring'

!ENTRY org.xmind.cathy 1 0 2017-10-08 17:03:47.258
!MESSAGE Skip unrecognized command line argument: '@user.home/.xmind/secure_storage_linux'

ram4nd commented on 2017-10-05 11:06

Deleting ~/.xmind helped with the error.


java.version=1.8.0_144
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Framework arguments: -eclipse.keyring @user.home/.xmind/secure_storage_linux
Command-line arguments: -os linux -ws gtk -arch x86_64 -data @user.home/.xmind/workspace -eclipse.keyring @user.home/.xmind/secure_storage_linux

!ENTRY org.eclipse.osgi 4 0 2017-10-05 14:05:16.058
!MESSAGE Application error
!STACK 1
java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:78)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
at org.eclipse.equinox.launcher.Main.main(Main.java:1492)

zhangyi commented on 2017-09-25 07:53

I set "--launcher.GTK_version" in /usr/share/xmind/XMind/XMind.ini from 3 to 2, then it runs smoothly

dszryan commented on 2017-09-17 08:16

latest pull - is still causing high CPU

sthysel commented on 2017-09-10 02:46

I'm seeing very high CPU load from program start, even when idle. This is with latest aur pull.

dszryan commented on 2017-09-03 11:48

since the last update...

i am seeing java consuming high cpu after the application has launched - even before opening a xmind file - which should be idle condition.

anyone else having this issue?

dszryan commented on 2017-08-06 12:05

it installs jre7-openjdk-headless, but demand 8 when run.

hence. i did the following:
pacman -R jre7-openjdk-headless
pacman -S jre8-openjdk-headless
ln -s /usr/lib/jvm/java-8-openjdk/jre /usr/share/xmind/XMind/jre

can we update the package to do the same?

reefland commented on 2017-07-12 21:08

Just upgraded get same message as bruceutut did. For me, deleting the "~/.xmind" directory worked.

RemiliaForever commented on 2017-07-12 05:52

I have tried on different computers, it works fine.
I add gtk3 to depend, does it still launch failed?

mkasu commented on 2017-07-11 09:44

I get the same error on launch. Deleting .xmind or copying the config from /usr/share/xmind does not solve the issue for me.

bruceutut commented on 2017-07-11 02:19

Fail to start after latest update:
Traceback:

!SESSION 2017-07-11 10:14:46.224 -----------------------------------------------
eclipse.buildId=R3.7.2.201705011955
java.version=1.8.0_131
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=zh_CN
Framework arguments: -eclipse.keyring @user.home/.xmind/secure_storage_linux
Command-line arguments: -os linux -ws gtk -arch x86_64 -data @user.home/.xmind/workspace -eclipse.keyring @user.home/.xmind/secure_storage_linux

!ENTRY org.eclipse.osgi 4 0 2017-07-11 10:14:46.574
!MESSAGE Application error
!STACK 1
java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:78)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
at org.eclipse.equinox.launcher.Main.main(Main.java:1492)