Package Details: xml2rfc 3.2.1-1

Git Clone URL: https://aur.archlinux.org/xml2rfc.git (read-only, click to copy)
Package Base: xml2rfc
Description: Generates RFCs and IETF drafts from document source in XML according to the DTD in RFC 2629
Upstream URL: https://pypi.python.org/pypi/xml2rfc
Keywords: formatter generator IETF RFC XML
Licenses: custom:BSD
Submitter: felix.s
Maintainer: bidulock
Last Packager: bidulock
Votes: 5
Popularity: 0.000077
First Submitted: 2015-11-18 07:03
Last Updated: 2020-10-05 01:42

Latest Comments

SamWhited commented on 2020-11-22 21:11

Also still missing python-pyaml and python-jinja2

twiggers commented on 2020-11-16 08:34

Seems to be missing python-configargparse

SamWhited commented on 2020-05-09 22:39

This also appears to be missing a dependency on python-six and panics on startup unless you install it

SamWhited commented on 2020-05-09 22:29

nit: python is part of the base system and does not need to be included as a dependency, running the linter against the built package will complain (it will also have several other complaints, but those are false positives because it doesn't understand Python dependencies).

SamWhited commented on 2020-04-24 05:20

Looks like python-html5lib is also missing and I missed it in my last comment.

SamWhited commented on 2020-04-21 23:48

This is missing dependencies for python-pyflakes, pytnon-pycountry, python-kitchen, python-intervaltree, and python-google-i18n-address

Rucikir commented on 2019-12-23 10:42

Probably missing a dependency.

Traceback (most recent call last):
  File "/usr/bin/xml2rfc", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 3252, in <module>
    def _initialize_master_working_set():
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 3235, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 3264, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 583, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 900, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 786, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'pyflakes>=0.8.1' distribution was not found and is required by xml2rf

Rucikir commented on 2018-11-16 16:05

The website states that it's licensed under the OSI Approved :: BSD License. It is also indicated in the Debian package.

Check this file: xml2rfc/cli/LICENSE

felix.s commented on 2017-08-01 14:34

Hmm. Version 2.7.0 has been released, and it doesn't include any LICENSE file any more (other support files are missing from the source package as well). And I have no idea how to report this upstream; the Trac bug tracker is apparently only available to IETF members.

I probably shouldn't just ignore it, but I don't know what I'm supposed to do now. Any ideas?