Package Details: xmltv 0.6.1-1

Git Clone URL: https://aur.archlinux.org/xmltv.git (read-only)
Package Base: xmltv
Description: Set of utilities to download tv listings and format them in xml
Upstream URL: http://xmltv.org/wiki/
Licenses: GPL
Submitter: haawda
Maintainer: blueowl
Last Packager: blueowl
Votes: 61
Popularity: 0.037928
First Submitted: 2011-03-12 19:56
Last Updated: 2019-04-25 12:17

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

khampf commented on 2014-11-22 22:43

Compilation failed at Unicode::String and as it's optional (only recommended) I disabled it for now. If you get other SIGSEGVs please debug by going into the src/xmltv-0.5.xx dir and running:

perl -d Makefile.PL PREFIX=/usr INSTALLDIRS=vendor

(you then enter "c" at the DB<1> prompt to make magic happen)

For example Unicode::String gave me the following:

Signal SEGV at /usr/lib/perl5/vendor_perl/Unicode/String.pm line 28, <STDIN> line 1.
require Unicode/String.pm called at (eval 419)[Makefile.PL:1151] line 2
eval 'require Unicode::String' called at Makefile.PL line 1151
main::test_module("Unicode::String", 0) called at Makefile.PL line 1209

Burroughs commented on 2014-10-12 15:25

I still get the message "Perl API version v5.16.0 of Archive::Zip does not match v5.20.0 at /usr/lib/perl5/core_perl/DynaLoader.pm line 216, <STDIN> line 1.
Compilation failed in require at (eval 403) line 2, <STDIN> line 1.
...propagated at Makefile.PL line 1204, <STDIN> line 1."
Is there a way to fix this or a workaround (I know it depends on perl but xmltv is a very useful program for me)?

Burroughs commented on 2014-10-12 15:24

I still get the message "Perl API version v5.16.0 of Archive::Zip does not match v5.20.0 at /usr/lib/perl5/core_perl/DynaLoader.pm line 216, <STDIN> line 1.
Compilation failed in require at (eval 403) line 2, <STDIN> line 1.
...propagated at Makefile.PL line 1204, <STDIN> line 1."
Is there a way to fix this or a workaround (I know it depends from perl but xmltv is a very useful program for me)?

DarkElf commented on 2014-06-10 08:34

It happened since I upgraded perl packages...

khampf commented on 2014-06-09 14:03

I get a segfault at another place but as compilation was succesful earlier it's nothing in the packages per se, it's either perl or upstream :(

DarkElf commented on 2014-06-09 07:14

Perl API version v5.18.0 of Term::ReadKey does not match v5.20.0 at /usr/lib/perl5/core_perl/DynaLoader.pm line 216.
Compilation failed in require at lib/Ask/Term.pm line 9.
BEGIN failed--compilation aborted at lib/Ask/Term.pm line 9.
Compilation failed in require at Makefile.PL line 246.

Louis commented on 2014-05-21 22:17

Flagged. 0.5.65 released: http://sourceforge.net/projects/xmltv/files/xmltv/

khampf commented on 2013-01-11 15:00

Verified building on i686 and x86_64 without problems. Not sure why it would bork on PREFIX/INSTALL_BASE but if more people have problems with it I can look into it ...

chetwisniewski commented on 2013-01-11 05:16

Build fails with:

Only one of PREFIX or INSTALL_BASE can be given. Not both.


Removing PREFIX solved it, not sure on implications

andreas_baumann commented on 2012-09-29 08:00

0.5.63 is out.