Package Details: xmms-mp4-plugin 2.7-4

Git Clone URL: https://aur.archlinux.org/xmms-mp4-plugin.git (read-only)
Package Base: xmms-mp4-plugin
Description: ISO AAC audio decoder
Upstream URL: http://www.audiocoding.com/
Licenses: GPL
Submitter: Musikolo
Maintainer: Musikolo
Last Packager: Musikolo
Votes: 7
Popularity: 0.000000
First Submitted: 2009-08-21 20:27
Last Updated: 2015-07-24 03:15

Dependencies (1)

Required by (0)

Sources (5)

Latest Comments

Musikolo commented on 2010-04-17 18:27

@liquibyte

Hi,

the reason to do 'faad2=2.7' it's because I pretend this package to depend on the official faad2 package and prevent from working aside of it. The package faad2 release version is 2.7 and its compilation version is 1, thus 2.7-1, as you can see if you issue this:

[musikolo@MyPC ~]$ pacman -Q faad2
faad2 2.7-1

Therefore, the package does exist in the specified version and the author of the package (ie, me) is forcing to use such a version. I think will be more a benefit than a inconvenient for everyone, as a single binary file is needed to have XMMS playing mp4 files. Otherwise, a more complicated package will be needed very likely. So, the package does compile as it has proven to do in many PCs already. If it doesn't in your PC, something I don't believe, it would be due to other reason.

Best regards.

liquibyte commented on 2010-04-17 14:56

depends=( 'id3lib' 'faad2=2.7' 'xmms')

see this >>>>>>>>>>>>>>>^

I wish you people would not do that. This will not build because pacman is looking for a package named faad2=2.7 which will never be found because it doesn't exist. I can't be assed to tell you how it's supposed to be done but I'm sure it's a wiki away.

Musikolo commented on 2010-04-14 19:24

@baens:
Done!

Thank you.

Anonymous comment on 2010-04-14 15:40

I got the following error:
"configure: error: *** id3lib headers support not installed or not found"

It looks like the fix for this is to install id3lib.

I would suggest to require id3lib as a dependency.