Package Details: xmonad-git v0.17.0.r24.ge25d090-1

Git Clone URL: https://aur.archlinux.org/xmonad-git.git (read-only, click to copy)
Package Base: xmonad-git
Description: Lightweight X11 tiled window manager written in Haskell
Upstream URL: http://xmonad.org/
Licenses: BSD
Conflicts: xmonad
Provides: xmonad
Submitter: Mr.Elendig
Maintainer: sam-kirby
Last Packager: sam-kirby
Votes: 6
Popularity: 0.54
First Submitted: 2015-09-12 18:58 (UTC)
Last Updated: 2022-01-11 11:16 (UTC)

Latest Comments

theeyeofcthulhu commented on 2022-01-11 11:02 (UTC) (edited on 2022-01-11 11:07 (UTC) by theeyeofcthulhu)

GitHub removed git protocol support as of today. Please change the link in 'source' to 'git+https://github.com/xmonad/xmonad.git'.

Mr.Elendig commented on 2021-08-17 17:58 (UTC)

disowned since I'm mostly switched over to wayland, feel free to pick it up

sam-kirby commented on 2021-08-17 13:02 (UTC)

Fix for dynamic compilation patch: https://github.com/sam-kirby/xmonad-git/commit/d5f8b4897648991e945240abf8fcedd91a800ac8

alecs commented on 2021-06-05 08:19 (UTC)

fixed pkgbuild: https://git.ignuranza.net/alecs/cringe/src/branch/master/pkgbuilds/xmonad-git/PKGBUILD

alecs commented on 2021-06-05 07:57 (UTC)

Please update haskell-x11 dependency

eldog commented on 2018-01-02 09:23 (UTC)

I'm getting a compilation error with the latest version

dist/build/autogen/Paths_xmonad.hs:10:1: error:
    Could not find module ‘Control.Exception’
    There are files missing in the ‘base-4.10.1.0’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.
   |
10 | import qualified Control.Exception as Exception
   | ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

dist/build/autogen/Paths_xmonad.hs:11:1: error:
    Could not find module ‘Data.Version’
    There are files missing in the ‘base-4.10.1.0’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.
   |
11 | import Data.Version (Version(..))
   | ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

dist/build/autogen/Paths_xmonad.hs:12:1: error:
    Could not find module ‘System.Environment’
    There are files missing in the ‘base-4.10.1.0’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.
   |
12 | import System.Environment (getEnv)
   | ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

dist/build/autogen/Paths_xmonad.hs:13:1: error:
    Could not find module ‘Prelude’
    There are files missing in the ‘base-4.10.1.0’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.
   |
13 | import Prelude

Mr.Elendig commented on 2017-03-30 08:05 (UTC) (edited on 2017-03-30 08:06 (UTC) by Mr.Elendig)

Check LDFLAGS in your makepkg.conf, the one shipped by arch does not have -pie.

misc commented on 2017-03-29 16:16 (UTC)

Getting /usr/bin/ld: -r and -pie may not be used together since two or three weeks. Probably an Arch bug or GHC shortcoming, though.

de-vries commented on 2017-02-19 16:15 (UTC)

Shouldn't git be a makedepend? Currently building in a clean chroot fails because git is not automatically installed. Thanks for providing the PKGBUILD, btw :)

anpieber commented on 2017-02-17 08:16 (UTC)

I get the following error: :: xmonad-git: installing haskell-x11 (1.8-1) breaks dependency 'haskell-x11<1.8'

Mr.Elendig commented on 2016-12-31 11:47 (UTC) (edited on 2016-12-31 11:47 (UTC) by Mr.Elendig)

I'm not going to bother, it is trivial to just update the PKGBUILD for haskell-x11(-xft), and hopefully there is a new xmonad release soon™ so that haskell-x11 in the repos can get bumped anyway. But feel free to make haskell-x11-git if you like. Would require users to rebuild haskell-x11-xft too btw.

mazinght commented on 2016-12-28 13:08 (UTC)

Thanks! I think having the dependency wrong for a few days for the sake of spending time with family is completely understandable :) Should we make a haskell-x11-git package, perhaps, to avoid this situation?

Mr.Elendig commented on 2016-12-28 11:59 (UTC) (edited on 2016-12-28 12:02 (UTC) by Mr.Elendig)

Nothing I can do about haskell-x11 being too old in [community]. You can bump it yourself if you are not using anything that depends on <= 1.6. Was going to update the dep in the PKGBUILD earlier but then I got invaded by family. Stupid holidays.

mazinght commented on 2016-12-27 12:37 (UTC) (edited on 2016-12-27 12:38 (UTC) by mazinght)

I am getting Encountered missing dependencies: X11 == 1.7.* Also, after getting this error, I have to manually remove xmonad.desktop to be able to try (and fail) to install this package again. haskell-x11 has been flagged out of date a few days ago.