Package Details: xnconvert 1.72-1

Git Clone URL: https://aur.archlinux.org/xnconvert.git (read-only)
Package Base: xnconvert
Description: A cross-platform batch image-converter and resizer with a powerful and ease of use experience.
Upstream URL: http://www.xnview.com/en/xnconvert/
Licenses: custom
Submitter: None
Maintainer: Gryffyn
Last Packager: Gryffyn
Votes: 9
Popularity: 0.000097
First Submitted: 2012-02-02 15:31
Last Updated: 2016-02-23 08:27

Latest Comments

drdru commented on 2016-07-10 22:17

new one
630712e5fbc7385c0d610fca35df51bd

Voice commented on 2016-02-27 10:27

Checksum bad under pacaur 4.5.4-1
updpkgsums --help

yair commented on 2016-02-23 07:14

please update, latest md5sum worked for me

Moo commented on 2016-02-15 22:11

x86_64 md5sum is now

cfc76707ffa7ea49f3dce5a382b2b30f

gonzalomr commented on 2015-11-12 19:16

On x86_64
change md5sum

if [ "$CARCH" = 'x86_64' ]; then
source=(${pkgname}-${pkgver}.tgz::"http://download.xnview.com/XnConvert-linux-x64.tgz")
md5sums=('00255779243321700f78681d277f7c13')

fi

cokomoko commented on 2015-10-01 15:34

PKGBUILD edit md5sum

if [ "$CARCH" = 'x86_64' ]; then
source=(${pkgname}-${pkgver}.tgz::"http://download.xnview.com/XnConvert-linux-x64.tgz")
md5sums=('732a659abe5e4e4e6427f5a5a66ca274')

fi

successful compilation, no problem.

cokomoko commented on 2015-10-01 15:34

PKGBUILD edit

if [ "$CARCH" = 'x86_64' ]; then
source=(${pkgname}-${pkgver}.tgz::"http://download.xnview.com/XnConvert-linux-x64.tgz")
md5sums=('732a659abe5e4e4e6427f5a5a66ca274')

fi

successful compilation, no problem.

bjo commented on 2015-01-11 13:33

Updated, thx.

Alister.Hood commented on 2015-01-05 01:02

Please version the downloaded source file, to prevent problems (like willemw encountered) for people using AUR helpers:

source=(${pkgname}-${pkgver}.tgz::"http://download.xnview.com/XnConvert-linux.tgz")

willemw commented on 2014-11-27 18:09

url is now http://www.xnview.com/en/xnconvert/

willemw commented on 2014-11-21 16:55

==> Validating source files with md5sums...
XnConvert-linux-x64.tgz ... FAILED
==> ERROR: One or more files did not pass the validity check!

bjo commented on 2013-08-10 11:55

I'll fix the post-install ASAP.

I have qt4 installed and there are no issues with "mixed" types. No idea why the author of xnconvert bundles qt with his software.

willemw commented on 2013-08-09 09:58

@bjo
The 'update-desktop-database' line should be updated according to the wiki. At least, I think that, the leading / in /usr is wrong.

About the core dump:
Having only one qt version installed is not really feasible, with all the dependencies. I am the only one that has this problem? I have also qt3 installed BTW. I think the conflict is between the two qt4's. Why not use the system's qt4 libraries, which is done with (most) other qt4 programs? I could be wrong, but having qt bundled with the program falls under a paid license, right?

bjo commented on 2013-08-09 09:10

@willemw:

Updated deps.

Did you try what happens if only one qt-version is installed and you comment out the two lines?

willemw commented on 2013-08-08 21:18

Run xnconvert:
Cannot mix incompatible Qt library (version 0x40805) with this library (version 0x40802)
/usr/bin/xnconvert: line 5: 14988 Aborted (core dumped) "$dirname"/XnConvert "$@"

Qt4 and qt5 are installed. On x86_64.

Commenting out the export lines in /usr/bin/xnconvert solves the problem:
#export LD_LIBRARY_PATH="$dirname"/lib
#export QT_PLUGIN_PATH="$dirname"/lib

xnviewmp runs without needing to comment out the export lines.

willemw commented on 2013-08-08 20:49

.install file: 'update-desktop-database -q' in post_install and post_remove.
Package should depend on desktop-file-utils.

Anonymous comment on 2012-10-02 18:49

Thanks! The package is now up to date.

bjo commented on 2012-10-01 23:49

1.5 is out!