Package Details: xneur 0.20.0-1

Git Clone URL: https://aur.archlinux.org/xneur.git (read-only)
Package Base: xneur
Description: X Neural Switcher detects the language of input and corrects keyboard layout if needed
Upstream URL: http://www.xneur.ru
Keywords: keyboard layout
Licenses: GPL
Submitter: None
Maintainer: cucullus
Last Packager: cucullus
Votes: 90
Popularity: 0.000104
First Submitted: 2007-03-10 21:23
Last Updated: 2016-12-03 16:45

Latest Comments

1 2 3 4 5 Next › Last »

luntik2012 commented on 2019-06-06 13:22

wtf omg. enchant 1.6 is installed

make[1]: Entering directory '/tmp/yaourt-tmp-user/aur-xneur/src/xneur-0.20.0'
Making all in lib
make[2]: Entering directory '/tmp/yaourt-tmp-user/aur-xneur/src/xneur-0.20.0/lib'
Making all in notify
make[3]: Entering directory '/tmp/yaourt-tmp-user/aur-xneur/src/xneur-0.20.0/lib/notify'
  CC       libxnnotify_la-notify.lo
In file included from ../../lib/config/xnconfig.h:38,
                 from notify.c:25:
../../lib/lib/xneur.h:32:11: fatal error: enchant/enchant.h: No such file or directory
 # include <enchant/enchant.h>
           ^~~~~~~~~~~~~~~~~~~
compilation terminated.
make[3]: *** [Makefile:463: libxnnotify_la-notify.lo] Error 1

yar.ilich commented on 2019-02-28 04:54

UPD: installation completed successfully after I manually installed enchant1.6 from aur. Maintainer, please correct dependency specification.

./configure: line 4877: intltool-update: command not found
checking for intltool >= 0.35.0...  found
configure: error: Your intltool is too old.  You need intltool 0.35.0 or later.

and

checking for ENCHANT... configure: error: Package requirements (enchant >= 1.0) were not met:

Package 'enchant', required by 'virtual:world', not found

The last problem persists even after installing enchant-2.2.3-2.

Agafron commented on 2018-12-28 16:24

checking build system type... config.sub: missing argument

Try `config.sub --help' for more information.

configure: error: /bin/sh ./config.sub failed

==> ОШИБКА: Произошел сбой в build().

cucullus commented on 2018-05-31 09:19

New release is expected in a few weeks, please be patient!

SinClaus commented on 2018-05-24 12:37

Added enchant.pc to the /usr/share/pkgconfig, added link to /usr/include/enchant but while compiling we see [code] ../lib/lib/.libs/libxneur.so: undefined reference to enchant_dict_check' ../lib/lib/.libs/libxneur.so: undefined reference toenchant_broker_request_dict' ../lib/lib/.libs/libxneur.so: undefined reference to enchant_broker_free' ../lib/lib/.libs/libxneur.so: undefined reference toenchant_broker_init' ../lib/lib/.libs/libxneur.so: undefined reference to enchant_broker_free_dict' ../lib/lib/.libs/libxneur.so: undefined reference toenchant_broker_dict_exists' ../lib/lib/.libs/libxneur.so: undefined reference to enchant_dict_suggest' ../lib/lib/.libs/libxneur.so: undefined reference toenchant_dict_free_string_list' collect2: error: ld returned 1 exit status [/code] Is there somebody for rewrite this packet for enchant-2?

snqlby commented on 2018-02-23 20:52

sudo ln -s /usr/include/enchant-2 /usr/include/enchant && sudo ln -s /usr/lib/pkgconfig/enchant-2.pc /usr/lib/pkgconfig/enchant.pc

foi commented on 2018-02-17 05:56

Hi!

checking for ENCHANT... configure: error: Package requirements (enchant >= 1.0) were not met:

No package 'enchant' found

But yaourt enchant 1 extra/enchant 2.2.1-1 [installed] A wrapper library for generic spell checking

bug404 commented on 2018-01-29 22:26

laenco thanks, I did so - ln -s /usr/lib/libenchant-2.so.2.2.1 /usr/lib/libenchant.so.2

laenco commented on 2018-01-29 12:09

Sucessfully compiled with

build() {
    CFLAGS+=" -Wno-unused-variable "
    cd $srcdir/$pkgname-$pkgver
    ./configure --prefix=/usr --sysconfdir=/etc \
    --without-xosd \
    --with-spell=no \
    --with-gtk=gtk2 # Because gxneur still doesn't supports gtk3
    make
}

Wno-unused-variable is needed as min_levenshtein var in unused. spell=no because enchant-2 is not showed by pkg-config --exists --print-errors "enchant >= 1.0"

mrzx commented on 2017-09-16 13:00

When you install requires XML::Parser
Installed:
$ perl -e shell -MCPAN
$ install XML::Parser