Package Details: xnviewmp 0.96.4-1

Git Clone URL: https://aur.archlinux.org/xnviewmp.git (read-only, click to copy)
Package Base: xnviewmp
Description: An efficient multimedia viewer, browser and converter.
Upstream URL: http://www.xnview.com/en/xnviewmp/
Keywords: graphics
Licenses: custom
Submitter: oliwer
Maintainer: Corax
Last Packager: Corax
Votes: 271
Popularity: 2.44
First Submitted: 2008-07-25 19:01
Last Updated: 2020-07-01 21:36

Pinned Comments

Corax commented on 2017-01-21 15:34

I have created a new package: xnviewmp-system-libs. This is exactly the same build, except that the bundled Qt/icu libs are removed. Please try it if you want to use XnView without the bundled libs, and discuss any issue related to this configuration here: https://aur.archlinux.org/packages/xnviewmp-system-libs/. Do keep in mind that this is an experimental package though, and things may break when I try to fix other things...

Corax commented on 2017-01-20 21:49

If makepkg fails because the checksum is incorrect, please flag the package out-of-date and I will update the PKGBUILD.

Upstream does not version the released archives and does not announce new releases either, so the checksum is bound to become wrong every time there is a new release, and there's nothing I can do about that.

Latest Comments

« First ‹ Previous ... 9 10 11 12 13 14 15 16 17 18 19 ... Next › Last »

Anonymous comment on 2015-09-23 20:24

According to the WhatsNew.txt file in the downloaded tarball, this version is 0.75 and a lot has changed, despite the version number on the website remaining at 0.72. This version is built with QT 5.4.2 and won't run here. I've tried installing qt5-multimedia qt5-webkit qt5-svg qt5-x11extras, but I'm still getting "This application failed to start because it could not find or load the Qt platform plugin "xcb"." errors.

cdown commented on 2015-09-23 16:24

@mytbk This is the same version number, there is no new release as far as I'm aware.

mytbk commented on 2015-09-23 16:22

@cdown: XnViewMP is a closed source software, it is distributed in binary tarballs without version number, so when they update the software they just update the tarballs.

cdown commented on 2015-09-23 15:36

@scarecrow: Fixed, let me know if you still see problems. It was changed for both the x86 and x86_64 versions, no idea why they changed it upstream.

scarecrow commented on 2015-09-23 15:30

The MD5sum of the 64-bit package (at least) has changed... please update PKGBUILD.

not_anonymous commented on 2015-01-19 17:59

- Here's some (self-explanatory) corrections - I used namcap (Yes namcap can be wrong or over-report.) and pactree ... and these are the *valid* things that could be corrected - (I also bumped the pkgrel to make things easier.)

$ cat diff.PKGBUILD
--- PKGBUILD 2014-12-19 23:26:16.000000000 -0700
+++ PKGBUILD 2015-01-19 10:27:20.060450631 -0700
@@ -9 +9 @@
-pkgrel=1
+pkgrel=2
@@ -15 +15 @@
-depends=('glib2' 'expat' 'libpng12' 'gstreamer0.10-base' 'desktop-file-utils')
+depends=('libpng12' 'gstreamer0.10-base' 'phonon-qt4' 'qtwebkit')
@@ -31,0 +32,4 @@
+prepare() {
+ rm -rf "${srcdir}/XnView/AddOn/.fr-uOM3gq/"
+ rm -rf "${srcdir}/XnView/AddOn/.fr-umBezy/"
+}

kaptoxic commented on 2014-12-19 13:10

md5sum in case of x64 should be change, more specifically, corresponding lines in PKGBUILD should be:

if [ "$CARCH" = 'x86_64' ]; then
source=("XnViewMP-linux-x64-${pkgver}.tgz::http://download.xnview.com/XnViewMP-linux-x64.tgz"
"xnviewmp.desktop")
md5sums=('1e3ffc900abf13795f148156d7796c72'
'24f44d5a881b94daf48775213a57e4ec')
fi

CyberWolf2k14 commented on 2014-12-06 21:16

Please ignore previous about v0.71, I am kind of having on eof those days where my mind is "trying" to go like 5 different directions at once, NOT fun.

CyberWolf2k14 commented on 2014-12-06 21:15

@x33a:
I have NEVER tinkered with anything to do withe packages..EVER. I leave that up to those who definitely have FAR more experience than I do.
I just posted here to let someone know that there was definitely an MD5sum problem with this package. I use the package because I really like it, so woul like it updated. On that, I hope maintainer know it is now up to v0.71, right?

x33a commented on 2014-12-06 04:40

@ CyberWolf2k14,

you know that you can always modify your local copy of PKGBUILD, right?