Package Details: xonotic-autobuild 0.8.2-1

Git Clone URL: https://aur.archlinux.org/xonotic-autobuild.git (read-only, click to copy)
Package Base: xonotic-autobuild
Description: A free, fast-paced crossplatform first-person shooter
Upstream URL: http://xonotic.org
Keywords: shooter
Licenses: GPL
Conflicts: xonotic, xonotic-data, xonotic-git
Submitter: AlexTalker
Maintainer: johnnybash
Last Packager: johnnybash
Votes: 5
Popularity: 0.000014
First Submitted: 2013-12-29 17:39
Last Updated: 2020-12-23 12:05

Latest Comments

johnnybash commented on 2020-12-23 13:15

(kinda) works again. there is something wrong with rsyncing symlinks, so you need to run makepkg at least twice!

Opvolger commented on 2020-12-22 20:38

Your package is not working anymore, update-to-autobuild.sh is changed ==> Validating source files with sha256sums... update-to-autobuild.sh ... FAILED ==> ERROR: One or more files did not pass the validity check! Failed to build xonotic-autobuild

an input is expected (see last 2 commits): https://gitlab.com/xonotic/xonotic/-/commits/master/misc/tools/rsync-updater/update-to-autobuild.sh

If i edit it to this, its works agian: source=("https://gitlab.com/xonotic/xonotic/-/raw/2d25ba3ea003813c844a6c4a15a6455e0d1a27dd/misc/tools/rsync-updater/update-to-autobuild.sh") sha256sums=('SKIP')

Opvolger commented on 2020-06-15 19:59

Thnx!

johnnybash commented on 2020-06-08 17:17

done

Opvolger commented on 2020-06-07 23:46

Can you add aarch64?

arch=('x86_64' 'aarch64')

I have tested it on my pinebook pro. it is working!

johnnybash commented on 2020-06-03 17:12

the file I got the git revision from isn't there anymore, so I switched to the last official version number. means you need to "downgrade" once to get the newest build.

ekaljuk commented on 2019-05-13 08:25

The GLX-enabled binary is no longer supported by Xonotic, meaning the build fails because the xonotic-linux-glx.sh script does not exist anymore. If the xonotic-glx.desktop file and the associated install and ln -s commands are removed from the PKGBUILD, the build works again. Can this package please be updated?

AlexTalker commented on 2014-02-22 11:08

Updated!

AlexTalker commented on 2014-02-21 13:32

@danielpublic , thanks.

danielpublic commented on 2014-02-15 10:20

rsync is missing from the dependencies. :)