Package Details: xorg-server-common-dev 1.19.99.901-1

Git Clone URL: https://aur.archlinux.org/xorg-server-dev.git (read-only)
Package Base: xorg-server-dev
Description: Xorg server common files - Bleeding edge version
Upstream URL: https://xorg.freedesktop.org
Keywords: X-ABI-EXTENSION_VERSION X-ABI-VIDEODRV_VERSION X-ABI-XINPUT_VERSION x-server
Licenses: custom
Groups: xorg
Conflicts: xorg-server-common
Provides: xorg-server-common=1.19.99.901-1
Submitter: Det
Maintainer: None
Last Packager: Det
Votes: 18
Popularity: 0.000041
First Submitted: 2010-06-27 07:53
Last Updated: 2018-03-06 13:15

Dependencies (52)

Required by (10)

Sources (4)

Latest Comments

Det commented on 2018-04-08 10:18

Weirdest joke.

TheGreatAndyChow commented on 2018-04-08 09:54

The key is expired. Also, https://people.freedesktop.org/~ajax/ seems to comfirm this is legit, but ajax@benzedrine doesn't exactly inspire confidence. I do appreciate the work, but Poe's law applies.

Det commented on 2018-03-06 13:15

[✔] Fix

[✔] Disown

smurfhunter commented on 2018-03-06 13:13

Installing the file fails here:

patching file hw/xfree86/common/xf86Init.c

Hunk #1 succeeded at 76 with fuzz 2.

Hunk #2 FAILED at 299.

Hunk #3 succeeded at 832 (offset -40 lines).

Hunk #4 succeeded at 1342 (offset -50 lines).

Makepkg exits with code 2. Any ideas on how to fix this?

Det commented on 2017-02-15 07:28

Yes, that's due to these:

- xorg-server 1.19.1-3: https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/xorg-server&id=fdb75aee720eedd503a7a0ce819e45a6e13a0705
- nvidia-utils 375.26-3: https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/nvidia-utils&id=8752970c53aee6b6f3c9990c78ba1a5dc1e82ba7

I updated the conflicts=() as well, but you should probably be on [testing] with this anyway.

Teknoman117 commented on 2017-02-15 06:17

So this appears to conflict with the standard nvidia drivers (seems that /usr/lib/xorg/modules/extensions/libglx.so already exists in the filesystem).

PawkyPenguin commented on 2016-11-29 16:05

Hey. I just noticed that xorg-server-1.19.0.tar.bz2 is failing the validity check.

Det commented on 2016-11-06 21:11

Updated + fixed deps.

You need either xf86-input-evdev-git or xf86-input-libinput-git for this:
- https://aur.archlinux.org/packages/xf86-input-evdev-git/
- https://aur.archlinux.org/packages/xf86-input-libinput-git/

HappyTetrahedron commented on 2016-11-06 15:38

There seem to be version conflicts with the xorg input drivers. When installing the compiled packages on a freshly updated system, I get the following:

looking for conflicting packages...
:: xorg-server-dev and xf86-input-evdev are in conflict (X-ABI-XINPUT_VERSION). Remove xf86-input-evdev? [y/N] y
:: xorg-server-dev and xf86-input-libinput are in conflict (X-ABI-XINPUT_VERSION). Remove xf86-input-libinput? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: xorg-server-dev: requires xf86-input-driver

My installed evdev version is 2.10.4-1, libinput version is 0.22.0-1.

HappyTetrahedron commented on 2016-11-06 14:12

Might it be that you're missing a dependency? I got the following error:

configure: error: Package requirements (fixesproto >= 5.0 damageproto >= 1.1 xcmiscproto >= 1.2.0 xtrans >= 1.3.5 bigreqsproto >= 1.1.0 xproto >= 7.0.28 randrproto >= 1.5.0 renderproto >= 0.11 xextproto >= 7.2.99.901 inputproto >= 2.3 kbproto >= 1.0.3 fontsproto >= 2.1.3 pixman-1 >= 0.27.2 videoproto compositeproto >= 0.4 recordproto >= 1.13.99.1 scrnsaverproto >= 1.1 resourceproto >= 1.2.0 xf86driproto >= 2.1.0 glproto >= 1.4.17 dri >= 7.8.0 presentproto >= 1.0 xineramaproto xkbfile pixman-1 >= 0.27.2 xfont2 >= 2.0.0 xau libsystemd >= 209 xshmfence >= 1.1 xdmcp) were not met:

No package 'xfont2' found

I installed 'xfont2-git' from AUR and now it compiles happily.

All comments