Package Details: xorg-server-common-dev 1.19.0-1

Git Clone URL: https://aur.archlinux.org/xorg-server-dev.git (read-only)
Package Base: xorg-server-dev
Description: Xorg server common files - Bleeding edge version
Upstream URL: http://xorg.freedesktop.org
Keywords: X-ABI-EXTENSION_VERSION X-ABI-VIDEODRV_VERSION X-ABI-XINPUT_VERSION x-server
Licenses: custom
Conflicts: xorg-server-common
Provides: xorg-server-common
Submitter: Det
Maintainer: Det
Last Packager: Det
Votes: 18
Popularity: 0.980630
First Submitted: 2010-06-27 07:53
Last Updated: 2016-11-29 16:31

Dependencies (54)

Required by (23)

Sources (4)

Latest Comments

PawkyPenguin commented on 2016-11-29 16:05

Hey. I just noticed that xorg-server-1.19.0.tar.bz2 is failing the validity check.

Det commented on 2016-11-06 21:11

Updated + fixed deps.

You need either xf86-input-evdev-git or xf86-input-libinput-git for this:
- https://aur.archlinux.org/packages/xf86-input-evdev-git/
- https://aur.archlinux.org/packages/xf86-input-libinput-git/

HappyTetrahedron commented on 2016-11-06 15:38

There seem to be version conflicts with the xorg input drivers. When installing the compiled packages on a freshly updated system, I get the following:

looking for conflicting packages...
:: xorg-server-dev and xf86-input-evdev are in conflict (X-ABI-XINPUT_VERSION). Remove xf86-input-evdev? [y/N] y
:: xorg-server-dev and xf86-input-libinput are in conflict (X-ABI-XINPUT_VERSION). Remove xf86-input-libinput? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: xorg-server-dev: requires xf86-input-driver

My installed evdev version is 2.10.4-1, libinput version is 0.22.0-1.

HappyTetrahedron commented on 2016-11-06 14:12

Might it be that you're missing a dependency? I got the following error:

configure: error: Package requirements (fixesproto >= 5.0 damageproto >= 1.1 xcmiscproto >= 1.2.0 xtrans >= 1.3.5 bigreqsproto >= 1.1.0 xproto >= 7.0.28 randrproto >= 1.5.0 renderproto >= 0.11 xextproto >= 7.2.99.901 inputproto >= 2.3 kbproto >= 1.0.3 fontsproto >= 2.1.3 pixman-1 >= 0.27.2 videoproto compositeproto >= 0.4 recordproto >= 1.13.99.1 scrnsaverproto >= 1.1 resourceproto >= 1.2.0 xf86driproto >= 2.1.0 glproto >= 1.4.17 dri >= 7.8.0 presentproto >= 1.0 xineramaproto xkbfile pixman-1 >= 0.27.2 xfont2 >= 2.0.0 xau libsystemd >= 209 xshmfence >= 1.1 xdmcp) were not met:

No package 'xfont2' found

I installed 'xfont2-git' from AUR and now it compiles happily.

Det commented on 2016-10-23 22:01

Fixed.

HappyTetrahedron commented on 2016-10-23 13:33

Heyo, it would seem the file xorg-server-1.18.99.901.tar.bz2 fails the sha256sum validity check.

shoober420 commented on 2016-09-18 18:36

Just in case you decide to upgrade, git versions do not work with libinput because of ABI version mismatches. Only evdev-git can be used with -ignoreABI if you use NVIDIA blob.

Det commented on 2016-04-06 13:39

D'oh, mate.

shoober420 commented on 2016-04-05 22:54

This fails to build because the Firefox patch is already included in the offical X.Org package.

Det commented on 2016-02-21 13:42

Pastebin.

All comments