Package Details: xorg-server-xwayland-notty 1.20.7-1

Git Clone URL: https://aur.archlinux.org/xorg-server-notty.git (read-only, click to copy)
Package Base: xorg-server-notty
Description: run X clients under wayland
Upstream URL: http://xorg.freedesktop.org
Licenses: custom
Conflicts: xorg-server-xwayland
Provides: xorg-server-xwayland
Submitter: lilmike
Maintainer: lilmike
Last Packager: lilmike
Votes: 0
Popularity: 0.000000
First Submitted: 2018-09-27 16:12
Last Updated: 2020-03-22 21:52

Dependencies (40)

Required by (27)

Sources (8)

Latest Comments

gardotd426 commented on 2020-02-13 22:26

I imagine this is probably abandoned, but either way, it fails to build with some cryptic "gl" dependency error. It literally says:

Dependency gl found: NO found 1.2 but need: '>= 9.2.0'
Run-time dependency gl found: NO 

glx/meson.build:35:4: ERROR: Invalid version of dependency, need 'gl' ['>= 9.2.0'] found '1.2'.

A full log can be found at /tmp/makepkg/xorg-server-notty/src/build/meson-logs/meson-log.txt ==> ERROR: A failure occurred in build(). Aborting... Error making: xorg-server-notty (xorg-server-xdmx-notty)

Whatever the hell "gl" is, I have no idea. Does it mean mesa-libgl (mesa)? That would make no sense, since the mesa package I have installed is 19.3.3, not 1.2. Not only that, there's nothing "gl" related installed on my system that's version 1.2 whatsoever. yay -Q | grep -i 1.2 shows nothing. There's nothing in the dependencies on this page or the PKGBUILD that give any hint whatsoever as to what this issue is, and it sure didn't try to pull the dependency itself. libglvnd isn't it, I don't know what the issue is.