Package Details: xournal-git

Git Clone URL: (read-only)
Package Base: xournal-git
Description: Notetaking and sketching application
Upstream URL:
Licenses: GPL
Conflicts: xournal, xournal-image-patched, xournalpp-svn
Provides: xournal
Submitter: The-Compiler
Maintainer: The-Compiler
Last Packager: The-Compiler
Votes: 7
Popularity: 0.017840
First Submitted: 2012-07-03 08:49
Last Updated: 2016-06-07 07:26

Latest Comments

x4fyr commented on 2015-03-16 10:25

update to version 4.8.8. Otherwise tools like yaourt will update over and over again.

orschiro commented on 2014-01-28 06:01


I can confirm it is working again. Thanks for maintaining!

The-Compiler commented on 2014-01-28 05:44

Using "./" instead of "autoreconf -i" in the PKGBUILD fixed that. I have no idea what this all means exactly (don't really know autotools) but it builds again now :)

orschiro commented on 2014-01-27 21:49

Does someone else also get a build error recently?

configure: WARNING: 'missing' script is too old or missing
config.status: error: cannot find input file: `po/'

The-Compiler commented on 2013-05-23 08:09

Thanks, updated it now.

On a sidenote: My patch didn't get included, but another one, because it was a smaller changeset. So it's only a question of time until autotools get updated again (and things that are deprecated for ages and not fixed with the other patch start to break) and we can do the same stuff another time.

techwiz commented on 2013-05-17 16:26

I think your patch finally got pushed upstream and you need to update the repo in the PKGBUILD to


The-Compiler commented on 2013-03-04 15:46

Sorry it took me so long, but I wrote a patch to fix this and included it into the PKGBUILD.

I also submitted it upstream ages ago, but they didn't accept it yet for stupid reasons. We'll see.

Anonymous comment on 2013-01-27 17:18

Doesn't build with automake-1.13.

Compiles when downgrading automake to 1.12 version (as of xournal-git 20120913-1).

janhieber commented on 2013-01-14 13:04

Doesn't build anymore:

==> Starting build...
Cloning into '/home/jan/.pkgbuilds/xournal-git/src/xournal-build'...
aclocal: warning: autoconf input should be named '', not '' error: 'AM_CONFIG_HEADER': this macro is obsolete.
You should use the 'AC_CONFIG_HEADERS' macro instead.
/usr/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded from... the top level
autom4te: /usr/bin/m4 failed with exit status: 1
aclocal: error: echo failed with exit status: 1
autoreconf: aclocal failed with exit status: 1

The-Compiler commented on 2012-07-03 21:02

@conan That's odd. While I also get the error message, it builds perfectly fine both on my machine and in a vanilla VM I just set up for testing.

Anyways, I did some updates with pkgrel=2:
- I added gettext to makedepends. According to the docs it is needed to build. Also, all but one .m4-files you mentioned is in gettext. Even if it's installed, the message doesn't go away, but it doesn't hurt I guess.
- I added gtk2 to depends, also because it's in the docs
- I replaced "./" by "autoreconf -i" as this seems to be the preferred way to do it
- I added "desktop-install" to the make line and an install-file which updates the caches (taken from the xournal abs PKGBUILD)

All comments