Package Details: xplanetfx 2.6.9-1

Git Clone URL: https://aur.archlinux.org/xplanetfx.git (read-only)
Package Base: xplanetfx
Description: xplanet earth with realistic clouding and lightning effects as your wallpaper.
Upstream URL: http://mein-neues-blog.de/xplanetfx/
Licenses: custom
Submitter: kwirkie
Maintainer: bidulock
Last Packager: bidulock
Votes: 60
Popularity: 0.562511
First Submitted: 2010-11-16 22:10
Last Updated: 2016-07-27 06:48

Latest Comments

jamesan commented on 2015-09-28 22:41

Upstream version incremented as of May 29, 2015. I successfully built, installed, and am currently using the newer version by making the following changes to the PKGBUILD variables:

pkgver=2.6.6
source=("http://repository.mein-neues-blog.de:9000/archive/$pkgname-${pkgver}_all.tar.gz")
md5sums=('4013622571d658f9cb8dc1c1b9186b79')

jamesan commented on 2015-09-28 22:39

Upstream version incremented as of May 29, 2015:

pkgver=2.6.6
source=("http://repository.mein-neues-blog.de:9000/archive/$pkgname-${pkgver}_all.tar.gz")
md5sum=('4013622571d658f9cb8dc1c1b9186b79')

jamesan commented on 2015-09-28 22:37

Upstream version incremented as of May 29, 2015:

pkgver=2.6.6
sources=("http://repository.mein-neues-blog.de:9000/archive/$pkgname-$pkgver_all.tar.gz")
md5sum=('4013622571d658f9cb8dc1c1b9186b79')

ertua commented on 2015-05-25 11:54

pkgver=2.6.5
md5sums=('99cf8b65a7a69f573103e91473688838')

kwirkie commented on 2015-03-06 22:17

I'm no longer using this, making it hard for me to test. Welcome someone to take over. Please note the dependency changes: http://mein-neues-blog.de/2015/03/05/xplanetfx-2-6-3-get-rid-of-perl/

jawz101 commented on 2013-12-30 03:12

they're up to version 2.5.23

Fandekasp commented on 2012-11-16 10:25

ahh ok . Not a big deal, let's wait :)

kwirkie commented on 2012-11-16 10:01

Fandekasp - It appears the xplanetFX site is down. I'm not aware of any mirrors, so we'll have to wait until is back online.

Fandekasp commented on 2012-11-15 23:37

Hi,

I'm getting an error when trying to upgrade xplanetfx:

==> ERROR: Failure while downloading xplanetfx-2.5.7_all.tar.gz
Aborting...
The build failed.

Anonymous comment on 2012-08-05 23:29

It works. Thanks!

kwirkie commented on 2012-08-05 16:47

Strange. The site still seems to be up, but seems the DNS server may be down. The following command should allow you to download the file still:
curl -O --resolve repository.mein-neues-blog.de:9000:88.198.27.39 "http://repository.mein-neues-blog.de:9000/archive/xplanetfx-2.4.13_all.tar.gz"

Anonymous comment on 2012-08-04 22:24

mein-neues-blog.de is down. Are there any mirrors? I couldn't find any.

kwirkie commented on 2012-01-28 17:48

Thanks ianux!

ianux commented on 2012-01-28 17:16

2.4.5 is out. libnotify is in optdepends.

kwirkie commented on 2011-05-06 20:28

josephgbr: Thanks for the report. I've checked the package and the dependencies are valid. The empty directories seem to be the ones which are present and utilised in ~/.xplanetFX, although why they exist in /usr/share/xplanetFX isn't apparent, they are as provided from source and cause no issues.

rafaelff commented on 2011-05-04 22:46

It could be nothing, but namcap returned some warnings.

xplanetfx W: Directory (usr/share/xplanetFX/cache) is empty
xplanetfx W: Directory (usr/share/xplanetFX/logs) is empty
xplanetfx W: Directory (usr/share/xplanetFX/overlays) is empty
xplanetfx W: Directory (usr/share/xplanetFX/thumbcache) is empty
xplanetfx W: Directory (usr/share/xplanetFX/output) is empty
xplanetfx W: Dependency included and not needed ('imagemagick')
xplanetfx W: Dependency included and not needed ('xplanet')
xplanetfx W: Dependency included and not needed ('perl-libwww')
xplanetfx W: Dependency included and not needed ('bc')

kwirkie commented on 2011-05-04 19:22

misterxyx: I reported the issue on the author's blog and he has now fixed it using the gsettings command you had in your replacement. The author hasn't tested it yet, so hopefully it will work.

Leon23: version now uploaded, you just beat me to it ;)

FredericChopin commented on 2011-05-04 19:12

Version 2.2.21 works also with Gnome3.

Anonymous comment on 2011-05-03 07:21

If xplanetFX doesn't work with Gnome3, replace the /usr/bin/xplanetFX Script with this one: http://pastebin.com/4PuCCAE5

This script uses gsettings instead of gconftool, for setting the wallpaper.

HF

Anonymous comment on 2011-02-05 12:08

Oh yeah, now, it's good. The link works ;)

kwirkie commented on 2011-02-02 19:15

Lonigan: I've checked the links and have had no issues downloading... Maybe the server was down, might be worth trying again.

Anonymous comment on 2011-02-02 00:04

I think the link to download don't work :S

kwirkie commented on 2011-01-09 10:44

cmudik: Thanks, bc now added to dependencies.

cmudik commented on 2011-01-08 11:11

I think bc should be in dependencies. Without this package cloud rendering didn't work for me. http://www.archlinux.org/packages/extra/i686/bc/

kwirkie commented on 2011-01-07 18:22

Update: python(2) is now a optional dependency only (via pygtk) for users intending to utilise the GUI.
perlmagick added as an optional dependency to validate cloud images (available at http://aur.archlinux.org/packages.php?ID=40856)

kwirkie commented on 2011-01-05 22:28

The main script requires python or python2, whereas the GUI requires python2 (although this dependency is satisfied to the optional dependency pygtk for the GUI). I'm unsure on the best approach for this. It wouldn't be appropriate to install python2 if the user does not intend to use the GUI and they have python that satisfies the dependency. Equally why would someone want to install python if they've have python2 and do not require python for anything else. As python is Arch Linux primary version of 'python' it should be left as the dependency.
(Note that the requirement for 'python' in the main script is only as a random number generator. I'll propose to the developer to look at an alternative method for this that would simplifiy the need for 'python' as just an optional dependency satisfied by pygtk.)

Madek commented on 2011-01-05 04:05

this depend to python2 instead python

kwirkie commented on 2010-12-21 22:30

oliwer: Thanks for the feedback, greatly appreciated. I've now added the additional dependency and replaced 'gconftool' with 'gconftool-2'.

oliwer commented on 2010-12-21 19:30

Thanks for the package. You might also add perl-libwww which is required to download the clouds.

Also, under GNOME, xplanetFX uses gconftool to set the background, but this fails on archlinux since we only have gconftool-2. Either provide a symlink or path xplanetFX to use gconftool-2.